]> git.pld-linux.org Git - packages/libimobiledevice.git/blob - libimobiledevice.spec
- up to 1.0.3
[packages/libimobiledevice.git] / libimobiledevice.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4
5 Summary:        Library for connecting to mobile devices
6 Summary(pl.UTF-8):      Biblioteka do łączenia się z urządzeniami mobilnymi
7 Name:           libimobiledevice
8 Version:        1.0.3
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://www.libimobiledevice.org/downloads/%{name}-%{version}.tar.bz2
13 # Source0-md5:  68e68b5c2bea3ad99917add839d32cb2
14 URL:            http://www.libimobiledevice.org/
15 BuildRequires:  autoconf >= 2.61
16 BuildRequires:  automake
17 BuildRequires:  glib2-devel >= 1:2.14.1
18 BuildRequires:  gnutls-devel >= 1.6.3
19 BuildRequires:  libgcrypt-devel
20 BuildRequires:  libplist-devel >= 0.15
21 BuildRequires:  libtasn1-devel >= 1.1
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  swig-python >= 1.3.21
25 BuildRequires:  usbmuxd-devel >= 0.1.4
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 libimobiledevice is a library for connecting to mobile devices.
30
31 %description -l pl.UTF-8
32 libimobiledevice jest biblioteką do łączenia się z urządzeniami
33 mobilnymi.
34
35 %package devel
36 Summary:        Header files for libimobiledevice library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libimobiledevice
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       glib2-devel >= 1:2.14.1
41 Requires:       gnutls-devel >= 1.6.3
42 Requires:       libplist-devel >= 0.15
43 Requires:       libtasn1-devel >= 1.1
44 Requires:       usbmuxd-devel >= 0.1.4
45
46 %description devel
47 Header files for libimobiledevice library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki libimobiledevice.
51
52 %package static
53 Summary:        Static libimobiledevice library
54 Summary(pl.UTF-8):      Statyczna biblioteka libimobiledevice
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libimobiledevice library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libimobiledevice.
63
64 %package -n python-imobiledevice
65 Summary:        libimobiledevice Python bindings
66 Summary(pl.UTF-8):      Wiązania libimobiledevice dla Pythona
67 Group:          Development/Languages/Python
68 Requires:       %{name} = %{version}-%{release}
69
70 %description -n python-imobiledevice
71 libimobiledevice Python bindings.
72
73 %description -n python-imobiledevice -l pl.UTF-8
74 Wiązania libimobiledevice dla Pythona.
75
76 %prep
77 %setup -q
78
79 %build
80 %{__libtoolize}
81 %{__aclocal} -I m4
82 %{__autoconf}
83 %{__autoheader}
84 %{__automake}
85 %configure \
86         %{!?with_static_libs:--disable-static} \
87         --disable-silent-rules
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92
93 %{__make} install \
94         DESTDIR=$RPM_BUILD_ROOT
95
96 rm -f $RPM_BUILD_ROOT%{py_sitedir}/imobiledevice/*.{a,la}
97
98 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
99 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
100 %py_postclean
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post   -p /sbin/ldconfig
106 %postun -p /sbin/ldconfig
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS NEWS README
111 %attr(755,root,root) %{_bindir}/idevicebackup
112 %attr(755,root,root) %{_bindir}/idevice_id
113 %attr(755,root,root) %{_bindir}/ideviceimagemounter
114 %attr(755,root,root) %{_bindir}/ideviceinfo
115 %attr(755,root,root) %{_bindir}/idevicepair
116 %attr(755,root,root) %{_bindir}/idevicescreenshot
117 %attr(755,root,root) %{_bindir}/idevicesyslog
118 %attr(755,root,root) %{_libdir}/libimobiledevice.so.*.*.*
119 %attr(755,root,root) %ghost %{_libdir}/libimobiledevice.so.1
120 %{_mandir}/man1/idevice_id.1*
121 %{_mandir}/man1/idevicebackup.1*
122 %{_mandir}/man1/ideviceimagemounter.1*
123 %{_mandir}/man1/ideviceinfo.1*
124 %{_mandir}/man1/idevicescreenshot.1*
125 %{_mandir}/man1/idevicesyslog.1*
126
127 %files devel
128 %defattr(644,root,root,755)
129 %doc docs/html/
130 %attr(755,root,root) %{_libdir}/libimobiledevice.so
131 %{_libdir}/libimobiledevice.la
132 %{_includedir}/libimobiledevice
133 %{_pkgconfigdir}/libimobiledevice-1.0.pc
134
135 %if %{with static_libs}
136 %files static
137 %defattr(644,root,root,755)
138 %{_libdir}/libimobiledevice.a
139 %endif
140
141 %files -n python-imobiledevice
142 %defattr(644,root,root,755)
143 %dir %{py_sitedir}/imobiledevice
144 %attr(755,root,root) %{py_sitedir}/imobiledevice/_imobiledevice.so
145 %{py_sitedir}/imobiledevice/*.py[co]
This page took 0.108805 seconds and 4 git commands to generate.