]> git.pld-linux.org Git - packages/libidn.git/blob - libidn.spec
- added without python bcond
[packages/libidn.git] / libidn.spec
1 # TODO:
2 # - prepare package with web-files and java from contrib
3 #
4 # Conditional build:
5 %bcond_with     java    # build Java implementation
6 %bcond_without  python  # don't build python interface
7 #
8 Summary:        Internationalized string processing library
9 Summary(pl):    Biblioteka do przetwarzania umiêdzynarodowionych ³añcuchów
10 Name:           libidn
11 Version:        0.5.20
12 Release:        1
13 License:        LGPL v2.1
14 Group:          Libraries
15 Source0:        http://josefsson.org/libidn/releases/%{name}-%{version}.tar.gz
16 # Source0-md5:  b8ccbdf43b8da1722a6773c4e426d059
17 Patch0:         %{name}-info.patch
18 Patch1:         %{name}-python.patch
19 URL:            http://www.gnu.org/software/libidn/
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake >= 1:1.9
22 BuildRequires:  gettext-devel >= 0.14.1
23 %{?with_java:BuildRequires:     jdk}
24 BuildRequires:  libtool >= 2:1.5
25 BuildRequires:  perl-base
26 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
27 BuildRequires:  texinfo >= 4.7
28 Requires(post,postun):  /sbin/ldconfig
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 # is it correct?
32 %define         _emacs_lispdir  %{_datadir}/emacs/site-lisp
33
34 %description
35 GNU Libidn is an implementation of the Stringprep, Punycode and IDNA
36 specifications defined by the IETF Internationalized Domain Names
37 (IDN) working group, used for internationalized domain names.
38
39 %description -l pl
40 GNU Libidn to implementacja specyfikacji Stringprep, Punycode i IDNA
41 zdefiniowanych przez grupê robocz± IETF Internationalized Domain Names
42 (IDN), zajmuj±c± siê umiêdzynarodowionymi nazwami domen.
43
44 %package devel
45 Summary:        Header files for libidn library
46 Summary(pl):    Pliki nag³ówkowe biblioteki libidn
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for libidn library.
52
53 %description devel -l pl
54 Pliki nag³ówkowe biblioteki libidn.
55
56 %package static
57 Summary:        Static libidn library
58 Summary(pl):    Statyczna biblioteka libidn
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static libidn library.
64
65 %description static -l pl
66 Statyczna biblioteka libidn.
67
68 %package -n emacs-libidn-pkg
69 Summary:        IDN support files for emacs
70 Summary(pl):    Obs³uga IDN dla emacsa
71 Group:          Applications/Editors/Emacs
72 Requires:       %{name} = %{version}-%{release}
73
74 %description -n emacs-libidn-pkg
75 IDN support files for emacs.
76
77 %description -n emacs-libidn-pkg -l pl
78 Obs³uga IDN dla emacsa.
79
80 %package -n java-libidn
81 Summary:        Java implementation of libidn
82 Summary(pl):    Implementacja libidn w Javie
83 Group:          Libraries
84 Requires:       jre
85
86 %description -n java-libidn
87 Java implementation of libidn (internationalized domain names
88 library).
89
90 %description -n java-libidn -l pl
91 Implementacja libidn (biblioteki umiêdzynarodowionych nazw domen) w
92 Javie.
93
94 %package -n python-idn
95 Summary:        Python interface to libidn
96 Summary(pl):    Pythonowy interfejs do libidn
97 Group:          Libraries/Python
98 Requires:       %{name} = %{version}-%{release}
99 %pyrequires_eq  python-libs
100
101 %description -n python-idn
102 Python interface to libidn (internationalized domain names library).
103
104 %description -n python-idn -l pl
105 Pythonowy interfejs do libidn (biblioteki umiêdzynarodowionych nazw
106 domen).
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112
113 %build
114 %{__gettextize}
115 %{__libtoolize}
116 %{__aclocal} -I m4 -I gl/m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         %{?with_java:--enable-java} \
122         --with-lispdir=%{_emacs_lispdir}
123
124 %{__make}
125
126 %if %{with python}
127 %{__make} -C contrib/idn-python \
128         INCLUDE="/usr/include/python2.4 -I/usr/include/python2.3 %{rpmcflags} -I../../lib -L../../lib/.libs"
129 %endif
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %if %{with python}
138 install -D contrib/idn-python/idn.so $RPM_BUILD_ROOT%{py_sitedir}/idn.so
139 %endif
140
141 %find_lang %{name}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post
147 /sbin/ldconfig
148 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
149
150 %postun
151 /sbin/ldconfig
152 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
153
154 %files -f %{name}.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS ChangeLog FAQ NEWS README* THANKS TODO doc/libidn.html contrib
157 %attr(755,root,root) %{_bindir}/idn
158 %attr(755,root,root) %{_libdir}/libidn.so.*.*.*
159 %{_mandir}/man1/idn.1*
160 %{_infodir}/libidn.info*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libidn.so
165 %{_libdir}/libidn.la
166 %{_includedir}/*.h
167 %{_pkgconfigdir}/libidn.pc
168 %{_mandir}/man3/*
169
170 %files static
171 %defattr(644,root,root,755)
172 %{_libdir}/libidn.a
173
174 %files -n emacs-libidn-pkg
175 %defattr(644,root,root,755)
176 %{_emacs_lispdir}/*.el
177
178 %if %{with java}
179 %files -n java-libidn
180 %defattr(644,root,root,755)
181 %{_datadir}/java/libidn*.jar
182 %endif
183
184 %if %{with python}
185 %files -n python-idn
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{py_sitedir}/idn.so
188 %endif
This page took 0.070253 seconds and 4 git commands to generate.