]> git.pld-linux.org Git - packages/libidn.git/blob - libidn.spec
- updated to 0.4.9
[packages/libidn.git] / libidn.spec
1 # TODO:
2 # - prepare package with web-files and java from contrib
3 #
4 # Conditional build:
5 %bcond_with     java    # build Java implementation
6 #
7 Summary:        Internationalized string processing library
8 Summary(pl):    Biblioteka do przetwarzania umiêdzynarodowionych ³añcuchów
9 Name:           libidn
10 Version:        0.4.9
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        http://josefsson.org/libidn/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  cc87a7bdce60a6e229f0984ca551e273
16 Patch0:         %{name}-info.patch
17 Patch1:         %{name}-python.patch
18 URL:            http://www.gnu.org/software/libidn/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake >= 1.8
21 BuildRequires:  gettext-devel >= 0.14.1
22 %{?with_java:BuildRequires:     jdk}
23 BuildRequires:  libtool >= 2:1.5
24 BuildRequires:  python-devel
25 BuildRequires:  texinfo >= 4.7
26 Requires(post,postun):  /sbin/ldconfig
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 # is it correct?
30 %define         _emacs_lispdir  %{_datadir}/emacs/site-lisp
31
32 %description
33 GNU Libidn is an implementation of the Stringprep, Punycode and IDNA
34 specifications defined by the IETF Internationalized Domain Names
35 (IDN) working group, used for internationalized domain names.
36
37 %description -l pl
38 GNU Libidn to implementacja specyfikacji Stringprep, Punycode i IDNA
39 zdefiniowanych przez grupê robocz± IETF Internationalized Domain Names
40 (IDN), zajmuj±c± siê umiêdzynarodowionymi nazwami domen.
41
42 %package devel
43 Summary:        Header files for libidn library
44 Summary(pl):    Pliki nag³ówkowe biblioteki libidn
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47
48 %description devel
49 Header files for libidn library.
50
51 %description devel -l pl
52 Pliki nag³ówkowe biblioteki libidn.
53
54 %package static
55 Summary:        Static libidn library
56 Summary(pl):    Statyczna biblioteka libidn
57 Group:          Development/Libraries
58 Requires:       %{name}-devel = %{version}-%{release}
59
60 %description static
61 Static libidn library.
62
63 %description static -l pl
64 Statyczna biblioteka libidn.
65
66 %package -n emacs-libidn-pkg
67 Summary:        IDN support files for emacs
68 Summary(pl):    Obs³uga IDN dla emacsa
69 Group:          Applications/Editors/Emacs
70 Requires:       %{name} = %{version}-%{release}
71
72 %description -n emacs-libidn-pkg
73 IDN support files for emacs.
74
75 %description -n emacs-libidn-pkg -l pl
76 Obs³uga IDN dla emacsa.
77
78 %package -n java-libidn
79 Summary:        Java implementation of libidn
80 Summary(pl):    Implementacja libidn w Javie
81 Group:          Libraries
82 Requires:       jre
83
84 %description -n java-libidn
85 Java implementation of libidn (internationalized domain names
86 library).
87
88 %description -n java-libidn -l pl
89 Implementacja libidn (biblioteki umiêdzynarodowionych nazw domen) w
90 Javie.
91
92 %package -n python-idn
93 Summary:        Python interface to libidn
94 Summary(pl):    Pythonowy interfejs do libidn
95 Group:          Libraries/Python
96 Requires:       %{name} = %{version}-%{release}
97 %pyrequires_eq  python-lib
98
99 %description -n python-idn
100 Python interface to libidn (internationalized domain names library).
101
102 %description -n python-idn -l pl
103 Pythonowy interfejs do libidn (biblioteki umiêdzynarodowionych nazw
104 domen).
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110
111 %build
112 %{__gettextize}
113 %{__libtoolize}
114 %{__aclocal} -I m4
115 %{__autoconf}
116 %{__autoheader}
117 %{__automake}
118 %configure \
119         %{?with_java:--enable-java} \
120         --with-lispdir=%{_emacs_lispdir}
121
122 %{__make}
123
124 %{__make} -C contrib/idn-python \
125         INCLUDE="/usr/include/python2.3 %{rpmcflags} -I../../lib -L../../lib/.libs"
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 install -D contrib/idn-python/idn.so $RPM_BUILD_ROOT%{py_sitedir}/idn.so
134
135 %find_lang %{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 /sbin/ldconfig
142 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
143
144 %postun
145 /sbin/ldconfig
146 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc AUTHORS ChangeLog FAQ NEWS README* THANKS TODO doc/libidn.html contrib
151 %attr(755,root,root) %{_bindir}/idn
152 %attr(755,root,root) %{_libdir}/libidn.so.*.*.*
153 %{_mandir}/man1/idn.1*
154 %{_infodir}/libidn.info*
155
156 %files devel
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_libdir}/libidn.so
159 %{_libdir}/libidn.la
160 %{_includedir}/*.h
161 %{_pkgconfigdir}/libidn.pc
162 %{_mandir}/man3/*
163
164 %files static
165 %defattr(644,root,root,755)
166 %{_libdir}/libidn.a
167
168 %files -n emacs-libidn-pkg
169 %defattr(644,root,root,755)
170 %{_emacs_lispdir}/*.el
171
172 %if %{with java}
173 %files -n java-libidn
174 %defattr(644,root,root,755)
175 %{_datadir}/java/libidn.jar
176 %endif
177
178 %files -n python-idn
179 %defattr(644,root,root,755)
180 %attr(755,root,root) %{py_sitedir}/idn.so
This page took 0.923115 seconds and 4 git commands to generate.