]> git.pld-linux.org Git - packages/libidn.git/blob - libidn.spec
- updated to 1.10
[packages/libidn.git] / libidn.spec
1 # TODO:
2 # - prepare package with web-files and java from contrib
3 #
4 # Conditional build:
5 %bcond_without  dotnet  # don't build C# binding
6 %bcond_without  java    # don't build Java implementation
7 %bcond_without  python  # don't build python interface
8 #
9 %ifnarch %{ix86} %{x8664} alpha arm hppa ppc s390 s390x sparc sparcv9 sparc64
10 %undefine       with_dotnet
11 %endif
12 %ifarch i386
13 %undefine       with_dotnet
14 %endif
15 Summary:        Internationalized string processing library
16 Summary(pl.UTF-8):      Biblioteka do przetwarzania umiędzynarodowionych łańcuchów
17 Name:           libidn
18 Version:        1.10
19 Release:        1
20 License:        LGPL v2.1+ (library), GPL v3+ (utilities)
21 Group:          Libraries
22 Source0:        http://ftp.gnu.org/gnu/libidn/%{name}-%{version}.tar.gz
23 # Source0-md5:  142c21f2bd922c84c4a3c3d469bbc596
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-python.patch
26 URL:            http://www.gnu.org/software/libidn/
27 BuildRequires:  autoconf >= 2.61
28 BuildRequires:  automake >= 1:1.10
29 %{?with_java:BuildRequires:     gcc-java}
30 BuildRequires:  gettext-devel >= 0.17
31 %{?with_java:BuildRequires:     gjdoc}
32 BuildRequires:  libtool >= 2:1.5
33 %{?with_dotnet:BuildRequires:   mono}
34 BuildRequires:  perl-base
35 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
36 %{?with_python:BuildRequires:   rpm-pythonprov}
37 BuildRequires:  rpmbuild(macros) >= 1.384
38 BuildRequires:  texinfo >= 4.7
39 Requires(post,postun):  /sbin/ldconfig
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 # is it correct?
43 %define         _emacs_lispdir  %{_datadir}/emacs/site-lisp
44
45 %description
46 GNU Libidn is an implementation of the Stringprep, Punycode and IDNA
47 specifications defined by the IETF Internationalized Domain Names
48 (IDN) working group, used for internationalized domain names.
49
50 %description -l pl.UTF-8
51 GNU Libidn to implementacja specyfikacji Stringprep, Punycode i IDNA
52 zdefiniowanych przez grupę roboczą IETF Internationalized Domain Names
53 (IDN), zajmującą się umiędzynarodowionymi nazwami domen.
54
55 %package devel
56 Summary:        Header files for libidn library
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libidn
58 License:        LGPL v2.1+
59 Group:          Development/Libraries
60 Requires:       %{name} = %{version}-%{release}
61
62 %description devel
63 Header files for libidn library.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe biblioteki libidn.
67
68 %package static
69 Summary:        Static libidn library
70 Summary(pl.UTF-8):      Statyczna biblioteka libidn
71 License:        LGPL v2.1+
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static libidn library.
77
78 %description static -l pl.UTF-8
79 Statyczna biblioteka libidn.
80
81 %package -n dotnet-libidn
82 Summary:        C# binding for libidn
83 Summary(pl.UTF-8):      Wiązanie C# dla libidn
84 License:        LGPL v2.1+
85 Group:          Libraries
86 Requires:       %{name} = %{version}-%{release}
87
88 %description -n dotnet-libidn
89 C# binding for libidn.
90
91 %description -n dotnet-libidn -l pl.UTF-8
92 Wiązanie C# dla libidn.
93
94 %package -n emacs-libidn-pkg
95 Summary:        IDN support files for emacs
96 Summary(pl.UTF-8):      Obsługa IDN dla emacsa
97 License:        GPL v3+
98 Group:          Applications/Editors/Emacs
99 Requires:       %{name} = %{version}-%{release}
100
101 %description -n emacs-libidn-pkg
102 IDN support files for emacs.
103
104 %description -n emacs-libidn-pkg -l pl.UTF-8
105 Obsługa IDN dla emacsa.
106
107 %package -n java-libidn
108 Summary:        Java implementation of libidn
109 Summary(pl.UTF-8):      Implementacja libidn w Javie
110 License:        LGPL v2.1+
111 Group:          Libraries
112 Requires:       jre
113
114 %description -n java-libidn
115 Java implementation of libidn (internationalized domain names
116 library).
117
118 %description -n java-libidn -l pl.UTF-8
119 Implementacja libidn (biblioteki umiędzynarodowionych nazw domen) w
120 Javie.
121
122 %package -n python-idn
123 Summary:        Python interface to libidn
124 Summary(pl.UTF-8):      Pythonowy interfejs do libidn
125 License:        LGPL v2.1+
126 Group:          Libraries/Python
127 Requires:       %{name} = %{version}-%{release}
128 %pyrequires_eq  python-libs
129
130 %description -n python-idn
131 Python interface to libidn (internationalized domain names library).
132
133 %description -n python-idn -l pl.UTF-8
134 Pythonowy interfejs do libidn (biblioteki umiędzynarodowionych nazw
135 domen).
136
137 %prep
138 %setup -q
139 %patch0 -p1
140 %patch1 -p1
141
142 rm -f po/stamp-po
143
144 %build
145 %{__gettextize}
146 %{__libtoolize}
147 %{__aclocal} -I m4 -I gl/m4 -I lib/gl/m4
148 %{__autoconf}
149 %{__autoheader}
150 %{__automake}
151 JAR=%{_bindir}/fastjar \
152 %configure \
153         %{?with_dotnet:--enable-csharp=mono}%{!?with_dotnet:--disable-csharp} \
154         %{?with_java:--enable-java} \
155         --with-lispdir=%{_emacs_lispdir}
156
157 %{__make}
158
159 %if %{with python}
160 %{__make} -C contrib/idn-python \
161         INCLUDE="%{py_incdir} %{rpmcflags} -I../../lib -L../../lib/.libs"
162 %endif
163
164 %install
165 rm -rf $RPM_BUILD_ROOT
166
167 %{__make} install \
168         DESTDIR=$RPM_BUILD_ROOT
169
170 %if %{with python}
171 install -D contrib/idn-python/idn.so $RPM_BUILD_ROOT%{py_sitedir}/idn.so
172 %endif
173
174 %find_lang %{name}
175
176 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
177
178 %clean
179 rm -rf $RPM_BUILD_ROOT
180
181 %post
182 /sbin/ldconfig
183 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
184
185 %postun
186 /sbin/ldconfig
187 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
188
189 %files -f %{name}.lang
190 %defattr(644,root,root,755)
191 %doc AUTHORS ChangeLog FAQ NEWS README* THANKS TODO doc/libidn.html contrib
192 %attr(755,root,root) %{_bindir}/idn
193 %attr(755,root,root) %{_libdir}/libidn.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/libidn.so.11
195 %{_mandir}/man1/idn.1*
196 %{_infodir}/libidn.info*
197 %{_infodir}/libidn-*.png
198
199 %files devel
200 %defattr(644,root,root,755)
201 %attr(755,root,root) %{_libdir}/libidn.so
202 %{_libdir}/libidn.la
203 %{_includedir}/idn-*.h
204 %{_includedir}/idna.h
205 %{_includedir}/pr29.h
206 %{_includedir}/punycode.h
207 %{_includedir}/stringprep.h
208 %{_includedir}/tld.h
209 %{_pkgconfigdir}/libidn.pc
210 %{_mandir}/man3/idna_*.3*
211 %{_mandir}/man3/pr29_*.3*
212 %{_mandir}/man3/punycode_*.3*
213 %{_mandir}/man3/stringprep*.3*
214 %{_mandir}/man3/tld_*.3*
215
216 %files static
217 %defattr(644,root,root,755)
218 %{_libdir}/libidn.a
219
220 %if %{with dotnet}
221 %files -n dotnet-libidn
222 %defattr(644,root,root,755)
223 # why not in gac? does it work here?
224 %{_libdir}/Libidn.dll
225 %endif
226
227 %files -n emacs-libidn-pkg
228 %defattr(644,root,root,755)
229 %{_emacs_lispdir}/*.el
230
231 %if %{with java}
232 %files -n java-libidn
233 %defattr(644,root,root,755)
234 %{_datadir}/java/libidn*.jar
235 %endif
236
237 %if %{with python}
238 %files -n python-idn
239 %defattr(644,root,root,755)
240 %attr(755,root,root) %{py_sitedir}/idn.so
241 %endif
This page took 0.060165 seconds and 4 git commands to generate.