]> git.pld-linux.org Git - packages/libidn.git/blob - libidn.spec
- updated to 0.6.0 (with C# binding, where mono available - maybe use pnet elsewhere?)
[packages/libidn.git] / libidn.spec
1 # TODO:
2 # - prepare package with web-files and java from contrib
3 #
4 # Conditional build:
5 %bcond_without  dotnet  # don't build C# binding
6 %bcond_with     java    # build Java implementation
7 %bcond_without  python  # don't build python interface
8 #
9 %ifnarch %{ix86} %{x8664} arm hppa ppc s390 s390x
10 %undefine       with_dotnet
11 %endif
12 %ifarch i386
13 %undefine       with_dotnet
14 %endif
15 Summary:        Internationalized string processing library
16 Summary(pl):    Biblioteka do przetwarzania umiêdzynarodowionych ³añcuchów
17 Name:           libidn
18 Version:        0.6.0
19 Release:        1
20 License:        LGPL v2.1
21 Group:          Libraries
22 Source0:        http://josefsson.org/libidn/releases/%{name}-%{version}.tar.gz
23 # Source0-md5:  4991ab5ce647c89fa4812d9a1700a8f6
24 Patch0:         %{name}-info.patch
25 Patch1:         %{name}-python.patch
26 URL:            http://www.gnu.org/software/libidn/
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake >= 1:1.9
29 BuildRequires:  gettext-devel >= 0.14.1
30 %{?with_java:BuildRequires:     jdk}
31 BuildRequires:  libtool >= 2:1.5
32 %{?with_dotnet:BuildRequires:   mono}
33 BuildRequires:  perl-base
34 %{?with_python:BuildRequires:   python-devel >= 1:2.3}
35 BuildRequires:  texinfo >= 4.7
36 Requires(post,postun):  /sbin/ldconfig
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 # is it correct?
40 %define         _emacs_lispdir  %{_datadir}/emacs/site-lisp
41
42 %description
43 GNU Libidn is an implementation of the Stringprep, Punycode and IDNA
44 specifications defined by the IETF Internationalized Domain Names
45 (IDN) working group, used for internationalized domain names.
46
47 %description -l pl
48 GNU Libidn to implementacja specyfikacji Stringprep, Punycode i IDNA
49 zdefiniowanych przez grupê robocz± IETF Internationalized Domain Names
50 (IDN), zajmuj±c± siê umiêdzynarodowionymi nazwami domen.
51
52 %package devel
53 Summary:        Header files for libidn library
54 Summary(pl):    Pliki nag³ówkowe biblioteki libidn
55 Group:          Development/Libraries
56 Requires:       %{name} = %{version}-%{release}
57
58 %description devel
59 Header files for libidn library.
60
61 %description devel -l pl
62 Pliki nag³ówkowe biblioteki libidn.
63
64 %package static
65 Summary:        Static libidn library
66 Summary(pl):    Statyczna biblioteka libidn
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static libidn library.
72
73 %description static -l pl
74 Statyczna biblioteka libidn.
75
76 %package -n dotnet-libidn
77 Summary:        C# binding for libidn
78 Summary(pl):    Wi±zanie C# dla libidn
79 Group:          Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description -n dotnet-libidn
83 C# binding for libidn.
84
85 %description -n dotnet-libidn -l pl
86 Wi±zanie C# dla libidn.
87
88 %package -n emacs-libidn-pkg
89 Summary:        IDN support files for emacs
90 Summary(pl):    Obs³uga IDN dla emacsa
91 Group:          Applications/Editors/Emacs
92 Requires:       %{name} = %{version}-%{release}
93
94 %description -n emacs-libidn-pkg
95 IDN support files for emacs.
96
97 %description -n emacs-libidn-pkg -l pl
98 Obs³uga IDN dla emacsa.
99
100 %package -n java-libidn
101 Summary:        Java implementation of libidn
102 Summary(pl):    Implementacja libidn w Javie
103 Group:          Libraries
104 Requires:       jre
105
106 %description -n java-libidn
107 Java implementation of libidn (internationalized domain names
108 library).
109
110 %description -n java-libidn -l pl
111 Implementacja libidn (biblioteki umiêdzynarodowionych nazw domen) w
112 Javie.
113
114 %package -n python-idn
115 Summary:        Python interface to libidn
116 Summary(pl):    Pythonowy interfejs do libidn
117 Group:          Libraries/Python
118 Requires:       %{name} = %{version}-%{release}
119 %pyrequires_eq  python-libs
120
121 %description -n python-idn
122 Python interface to libidn (internationalized domain names library).
123
124 %description -n python-idn -l pl
125 Pythonowy interfejs do libidn (biblioteki umiêdzynarodowionych nazw
126 domen).
127
128 %prep
129 %setup -q
130 %patch0 -p1
131 %patch1 -p1
132
133 %build
134 %{__gettextize}
135 %{__libtoolize}
136 %{__aclocal} -I m4 -I gl/m4
137 %{__autoconf}
138 %{__autoheader}
139 %{__automake}
140 %configure \
141         %{?with_dotnet:--enable-csharp=mono}%{!?with_dotnet:--disable-csharp} \
142         %{?with_java:--enable-java} \
143         --with-lispdir=%{_emacs_lispdir}
144
145 %{__make}
146
147 %if %{with python}
148 %{__make} -C contrib/idn-python \
149         INCLUDE="/usr/include/python2.4 -I/usr/include/python2.3 %{rpmcflags} -I../../lib -L../../lib/.libs"
150 %endif
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154
155 %{__make} install \
156         DESTDIR=$RPM_BUILD_ROOT
157
158 %if %{with python}
159 install -D contrib/idn-python/idn.so $RPM_BUILD_ROOT%{py_sitedir}/idn.so
160 %endif
161
162 %find_lang %{name}
163
164 %clean
165 rm -rf $RPM_BUILD_ROOT
166
167 %post
168 /sbin/ldconfig
169 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
170
171 %postun
172 /sbin/ldconfig
173 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
174
175 %files -f %{name}.lang
176 %defattr(644,root,root,755)
177 %doc AUTHORS ChangeLog FAQ NEWS README* THANKS TODO doc/libidn.html contrib
178 %attr(755,root,root) %{_bindir}/idn
179 %attr(755,root,root) %{_libdir}/libidn.so.*.*.*
180 %{_mandir}/man1/idn.1*
181 %{_infodir}/libidn.info*
182
183 %files devel
184 %defattr(644,root,root,755)
185 %attr(755,root,root) %{_libdir}/libidn.so
186 %{_libdir}/libidn.la
187 %{_includedir}/*.h
188 %{_pkgconfigdir}/libidn.pc
189 %{_mandir}/man3/*
190
191 %files static
192 %defattr(644,root,root,755)
193 %{_libdir}/libidn.a
194
195 %if %{with dotnet}
196 %files -n dotnet-libidn
197 %defattr(644,root,root,755)
198 # why not in gac? does it work here?
199 %{_libdir}/Libidn.dll
200 %endif
201
202 %files -n emacs-libidn-pkg
203 %defattr(644,root,root,755)
204 %{_emacs_lispdir}/*.el
205
206 %if %{with java}
207 %files -n java-libidn
208 %defattr(644,root,root,755)
209 %{_datadir}/java/libidn*.jar
210 %endif
211
212 %if %{with python}
213 %files -n python-idn
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{py_sitedir}/idn.so
216 %endif
This page took 0.051703 seconds and 4 git commands to generate.