]> git.pld-linux.org Git - packages/libidn.git/blob - libidn.spec
f326ede2eb187b6a2d78d9d64e1edc86988768fa
[packages/libidn.git] / libidn.spec
1 # TODO:
2 # - prepare package with web-files and java from contrib
3 #
4 # Conditional build:
5 %bcond_with     java    # build Java implementation (but Punycode*.java missing from tar???)
6 #
7 Summary:        Internationalized string processing library
8 Summary(pl):    Biblioteka do przetwarzania umiêdzynarodowionych ³añcuchów
9 Name:           libidn
10 Version:        0.4.2
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        http://josefsson.org/libidn/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  194d3d8e68501d3363f3842d83b96f1f
16 Patch0:         %{name}-info.patch
17 URL:            http://www.gnu.org/software/libidn/
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake >= 1.8
20 BuildRequires:  gettext-devel >= 0.14.1
21 %{?with_java:BuildRequires:     jdk}
22 BuildRequires:  libtool >= 2:1.5
23 BuildRequires:  python-devel
24 BuildRequires:  texinfo >= 4.7
25 Requires(post,postun):  /sbin/ldconfig
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 # is it correct?
29 %define         _emacs_lispdir  %{_datadir}/emacs/site-lisp
30
31 %description
32 GNU Libidn is an implementation of the Stringprep, Punycode and IDNA
33 specifications defined by the IETF Internationalized Domain Names
34 (IDN) working group, used for internationalized domain names.
35
36 %description -l pl
37 GNU Libidn to implementacja specyfikacji Stringprep, Punycode i IDNA
38 zdefiniowanych przez grupê robocz± IETF Internationalized Domain Names
39 (IDN), zajmuj±c± siê umiêdzynarodowionymi nazwami domen.
40
41 %package devel
42 Summary:        Header files for libidn library
43 Summary(pl):    Pliki nag³ówkowe biblioteki libidn
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description devel
48 Header files for libidn library.
49
50 %description devel -l pl
51 Pliki nag³ówkowe biblioteki libidn.
52
53 %package static
54 Summary:        Static libidn library
55 Summary(pl):    Statyczna biblioteka libidn
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static libidn library.
61
62 %description static -l pl
63 Statyczna biblioteka libidn.
64
65 %package -n emacs-libidn-pkg
66 Summary:        IDN support files for emacs
67 Summary(pl):    Obs³uga IDN dla emacsa
68 Group:          Applications/Editors/Emacs
69 Requires:       %{name} = %{version}-%{release}
70
71 %description -n emacs-libidn-pkg
72 IDN support files for emacs.
73
74 %description -n emacs-libidn-pkg -l pl
75 Obs³uga IDN dla emacsa.
76
77 %package -n java-libidn
78 Summary:        Java implementation of libidn
79 Summary(pl):    Implementacja libidn w Javie
80 Group:          Libraries
81 Requires:       jre
82
83 %description -n java-libidn
84 Java implementation of libidn (internationalized domain names
85 library).
86
87 %description -n java-libidn -l pl
88 Implementacja libidn (biblioteki umiêdzynarodowionych nazw domen) w
89 Javie.
90
91 %package -n python-idn
92 Summary:        Python interface to libidn
93 Summary(pl):    Pythonowy interfejs do libidn
94 Group:          Libraries/Python
95 Requires:       %{name} = %{version}-%{release}
96 %pyrequires_eq  python-lib
97
98 %description -n python-idn
99 Python interface to libidn (internationalized domain names library).
100
101 %description -n python-idn -l pl
102 Pythonowy interfejs do libidn (biblioteki umiêdzynarodowionych nazw
103 domen).
104
105 %prep
106 %setup -q
107 %patch0 -p1
108
109 %build
110 %{__gettextize}
111 %{__libtoolize}
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %{__autoheader}
115 %{__automake}
116 %configure \
117         %{?with_java:--enable-java} \
118         --with-lispdir=%{_emacs_lispdir}
119
120 %{__make}
121
122 %{__make} -C contrib/idn-python \
123         INCLUDE="/usr/include/python2.3 %{rpmcflags} -L../../lib/.libs"
124
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 %{__make} install \
129         DESTDIR=$RPM_BUILD_ROOT
130
131 install -D contrib/idn-python/idn.so $RPM_BUILD_ROOT%{py_sitedir}/idn.so
132
133 %find_lang %{name}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post
139 /sbin/ldconfig
140 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
141
142 %postun
143 /sbin/ldconfig
144 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
145
146 %files -f %{name}.lang
147 %defattr(644,root,root,755)
148 %doc AUTHORS ChangeLog FAQ NEWS README* THANKS TODO doc/libidn.html contrib
149 %attr(755,root,root) %{_bindir}/idn
150 %attr(755,root,root) %{_libdir}/libidn.so.*.*.*
151 %{_mandir}/man1/idn.1*
152 %{_infodir}/libidn.info*
153
154 %files devel
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_libdir}/libidn.so
157 %{_libdir}/libidn.la
158 %{_includedir}/*.h
159 %{_pkgconfigdir}/libidn.pc
160 %{_mandir}/man3/*
161
162 %files static
163 %defattr(644,root,root,755)
164 %{_libdir}/libidn.a
165
166 %files -n emacs-libidn-pkg
167 %defattr(644,root,root,755)
168 %{_emacs_lispdir}/*.el
169
170 %if %{with java}
171 %files -n java-libidn
172 %defattr(644,root,root,755)
173 %{_datadir}/java/libidn.jar
174 %endif
175
176 %files -n python-idn
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{py_sitedir}/idn.so
This page took 0.293217 seconds and 3 git commands to generate.