]> git.pld-linux.org Git - packages/libgoffice.git/blob - libgoffice.spec
- 0.8.6
[packages/libgoffice.git] / libgoffice.spec
1 # $Revision: 1.43 $, $Da1te: 2007/09/07 15:28:31 $
2 #
3 # Conditional build:
4 %bcond_without  gnome   # disable all GNOME components
5 #
6 %define         orgname goffice
7 #
8 Summary:        Glib/Gtk+ set of document centric objects and utilities
9 Summary(pl.UTF-8):      Zestaw zorientowanych dokumentowo obiektów i narzędzi Glib/Gtk+
10 Name:           libgoffice
11 Version:        0.8.6
12 Release:        1
13 License:        GPL v2+
14 Group:          Libraries
15 Source0:        http://ftp.gnome.org/pub/GNOME/sources/goffice/0.8/%{orgname}-%{version}.tar.bz2
16 # Source0-md5:  78b749f9b6913c2995171396f5deb525
17 URL:            http://www.gtk.org/
18 BuildRequires:  GConf2-devel >= 2.20.0
19 BuildRequires:  autoconf >= 2.54
20 BuildRequires:  automake
21 BuildRequires:  cairo-devel >= 1.2.4
22 BuildRequires:  gettext-devel
23 %{?with_gnome:BuildRequires:    gnome-common >= 2.20.0}
24 BuildRequires:  gtk+2-devel >= 2:2.12.0
25 BuildRequires:  gtk-doc >= 1.4
26 BuildRequires:  intltool >= 0.35.0
27 BuildRequires:  libart_lgpl-devel >= 2.3.11
28 BuildRequires:  libglade2-devel >= 1:2.6.2
29 %{?with_gnome:BuildRequires:    libgnomeui-devel >= 2.20.0}
30 %{?with_gnome:BuildRequires:    libgsf-gnome-devel >= 1.14.6}
31 BuildRequires:  libtool
32 BuildRequires:  libxml2-devel >= 1:2.6.26
33 BuildRequires:  pkgconfig
34 %{?with_gnome:Requires: libgsf-gnome >= 1.14.6}
35 # sr@Latn vs. sr@latin
36 Conflicts:      glibc-misc < 6:2.7
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 GOffice - a Glib/Gtk+ set of document centric objects and utilities.
41
42 %description -l pl.UTF-8
43 GOffice - Zestaw zorientowanych dokumentowo obiektów i narzędzi
44 Glib/Gtk+.
45
46 %package devel
47 Summary:        Header files for GOffice library
48 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki GOffice
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       gtk+2-devel >= 2:2.12.0
52 Requires:       libart_lgpl-devel >= 2.3.11
53 Requires:       libglade2-devel >= 1:2.6.2
54 Requires:       libgsf-gnome-devel >= 1.14.6
55 Requires:       libxml2-devel >= 1:2.6.26
56
57 %description devel
58 This is the package containing the header files for GOffice.
59
60 %description devel -l pl.UTF-8
61 Ten pakiet zawiera pliki nagłówkowe GOffice.
62
63 %package static
64 Summary:        Static GOffice library
65 Summary(pl.UTF-8):      Statyczna biblioteka GOffice
66 Group:          Development/Libraries
67 Requires:       %{name}-devel = %{version}-%{release}
68
69 %description static
70 Static GOffice library.
71
72 %description static -l pl.UTF-8
73 Statyczna biblioteka GOffice.
74
75 %package apidocs
76 Summary:        GOffice library API documentation
77 Summary(pl.UTF-8):      Dokumentacja API biblioteki GOffice
78 Group:          Documentation
79 Requires:       gtk-doc-common
80
81 %description apidocs
82 GOffice library API documentation.
83
84 %description apidocs -l pl.UTF-8
85 Dokumentacja API biblioteki GOffice.
86
87 %prep
88 %setup -qn %{orgname}-%{version}
89
90 %build
91 %{__gtkdocize}
92 %{__intltoolize}
93 %{__libtoolize}
94 %{__aclocal}
95 %{__autoconf}
96 %{__autoheader}
97 %{__automake}
98 %configure \
99         --enable-static \
100         %{?with_gnome:--with-gnome} \
101         --with-html-dir=%{_gtkdocdir}
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 rm -f $RPM_BUILD_ROOT%{_libdir}/goffice/%{version}/plugins/*/*.{a,la}
111
112 %find_lang %{orgname}-%{version}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   -p /sbin/ldconfig
118 %postun -p /sbin/ldconfig
119
120 %files -f %{orgname}-%{version}.lang
121 %defattr(644,root,root,755)
122 %doc AUTHORS BUGS ChangeLog MAINTAINERS NEWS README
123 %attr(755,root,root) %{_libdir}/libgoffice-0.8.so.*.*.*
124 %attr(755,root,root) %ghost %{_libdir}/libgoffice-0.8.so.8
125 %dir %{_libdir}/goffice
126 %dir %{_libdir}/goffice/%{version}
127 %dir %{_libdir}/goffice/%{version}/plugins
128 %dir %{_libdir}/goffice/%{version}/plugins/*
129 %attr(755,root,root) %{_libdir}/goffice/%{version}/plugins/*/*.so
130 %{_libdir}/goffice/%{version}/plugins/*/*.xml
131 %{_libdir}/goffice/%{version}/plugins/*/*.ui
132 %{_datadir}/goffice
133 %{_pixmapsdir}/goffice
134
135 %files devel
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libgoffice-0.8.so
138 %{_libdir}/libgoffice-0.8.la
139 %{_includedir}/libgoffice-0.8
140 %{_pkgconfigdir}/libgoffice-0.8.pc
141
142 %files static
143 %defattr(644,root,root,755)
144 %{_libdir}/libgoffice-0.8.a
145
146 %files apidocs
147 %defattr(644,root,root,755)
148 %{_gtkdocdir}/goffice-0.8
This page took 0.17087 seconds and 3 git commands to generate.