]> git.pld-linux.org Git - packages/libgit2.git/blob - libgit2.spec
- added no-libgit2-test patch (disable patch requiring local libgit2 repository,...
[packages/libgit2.git] / libgit2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 %bcond_with     tests_online    # build with tests reqiuring online access
5
6 Summary:        C git library
7 Summary(pl.UTF-8):      Biblioteka git dla C
8 Name:           libgit2
9 Version:        0.20.0
10 Release:        1
11 License:        GPL v2 with linking exception
12 Group:          Libraries
13 Source0:        https://github.com/libgit2/libgit2/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
14 # Source0-md5:  e35f613a37e11354f34249f2faa68237
15 Patch0:         %{name}-test-online.patch
16 Patch1:         %{name}-no-libgit2-test.patch
17 URL:            http://libgit2.github.com/
18 BuildRequires:  cmake >= 2.6
19 BuildRequires:  http-parser-devel
20 BuildRequires:  libssh2-devel
21 BuildRequires:  openssl-devel
22 %{?with_tests:BuildRequires:    python}
23 BuildRequires:  zlib-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 libgit2 is a portable, pure C implementation of the Git core methods
28 provided as a re-entrant linkable library with a solid API, allowing
29 you to write native speed custom Git applications in any language with
30 bindings.
31
32 %description -l pl.UTF-8
33 libgit2 to przenośna implementacja w czystym C głównych metod Gita,
34 udostępniona jako bezpieczna dla wątków biblioteka ze stałym API,
35 pozwalająca na pisanie własnych aplikacji dla Gita o natywnej
36 szybkości w dowolnym języku posiadającym odpowiednie wiązania.
37
38 %package devel
39 Summary:        Header files for libgit2 library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgit2
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43 Requires:       openssl-devel
44 Requires:       zlib-devel
45
46 %description devel
47 Header files for libgit2 library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki libgit2.
51
52 %prep
53 %setup -q
54 %patch0 -p1
55 %patch1 -p1
56
57 %build
58 install -d build
59 cd build
60 %cmake .. \
61         %{?with_tests_online:-DONLINE_TESTS=1}
62 %{__make}
63
64 %{?with_tests:%{__make} test ARGS="-V"}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 %{__make} -C build install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %post   -p /sbin/ldconfig
75 %postun -p /sbin/ldconfig
76
77 %files
78 %defattr(644,root,root,755)
79 %doc AUTHORS CONTRIBUTING.md COPYING README.md
80 %attr(755,root,root) %{_libdir}/libgit2.so.*.*.*
81 %attr(755,root,root) %ghost %{_libdir}/libgit2.so.0
82
83 %files devel
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_libdir}/libgit2.so
86 %{_includedir}/git2.h
87 %{_includedir}/git2
88 %{_pkgconfigdir}/libgit2.pc
This page took 0.085521 seconds and 4 git commands to generate.