]> git.pld-linux.org Git - packages/libgit2.git/blob - libgit2.spec
- pl, -devel deps
[packages/libgit2.git] / libgit2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 Summary:        C git library
6 Summary(pl.UTF-8):      Biblioteka git dla C
7 Name:           libgit2
8 Version:        0.18.0
9 Release:        1
10 License:        GPL v2 with linking exception
11 Group:          Libraries
12 Source0:        https://github.com/libgit2/libgit2/archive/v%{version}.tar.gz?/%{name}-version.tgz
13 # Source0-md5:  ce6845df0dd084ef2633a69dba64929c
14 URL:            http://libgit2.github.com/
15 BuildRequires:  cmake >= 2.6
16 BuildRequires:  openssl-devel
17 %{?with_tests:BuildRequires:    python}
18 BuildRequires:  zlib-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 libgit2 is a portable, pure C implementation of the Git core methods
23 provided as a re-entrant linkable library with a solid API, allowing
24 you to write native speed custom Git applications in any language with
25 bindings.
26
27 %description -l pl.UTF-8
28 libgit2 to przenośna implementacja w czystym C głównych metod Gita,
29 udostępniona jako bezpieczna dla wątków biblioteka ze stałym API,
30 pozwalająca na pisanie własnych aplikacji dla Gita o natywnej
31 szybkości w dowolnym języku posiadającym odpowiednie wiązania.
32
33 %package devel
34 Summary:        Header files for libgit2 library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libgit2
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       openssl-devel
39 Requires:       zlib-devel
40
41 %description devel
42 Header files for libgit2 library.
43
44 %description devel -l pl.UTF-8
45 Pliki nagłówkowe biblioteki libgit2.
46
47 %prep
48 %setup -q
49
50 %build
51 install -d build
52 cd build
53 %cmake ..
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60 %{__make} -C build install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post   -p /sbin/ldconfig
67 %postun -p /sbin/ldconfig
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS CONTRIBUTING.md COPYING README.md
72 %attr(755,root,root) %{_libdir}/libgit2.so.*.*.*
73 %attr(755,root,root) %ghost %{_libdir}/libgit2.so.0
74
75 %files devel
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_libdir}/libgit2.so
78 %{_includedir}/git2.h
79 %{_includedir}/git2
80 %{_pkgconfigdir}/libgit2.pc
This page took 0.083455 seconds and 4 git commands to generate.