]> git.pld-linux.org Git - packages/libgda3.git/blob - libgda3.spec
- release 4
[packages/libgda3.git] / libgda3.spec
1 #
2 # TODO: package dotnet-gda-sharp
3 #
4 # Conditional build:
5 %bcond_without  doc             # don't generate html documentation
6 %bcond_without  static_libs     # don't build static libraries
7 %bcond_with     gamin           # use gamin instead of fam library
8 %bcond_without  gnomevfs        # build without gnome-vfs support
9 %bcond_without  gnome           # without gnomevfs (convenience alias)
10 # - database plugins:
11 %bcond_without  firebird        # build without firebird plugin
12 %bcond_without  freetds         # build without freetds plugin
13 %bcond_without  ldap            # build without ldap plugin
14 %bcond_without  mdb             # build without MDB plugin
15 %bcond_without  mysql           # build without MySQL plugin
16 %bcond_without  odbc            # build without unixODBC
17 %bcond_without  pgsql           # build without PostgreSQL plugin
18 %bcond_without  sqlite          # build without sqlite plugin
19 %bcond_without  xbase           # build without xbase plugin
20 #
21 %if %{without gnome}
22 %undefine       with_gnomevfs
23 %endif
24 %ifnarch %{ix86} sparc sparcv9 alpha
25 %undefine       with_firebird
26 %endif
27 Summary:        GNU Data Access library
28 Summary(pl.UTF-8):      Biblioteka GNU Data Access
29 Name:           libgda3
30 Version:        3.1.2
31 Release:        4
32 License:        LGPL v2+/GPL v2+
33 Group:          Libraries
34 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/3.1/libgda-%{version}.tar.bz2
35 # Source0-md5:  fe299d264ddeb7fbc36276f74f1abfdc
36 Patch1:         %{name}-configure.patch
37 URL:            http://www.gnome-db.org/
38 %{?with_firebird:BuildRequires: Firebird-devel}
39 BuildRequires:  autoconf >= 2.59
40 BuildRequires:  automake >= 1:1.8
41 BuildRequires:  bison
42 BuildRequires:  db-devel
43 %{!?with_gamin:BuildRequires:   fam-devel}
44 BuildRequires:  flex
45 %{?with_freetds:BuildRequires:  freetds-devel >= 0.64}
46 %{?with_gamin:BuildRequires:    gamin-devel}
47 BuildRequires:  glib2-devel >= 1:2.12.0
48 BuildRequires:  gnome-common >= 2.12.0
49 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
50 BuildRequires:  gtk-doc >= 1.6
51 BuildRequires:  intltool >= 0.35.5
52 BuildRequires:  libgcrypt-devel >= 1.1.42
53 BuildRequires:  libtool
54 BuildRequires:  libxml2-devel >= 1:2.6.26
55 BuildRequires:  libxslt-devel >= 1.1.17
56 %{?with_mdb:BuildRequires:      mdbtools-devel >= 0.6}
57 %{?with_mysql:BuildRequires:    mysql-devel}
58 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
59 BuildRequires:  perl-base
60 BuildRequires:  popt-devel
61 %{?with_pgsql:BuildRequires:    postgresql-devel}
62 BuildRequires:  readline-devel >= 5.0
63 BuildRequires:  rpmbuild(macros) >= 1.213
64 %{?with_sqlite:BuildRequires:   sqlite3-devel >= 3.5.0-2}
65 %{?with_odbc:BuildRequires:     unixODBC-devel}
66 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _libgdadir      libgda-3.0
70 %define         _providersdir   %{_libdir}/%{_libgdadir}/providers
71
72 %description
73 GNU Data Access is an attempt to provide uniform access to different
74 kinds of data sources (databases, information servers, mail spools,
75 etc). It is a complete architecture that provides all you need to
76 access your data.
77
78 libgda was part of the GNOME-DB project but has been separated from it
79 to allow non-GNOME applications to be developed based on it.
80
81 %description -l pl.UTF-8
82 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
83 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
84 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
85 potrzebujesz do dostępu do danych.
86
87 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
88 pozwolić na używanie przez niegnomowe aplikacje.
89
90 %package devel
91 Summary:        GNU Data Access development files
92 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GNU Data Access
93 Group:          Development/Libraries
94 Requires:       %{name} = %{version}-%{release}
95 %{!?with_gamin:Requires:        fam-devel}
96 %{?with_gamin:Requires: gamin-devel}
97 Requires:       glib2-devel >= 1:2.12.0
98 %{?with_gnomevfs:Requires:      gnome-vfs2-devel >= 2.0}
99 Requires:       gtk-doc-common
100 Requires:       libgcrypt-devel >= 1.1.42
101 Requires:       libxml2-devel >= 1:2.6.26
102 Requires:       libxslt-devel >= 1.1.17
103 Obsoletes:      libgda0-devel
104
105 %description devel
106 GNU Data Access is an attempt to provide uniform access to different
107 kinds of data sources (databases, information servers, mail spools,
108 etc). It is a complete architecture that provides all you need to
109 access your data. This subpackage contains development files.
110
111 %description devel -l pl.UTF-8
112 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
113 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
114 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
115 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
116 programistów używających libgda.
117
118 %package static
119 Summary:        GNU Data Access static libraries
120 Summary(pl.UTF-8):      Statyczne biblioteki GNU Data Access
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description static
125 GNU Data Access static libraries.
126
127 %description static -l pl.UTF-8
128 Statyczne biblioteki GNU Data Access.
129
130 %package provider-db
131 Summary:        GDA Berkeley DB provider
132 Summary(pl.UTF-8):      Źródło danych Berkeley DB dla GDA
133 Group:          Libraries
134 Requires:       %{name} = %{version}-%{release}
135
136 %description provider-db
137 This package contains the GDA Berkeley DB provider.
138
139 %description provider-db -l pl.UTF-8
140 Pakiet dostaczający dane z Berkeley DB dla GDA.
141
142 %package provider-firebird
143 Summary:        GDA Firebird provider
144 Summary(pl.UTF-8):      Źródło danych Firebird dla GDA
145 Group:          Libraries
146 Requires:       %{name} = %{version}-%{release}
147
148 %description provider-firebird
149 This package contains the GDA Firebird provider.
150
151 %description provider-firebird -l pl.UTF-8
152 Pakiet dostarczający dane z Firebird dla GDA.
153
154 %package provider-freetds
155 Summary:        GDA FreeTDS provider
156 Summary(pl.UTF-8):      Źródło danych FreeTDS dla GDA
157 Group:          Libraries
158 Requires:       %{name} = %{version}-%{release}
159
160 %description provider-freetds
161 This package contains the GDA FreeTDS provider.
162
163 %description provider-freetds -l pl.UTF-8
164 Pakiet dostarczający dane z FreeTDS dla GDA.
165
166 %package provider-ldap
167 Summary:        GDA LDAP provider
168 Summary(pl.UTF-8):      Źródło danych LDAP dla GDA
169 Group:          Libraries
170 Requires:       %{name} = %{version}-%{release}
171
172 %description provider-ldap
173 This package contains the GDA LDAP provider.
174
175 %description provider-ldap -l pl.UTF-8
176 Pakiet dostarczający dane z LDAP dla GDA
177
178 %package provider-mdb
179 Summary:        GDA MDB provider
180 Summary(pl.UTF-8):      Źródło danych MDB
181 Group:          Libraries
182 Requires:       %{name} = %{version}-%{release}
183 Requires:       mdbtools-libs >= 0.6
184
185 %description provider-mdb
186 This package contains the GDA MDB provider.
187
188 %description provider-mdb -l pl.UTF-8
189 Pakiet dostarczający dane z MDB dla GDA.
190
191 %package provider-mysql
192 Summary:        GDA MySQL provider
193 Summary(pl.UTF-8):      Źródło danych MySQL dla GDA
194 Group:          Libraries
195 Requires:       %{name} = %{version}-%{release}
196 Obsoletes:      libgda-mysql0
197
198 %description provider-mysql
199 This package contains the GDA MySQL provider.
200
201 %description provider-mysql -l pl.UTF-8
202 Pakiet dostarczający dane z MySQL dla GDA.
203
204 %package provider-odbc
205 Summary:        GDA ODBC provider
206 Summary(pl.UTF-8):      Źródło danych ODBC dla GDA
207 Group:          Libraries
208 Requires:       %{name} = %{version}-%{release}
209
210 %description provider-odbc
211 This package contains the GDA ODBC provider.
212
213 %description provider-odbc -l pl.UTF-8
214 Pakiet dostarczający dane z ODBC dla GDA.
215
216 %package provider-postgres
217 Summary:        GDA PostgreSQL provider
218 Summary(pl.UTF-8):      Źródło danych PostgreSQL dla GDA
219 Group:          Libraries
220 Requires:       %{name} = %{version}-%{release}
221 Obsoletes:      libgda-postgres0
222
223 %description provider-postgres
224 This package contains the GDA PostgreSQL provider.
225
226 %description provider-postgres -l pl.UTF-8
227 Pakiet dostarczający dane z PostgreSQL dla GDA.
228
229 %package provider-sqlite
230 Summary:        GDA SQLite provider
231 Summary(pl.UTF-8):      Źródło danych SQLite dla GDA
232 Group:          Libraries
233 Requires:       %{name} = %{version}-%{release}
234
235 %description provider-sqlite
236 This package contains the GDA SQLite provider.
237
238 %description provider-sqlite -l pl.UTF-8
239 Pakiet dostarczający dane z SQLite dla GDA.
240
241 %package provider-xbase
242 Summary:        GDA xBase provider
243 Summary(pl.UTF-8):      Źródło danych xBase dla GDA
244 Group:          Libraries
245 Requires:       %{name} = %{version}-%{release}
246
247 %description provider-xbase
248 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
249
250 %description provider-xbase -l pl.UTF-8
251 Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
252
253 %prep
254 %setup -q -n libgda-%{version}
255 %patch1 -p1
256
257 %if %{without gamin}
258 sed -i -e 's#PKG_CHECK_MODULES(GAMIN.*)#have_fam=no#g' configure.in
259 %endif
260 %if %{without gnomevfs}
261 sed -i -e 's#PKG_CHECK_MODULES(GNOMEVFS.*)#have_gnomevfs=no#g' configure.in
262 %endif
263
264 %build
265 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
266 %{__intltoolize}
267 %{__libtoolize}
268 %{__aclocal}
269 %{__autoconf}
270 %{__automake}
271 %configure \
272         %{?with_doc:--enable-gtk-doc} \
273         %{!?with_static_libs:--enable-static=no} \
274         --with-html-dir=%{_gtkdocdir} \
275         --with%{!?with_firebird:out}-firebird \
276         --with%{!?with_ldap:out}-ldap \
277         --with%{!?with_mdb:out}-mdb \
278         --with%{!?with_mysql:out}-mysql \
279         --with%{!?with_odbc:out}-odbc \
280         --with%{!?with_pgsql:out}-postgres \
281         --with%{!?with_sqlite:out}-sqlite \
282         --with%{!?with_freetds:out}-tds \
283         --with%{!?with_xbase:out}-xbase \
284         --without-oracle
285 %{__make} -j1
286
287 %install
288 rm -rf $RPM_BUILD_ROOT
289
290 %{__make} install \
291         DESTDIR=$RPM_BUILD_ROOT \
292         HTML_DIR=%{_gtkdocdir}
293
294 # modules dlopened by *.so through libgmodule
295 rm -f $RPM_BUILD_ROOT%{_providersdir}/*.{a,la}
296
297 %find_lang libgda-3.0
298
299 %clean
300 rm -rf $RPM_BUILD_ROOT
301
302 %post   -p /sbin/ldconfig
303 %postun -p /sbin/ldconfig
304
305 %files -f libgda-3.0.lang
306 %defattr(644,root,root,755)
307 %doc AUTHORS ChangeLog NEWS README
308 %attr(755,root,root) %{_bindir}/gda-config-tool-3.0
309 %attr(755,root,root) %{_bindir}/gda-list-server-op-3.0
310 %attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
311 %attr(755,root,root) %ghost %{_libdir}/libgda-3.0.so.3
312 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
313 %attr(755,root,root) %ghost %{_libdir}/libgda-report-3.0.so.3
314 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so.*.*.*
315 %attr(755,root,root) %ghost %{_libdir}/libgda-xslt-3.0.so.0
316 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
317 %attr(755,root,root) %ghost %{_libdir}/libgdasql-3.0.so.3
318 %dir %{_libdir}/%{_libgdadir}
319 %dir %{_providersdir}
320 %{_datadir}/libgda-3.0
321 %dir %{_sysconfdir}/libgda-3.0
322 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
323 %{_mandir}/man1/gda-config-tool-3.0.1*
324 %{_mandir}/man5/gda-config-3.0.5*
325
326 %files devel
327 %defattr(644,root,root,755)
328 %attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
329 %attr(755,root,root) %{_bindir}/gda-bdb-test
330 %attr(755,root,root) %{_bindir}/gda-diagnose-3.0
331 %attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
332 %attr(755,root,root) %{_bindir}/gda-list-config-3.0
333 %attr(755,root,root) %{_bindir}/gda-sql-3.0
334 %attr(755,root,root) %{_bindir}/gda-test-connection-3.0
335 %attr(755,root,root) %{_libdir}/libgda-3.0.so
336 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so
337 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so
338 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so
339 %{_libdir}/libgda-3.0.la
340 %{_libdir}/libgda-report-3.0.la
341 %{_libdir}/libgda-xslt-3.0.la
342 %{_libdir}/libgdasql-3.0.la
343 %{_includedir}/libgda-3.0
344 %{_pkgconfigdir}/libgda-3.0.pc
345 %{_pkgconfigdir}/libgda-*-3.0.pc
346 %{_sysconfdir}/libgda-3.0/sales_test.db
347 %{?with_doc:%{_gtkdocdir}/libgda-3.0}
348
349 %if %{with static_libs}
350 %files static
351 %defattr(644,root,root,755)
352 %{_libdir}/libgda-3.0.a
353 %{_libdir}/libgda-report-3.0.a
354 %{_libdir}/libgda-xslt-3.0.a
355 %{_libdir}/libgdasql-3.0.a
356 %endif
357
358 %files provider-db
359 %defattr(644,root,root,755)
360 %attr(755,root,root) %{_providersdir}/libgda-bdb.so
361
362 %if %{with firebird}
363 %files provider-firebird
364 %defattr(644,root,root,755)
365 %attr(755,root,root) %{_providersdir}/libgda-firebird.so
366 %endif
367
368 %if %{with freetds}
369 %files provider-freetds
370 %defattr(644,root,root,755)
371 %attr(755,root,root) %{_providersdir}/libgda-freetds.so
372 %endif
373
374 %if %{with ldap}
375 %files provider-ldap
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_providersdir}/libgda-ldap.so
378 %endif
379
380 %if %{with mdb}
381 %files provider-mdb
382 %defattr(644,root,root,755)
383 %attr(755,root,root) %{_providersdir}/libgda-mdb.so
384 %endif
385
386 %if %{with mysql}
387 %files provider-mysql
388 %defattr(644,root,root,755)
389 %attr(755,root,root) %{_providersdir}/libgda-mysql.so
390 %endif
391
392 %if %{with odbc}
393 %files provider-odbc
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_providersdir}/libgda-odbc.so
396 %endif
397
398 %if %{with pgsql}
399 %files provider-postgres
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_providersdir}/libgda-postgres.so
402 %endif
403
404 %if %{with sqlite}
405 %files provider-sqlite
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_providersdir}/libgda-sqlite.so
408 %endif
409
410 %if %{with xbase}
411 %files provider-xbase
412 %defattr(644,root,root,755)
413 %attr(755,root,root) %{_providersdir}/libgda-xbase.so
414 %endif
This page took 0.922897 seconds and 4 git commands to generate.