]> git.pld-linux.org Git - packages/libgda3.git/blob - libgda3.spec
- killed duplicate install
[packages/libgda3.git] / libgda3.spec
1 #
2 # TODO: package dotnet-gda-sharp
3 #
4 # Conditional build:
5 %bcond_without  doc             # don't generate html documentation
6 %bcond_without  static_libs     # don't build static libraries
7 %bcond_with     gamin           # use gamin instead of fam library
8 %bcond_without  gnomevfs        # build without gnome-vfs support
9 %bcond_without  gnome           # without gnomevfs (convenience alias)
10 # - database plugins:
11 %bcond_without  firebird        # build without firebird plugin
12 %bcond_with     freetds         # build with freetds plugin
13 %bcond_without  ldap            # build without ldap plugin
14 %bcond_without  mdb             # build without MDB plugin
15 %bcond_without  mysql           # build without MySQL plugin
16 %bcond_without  odbc            # build without unixODBC
17 %bcond_without  pgsql           # build without PostgreSQL plugin
18 %bcond_without  sqlite          # build without sqlite plugin
19 %bcond_without  sybase          # build without sybase plugin
20 %bcond_without  xbase           # build without xbase plugin
21 #
22 %if %{without gnome}
23 %undefine       with_gnomevfs
24 %endif
25 %ifnarch %{ix86} sparc sparcv9 alpha
26 %undefine       with_firebird
27 %endif
28 Summary:        GNU Data Access library
29 Summary(pl.UTF-8):      Biblioteka GNU Data Access
30 Name:           libgda3
31 Version:        3.1.5
32 Release:        5
33 License:        LGPL v2+/GPL v2+
34 Group:          Libraries
35 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/3.1/libgda-%{version}.tar.bz2
36 # Source0-md5:  eb7da5286a112e7cff3111c89fba4456
37 Patch0:         %{name}-configure.patch
38 Patch1:         %{name}-am.patch
39 URL:            http://www.gnome-db.org/
40 %{?with_firebird:BuildRequires: Firebird-devel}
41 BuildRequires:  autoconf >= 2.59
42 BuildRequires:  automake >= 1:1.8
43 BuildRequires:  bison
44 BuildRequires:  db-devel
45 %{!?with_gamin:BuildRequires:   fam-devel}
46 BuildRequires:  flex
47 %{?with_freetds:BuildRequires:  freetds-devel = 0.64}
48 %{?with_gamin:BuildRequires:    gamin-devel >= 0.1.8}
49 BuildRequires:  glib2-devel >= 1:2.12.0
50 BuildRequires:  gnome-common >= 2.12.0
51 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.20}
52 BuildRequires:  gtk-doc >= 1.6
53 BuildRequires:  intltool >= 0.35.5
54 BuildRequires:  libgcrypt-devel >= 1.1.42
55 BuildRequires:  libtool
56 BuildRequires:  libxml2-devel >= 1:2.6.26
57 BuildRequires:  libxslt-devel >= 1.1.17
58 %{?with_mdb:BuildRequires:      mdbtools-devel >= 0.6}
59 %{?with_mysql:BuildRequires:    mysql-devel}
60 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
61 BuildRequires:  perl-base
62 BuildRequires:  popt-devel
63 %{?with_pgsql:BuildRequires:    postgresql-devel}
64 BuildRequires:  readline-devel >= 5.0
65 BuildRequires:  rpmbuild(macros) >= 1.213
66 %{?with_sqlite:BuildRequires:   sqlite3-devel >= 3.5.0-2}
67 %{?with_sybase:BuildRequires:   freetds-devel >= 0.82}
68 %{?with_odbc:BuildRequires:     unixODBC-devel}
69 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _libgdadir      libgda-3.0
73 %define         _providersdir   %{_libdir}/%{_libgdadir}/providers
74
75 %description
76 GNU Data Access is an attempt to provide uniform access to different
77 kinds of data sources (databases, information servers, mail spools,
78 etc). It is a complete architecture that provides all you need to
79 access your data.
80
81 libgda was part of the GNOME-DB project but has been separated from it
82 to allow non-GNOME applications to be developed based on it.
83
84 %description -l pl.UTF-8
85 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
86 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
87 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
88 potrzebujesz do dostępu do danych.
89
90 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
91 pozwolić na używanie przez niegnomowe aplikacje.
92
93 %package devel
94 Summary:        GNU Data Access development files
95 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GNU Data Access
96 Group:          Development/Libraries
97 Requires:       %{name} = %{version}-%{release}
98 %{!?with_gamin:Requires:        fam-devel}
99 %{?with_gamin:Requires: gamin-devel >= 0.1.8}
100 Requires:       glib2-devel >= 1:2.12.0
101 %{?with_gnomevfs:Requires:      gnome-vfs2-devel >= 2.20}
102 Requires:       gtk-doc-common
103 Requires:       libgcrypt-devel >= 1.1.42
104 Requires:       libxml2-devel >= 1:2.6.26
105 Requires:       libxslt-devel >= 1.1.17
106 Obsoletes:      libgda0-devel
107
108 %description devel
109 GNU Data Access is an attempt to provide uniform access to different
110 kinds of data sources (databases, information servers, mail spools,
111 etc). It is a complete architecture that provides all you need to
112 access your data. This subpackage contains development files.
113
114 %description devel -l pl.UTF-8
115 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
116 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
117 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
118 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
119 programistów używających libgda.
120
121 %package static
122 Summary:        GNU Data Access static libraries
123 Summary(pl.UTF-8):      Statyczne biblioteki GNU Data Access
124 Group:          Development/Libraries
125 Requires:       %{name}-devel = %{version}-%{release}
126
127 %description static
128 GNU Data Access static libraries.
129
130 %description static -l pl.UTF-8
131 Statyczne biblioteki GNU Data Access.
132
133 %package provider-db
134 Summary:        GDA Berkeley DB provider
135 Summary(pl.UTF-8):      Źródło danych Berkeley DB dla GDA
136 Group:          Libraries
137 Requires:       %{name} = %{version}-%{release}
138
139 %description provider-db
140 This package contains the GDA Berkeley DB provider.
141
142 %description provider-db -l pl.UTF-8
143 Pakiet dostaczający dane z Berkeley DB dla GDA.
144
145 %package provider-firebird
146 Summary:        GDA Firebird provider
147 Summary(pl.UTF-8):      Źródło danych Firebird dla GDA
148 Group:          Libraries
149 Requires:       %{name} = %{version}-%{release}
150
151 %description provider-firebird
152 This package contains the GDA Firebird provider.
153
154 %description provider-firebird -l pl.UTF-8
155 Pakiet dostarczający dane z Firebird dla GDA.
156
157 %package provider-freetds
158 Summary:        GDA FreeTDS provider
159 Summary(pl.UTF-8):      Źródło danych FreeTDS dla GDA
160 Group:          Libraries
161 Requires:       %{name} = %{version}-%{release}
162
163 %description provider-freetds
164 This package contains the GDA FreeTDS provider.
165
166 %description provider-freetds -l pl.UTF-8
167 Pakiet dostarczający dane z FreeTDS dla GDA.
168
169 %package provider-ldap
170 Summary:        GDA LDAP provider
171 Summary(pl.UTF-8):      Źródło danych LDAP dla GDA
172 Group:          Libraries
173 Requires:       %{name} = %{version}-%{release}
174
175 %description provider-ldap
176 This package contains the GDA LDAP provider.
177
178 %description provider-ldap -l pl.UTF-8
179 Pakiet dostarczający dane z LDAP dla GDA
180
181 %package provider-mdb
182 Summary:        GDA MDB provider
183 Summary(pl.UTF-8):      Źródło danych MDB
184 Group:          Libraries
185 Requires:       %{name} = %{version}-%{release}
186 Requires:       mdbtools-libs >= 0.6
187
188 %description provider-mdb
189 This package contains the GDA MDB provider.
190
191 %description provider-mdb -l pl.UTF-8
192 Pakiet dostarczający dane z MDB dla GDA.
193
194 %package provider-mysql
195 Summary:        GDA MySQL provider
196 Summary(pl.UTF-8):      Źródło danych MySQL dla GDA
197 Group:          Libraries
198 Requires:       %{name} = %{version}-%{release}
199 Obsoletes:      libgda-mysql0
200
201 %description provider-mysql
202 This package contains the GDA MySQL provider.
203
204 %description provider-mysql -l pl.UTF-8
205 Pakiet dostarczający dane z MySQL dla GDA.
206
207 %package provider-odbc
208 Summary:        GDA ODBC provider
209 Summary(pl.UTF-8):      Źródło danych ODBC dla GDA
210 Group:          Libraries
211 Requires:       %{name} = %{version}-%{release}
212
213 %description provider-odbc
214 This package contains the GDA ODBC provider.
215
216 %description provider-odbc -l pl.UTF-8
217 Pakiet dostarczający dane z ODBC dla GDA.
218
219 %package provider-postgres
220 Summary:        GDA PostgreSQL provider
221 Summary(pl.UTF-8):      Źródło danych PostgreSQL dla GDA
222 Group:          Libraries
223 Requires:       %{name} = %{version}-%{release}
224 Obsoletes:      libgda-postgres0
225
226 %description provider-postgres
227 This package contains the GDA PostgreSQL provider.
228
229 %description provider-postgres -l pl.UTF-8
230 Pakiet dostarczający dane z PostgreSQL dla GDA.
231
232 %package provider-sqlite
233 Summary:        GDA SQLite provider
234 Summary(pl.UTF-8):      Źródło danych SQLite dla GDA
235 Group:          Libraries
236 Requires:       %{name} = %{version}-%{release}
237
238 %description provider-sqlite
239 This package contains the GDA SQLite provider.
240
241 %description provider-sqlite -l pl.UTF-8
242 Pakiet dostarczający dane z SQLite dla GDA.
243
244 %package provider-sybase
245 Summary:        GDA Sybase provider
246 Summary(pl.UTF-8):      Źródło danych Sybase dla GDA
247 Group:          Libraries
248 Requires:       %{name} = %{version}-%{release}
249
250 %description provider-sybase
251 This package contains the GDA Sybase provider.
252
253 %description provider-sybase -l pl.UTF-8
254 Pakiet dostarczający dane z Sybase dla GDA.
255
256 %package provider-xbase
257 Summary:        GDA xBase provider
258 Summary(pl.UTF-8):      Źródło danych xBase dla GDA
259 Group:          Libraries
260 Requires:       %{name} = %{version}-%{release}
261
262 %description provider-xbase
263 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
264
265 %description provider-xbase -l pl.UTF-8
266 Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
267
268 %prep
269 %setup -q -n libgda-%{version}
270 %patch0 -p1
271 %patch1 -p1
272
273 %if %{without gamin}
274 sed -i -e 's#PKG_CHECK_MODULES(GAMIN.*)#have_fam=no#g' configure.in
275 %endif
276 %if %{without gnomevfs}
277 sed -i -e 's#PKG_CHECK_MODULES(GNOMEVFS.*)#have_gnomevfs=no#g' configure.in
278 %endif
279
280 %build
281 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
282 %{__intltoolize}
283 %{__libtoolize}
284 %{__aclocal}
285 %{__autoconf}
286 %{__automake}
287 %configure \
288         %{!?with_static_libs:--disable-static} \
289         %{?with_doc:--enable-gtk-doc} \
290         --with-html-dir=%{_gtkdocdir} \
291         --with%{!?with_firebird:out}-firebird \
292         --with%{!?with_ldap:out}-ldap \
293         --with%{!?with_mdb:out}-mdb \
294         --with%{!?with_mysql:out}-mysql \
295         --with%{!?with_odbc:out}-odbc \
296         --with%{!?with_pgsql:out}-postgres \
297         --with%{!?with_sqlite:out}-sqlite \
298         --with%{!?with_freetds:out}-tds \
299         --with%{!?with_xbase:out}-xbase \
300         %{?with_sybase:--with-sybase=/usr} \
301         --without-oracle
302 %{__make} -j1
303
304 %install
305 rm -rf $RPM_BUILD_ROOT
306
307 %{__make} install \
308         DESTDIR=$RPM_BUILD_ROOT \
309         HTML_DIR=%{_gtkdocdir}
310
311 # modules dlopened by *.so through libgmodule
312 rm -f $RPM_BUILD_ROOT%{_providersdir}/*.{a,la}
313
314 %find_lang libgda-3.0
315
316 %clean
317 rm -rf $RPM_BUILD_ROOT
318
319 %post   -p /sbin/ldconfig
320 %postun -p /sbin/ldconfig
321
322 %files -f libgda-3.0.lang
323 %defattr(644,root,root,755)
324 %doc AUTHORS ChangeLog NEWS README
325 %attr(755,root,root) %{_bindir}/gda-config-tool-3.0
326 %attr(755,root,root) %{_bindir}/gda-list-server-op-3.0
327 %attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
328 %attr(755,root,root) %ghost %{_libdir}/libgda-3.0.so.3
329 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
330 %attr(755,root,root) %ghost %{_libdir}/libgda-report-3.0.so.3
331 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so.*.*.*
332 %attr(755,root,root) %ghost %{_libdir}/libgda-xslt-3.0.so.0
333 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
334 %attr(755,root,root) %ghost %{_libdir}/libgdasql-3.0.so.3
335 %dir %{_libdir}/%{_libgdadir}
336 %dir %{_providersdir}
337 %{_datadir}/libgda-3.0
338 %dir %{_sysconfdir}/libgda-3.0
339 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
340 %{_mandir}/man1/gda-config-tool-3.0.1*
341 %{_mandir}/man5/gda-config-3.0.5*
342
343 %files devel
344 %defattr(644,root,root,755)
345 %attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
346 %attr(755,root,root) %{_bindir}/gda-bdb-test
347 %attr(755,root,root) %{_bindir}/gda-diagnose-3.0
348 %attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
349 %attr(755,root,root) %{_bindir}/gda-list-config-3.0
350 %attr(755,root,root) %{_bindir}/gda-sql-3.0
351 %attr(755,root,root) %{_bindir}/gda-test-connection-3.0
352 %attr(755,root,root) %{_libdir}/libgda-3.0.so
353 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so
354 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so
355 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so
356 %{_libdir}/libgda-3.0.la
357 %{_libdir}/libgda-report-3.0.la
358 %{_libdir}/libgda-xslt-3.0.la
359 %{_libdir}/libgdasql-3.0.la
360 %{_includedir}/libgda-3.0
361 %{_pkgconfigdir}/libgda-3.0.pc
362 %{_pkgconfigdir}/libgda-*-3.0.pc
363 %{_sysconfdir}/libgda-3.0/sales_test.db
364 %{?with_doc:%{_gtkdocdir}/libgda-3.0}
365
366 %if %{with static_libs}
367 %files static
368 %defattr(644,root,root,755)
369 %{_libdir}/libgda-3.0.a
370 %{_libdir}/libgda-report-3.0.a
371 %{_libdir}/libgda-xslt-3.0.a
372 %{_libdir}/libgdasql-3.0.a
373 %endif
374
375 %files provider-db
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_providersdir}/libgda-bdb.so
378
379 %if %{with firebird}
380 %files provider-firebird
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_providersdir}/libgda-firebird.so
383 %endif
384
385 %if %{with freetds}
386 %files provider-freetds
387 %defattr(644,root,root,755)
388 %attr(755,root,root) %{_providersdir}/libgda-freetds.so
389 %endif
390
391 %if %{with ldap}
392 %files provider-ldap
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_providersdir}/libgda-ldap.so
395 %endif
396
397 %if %{with mdb}
398 %files provider-mdb
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_providersdir}/libgda-mdb.so
401 %endif
402
403 %if %{with mysql}
404 %files provider-mysql
405 %defattr(644,root,root,755)
406 %attr(755,root,root) %{_providersdir}/libgda-mysql.so
407 %endif
408
409 %if %{with odbc}
410 %files provider-odbc
411 %defattr(644,root,root,755)
412 %attr(755,root,root) %{_providersdir}/libgda-odbc.so
413 %endif
414
415 %if %{with pgsql}
416 %files provider-postgres
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_providersdir}/libgda-postgres.so
419 %endif
420
421 %if %{with sqlite}
422 %files provider-sqlite
423 %defattr(644,root,root,755)
424 %attr(755,root,root) %{_providersdir}/libgda-sqlite.so
425 %endif
426
427 %if %{with sybase}
428 %files provider-sybase
429 %defattr(644,root,root,755)
430 %attr(755,root,root) %{_providersdir}/libgda-sybase.so
431 %endif
432
433 %if %{with xbase}
434 %files provider-xbase
435 %defattr(644,root,root,755)
436 %attr(755,root,root) %{_providersdir}/libgda-xbase.so
437 %endif
This page took 0.117357 seconds and 3 git commands to generate.