]> git.pld-linux.org Git - packages/libgda3.git/blob - libgda3.spec
- rel 1
[packages/libgda3.git] / libgda3.spec
1 #
2 # TODO: package dotnet-gda-sharp
3 #
4 # Conditional build:
5 %bcond_without  doc             # don't generate html documentation
6 %bcond_without  static_libs     # don't build static libraries
7 %bcond_with     gamin           # use gamin instead of fam library
8 #
9 %bcond_without  firebird        # build without firebird plugin
10 %bcond_without  freetds         # build without freetds plugin
11 %bcond_without  ldap            # build without ldap plugin
12 %bcond_without  mdb             # build without MDB plugin
13 %bcond_without  mysql           # build without MySQL plugin
14 %bcond_without  odbc            # build without unixODBC
15 %bcond_without  pgsql           # build without PostgreSQL plugin
16 %bcond_without  sqlite          # build without sqlite plugin
17 %bcond_without  xbase           # build without xbase plugin
18 #
19 %ifnarch %{ix86} sparc sparcv9 alpha
20 %undefine       with_firebird
21 %endif
22 Summary:        GNU Data Access library
23 Summary(pl.UTF-8):   Biblioteka GNU Data Access
24 Name:           libgda3
25 Version:        3.1.1
26 Release:        1
27 License:        LGPL v2/GPL v2
28 Group:          Applications/Databases
29 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/3.1/libgda-%{version}.tar.bz2
30 # Source0-md5:  1e56331d2b69094312f1f011bd45177f
31 Patch0:         %{name}-mdb.patch
32 Patch1:         %{name}-configure.patch
33 Patch2:         %{name}-firebird.patch
34 URL:            http://www.gnome-db.org/
35 %{?with_firebird:BuildRequires: Firebird-devel}
36 BuildRequires:  autoconf >= 2.59
37 BuildRequires:  automake >= 1:1.8
38 BuildRequires:  bison
39 BuildRequires:  db-devel
40 %{!?with_gamin:BuildRequires:   fam-devel}
41 BuildRequires:  flex
42 %{?with_freetds:BuildRequires:  freetds-devel >= 0.64}
43 %{?with_gamin:BuildRequires:    gamin-devel}
44 BuildRequires:  glib2-devel >= 1:2.12.0
45 BuildRequires:  gnome-common >= 2.12.0
46 BuildRequires:  gtk-doc >= 1.6
47 BuildRequires:  intltool >= 0.35
48 BuildRequires:  libtool
49 BuildRequires:  libxml2-devel >= 1:.2.6.26
50 BuildRequires:  libxslt-devel >= 1.1.17
51 %{?with_mdb:BuildRequires:      mdbtools-devel >= 0.6}
52 %{?with_mysql:BuildRequires:    mysql-devel}
53 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
54 BuildRequires:  perl-base
55 BuildRequires:  popt-devel
56 %{?with_pgsql:BuildRequires:    postgresql-devel}
57 BuildRequires:  readline-devel >= 5.0
58 BuildRequires:  rpmbuild(macros) >= 1.213
59 %{?with_sqlite:BuildRequires:   sqlite3-devel >= 3.5.0-2}
60 %{?with_odbc:BuildRequires:     unixODBC-devel}
61 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
62 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
63
64 #%define                _libgdadir      libgda-%(echo %{version} | cut -d '.' -f 1-2 )
65 %define         _libgdadir      libgda-3.0
66 %define         _providersdir   %{_libdir}/%{_libgdadir}/providers
67
68 %description
69 GNU Data Access is an attempt to provide uniform access to different
70 kinds of data sources (databases, information servers, mail spools,
71 etc). It is a complete architecture that provides all you need to
72 access your data.
73
74 libgda was part of the GNOME-DB project but has been separated from it
75 to allow non-GNOME applications to be developed based on it.
76
77 %description -l pl.UTF-8
78 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
79 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
80 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
81 potrzebujesz do dostępu do danych.
82
83 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
84 pozwolić na używanie przez niegnomowe aplikacje.
85
86 %package devel
87 Summary:        GNU Data Access development
88 Summary(pl.UTF-8):   Dla programistów GNU Data Access
89 Group:          Development/Libraries
90 Requires:       %{name} = %{version}-%{release}
91 %{!?with_gamin:Requires:        fam-devel}
92 %{?with_gamin:Requires: gamin-devel}
93 Requires:       glib2-devel >= 1:2.12.0
94 Requires:       gtk-doc-common
95 Requires:       libxml2-devel >= 1:2.6.26
96 Requires:       libxslt-devel >= 1.1.17
97 Obsoletes:      libgda0-devel
98
99 %description devel
100 GNU Data Access is an attempt to provide uniform access to different
101 kinds of data sources (databases, information servers, mail spools,
102 etc). It is a complete architecture that provides all you need to
103 access your data. This subpackage contains development files.
104
105 %description devel -l pl.UTF-8
106 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
107 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
108 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
109 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
110 programistów używających libgda.
111
112 %package static
113 Summary:        GNU Data Access static libraries
114 Summary(pl.UTF-8):   Statyczne biblioteki GNU Data Access
115 Group:          Development/Libraries
116 Requires:       %{name}-devel = %{version}-%{release}
117
118 %description static
119 GNU Data Access static libraries.
120
121 %description static -l pl.UTF-8
122 Statyczne biblioteki GNU Data Access.
123
124 %package provider-db
125 Summary:        GDA Berkeley DB provider
126 Summary(pl.UTF-8):   Źródło danych Berkeley DB dla GDA
127 Group:          Applications/Databases
128 Requires:       %{name} = %{version}-%{release}
129
130 %description provider-db
131 This package contains the GDA Berkeley DB provider.
132
133 %description provider-db -l pl.UTF-8
134 Pakiet dostaczający dane z Berkeley DB dla GDA.
135
136 %package provider-firebird
137 Summary:        GDA Firebird provider
138 Summary(pl.UTF-8):   Źródło danych Firebird dla GDA
139 Group:          Applications/Databases
140 Requires:       %{name} = %{version}-%{release}
141
142 %description provider-firebird
143 This package contains the GDA Firebird provider.
144
145 %description provider-firebird -l pl.UTF-8
146 Pakiet dostarczający dane z Firebird dla GDA.
147
148 %package provider-freetds
149 Summary:        GDA FreeTDS provider
150 Summary(pl.UTF-8):   Źródło danych FreeTDS dla GDA
151 Group:          Applications/Databases
152 Requires:       %{name} = %{version}-%{release}
153
154 %description provider-freetds
155 This package contains the GDA FreeTDS provider.
156
157 %description provider-freetds -l pl.UTF-8
158 Pakiet dostarczający dane z FreeTDS dla GDA.
159
160 %package provider-ldap
161 Summary:        GDA LDAP provider
162 Summary(pl.UTF-8):   Źródło danych LDAP dla GDA
163 Group:          Applications/Databases
164 Requires:       %{name} = %{version}-%{release}
165
166 %description provider-ldap
167 This package contains the GDA LDAP provider.
168
169 %description provider-ldap -l pl.UTF-8
170 Pakiet dostarczający dane z LDAP dla GDA
171
172 %package provider-mdb
173 Summary:        GDA MDB provider
174 Summary(pl.UTF-8):   Źródło danych MDB
175 Group:          Applications/Databases
176 Requires:       %{name} = %{version}-%{release}
177 Requires:       mdbtools-libs >= 0.6
178
179 %description provider-mdb
180 This package contains the GDA MDB provider.
181
182 %description provider-mdb -l pl.UTF-8
183 Pakiet dostarczający dane z MDB dla GDA.
184
185 %package provider-mysql
186 Summary:        GDA MySQL provider
187 Summary(pl.UTF-8):   Źródło danych MySQL dla GDA
188 Group:          Applications/Databases
189 Requires:       %{name} = %{version}-%{release}
190 Obsoletes:      libgda-mysql0
191
192 %description provider-mysql
193 This package contains the GDA MySQL provider.
194
195 %description provider-mysql -l pl.UTF-8
196 Pakiet dostarczający dane z MySQL dla GDA.
197
198 %package provider-odbc
199 Summary:        GDA ODBC provider
200 Summary(pl.UTF-8):   Źródło danych ODBC dla GDA
201 Group:          Applications/Databases
202 Requires:       %{name} = %{version}-%{release}
203
204 %description provider-odbc
205 This package contains the GDA ODBC provider.
206
207 %description provider-odbc -l pl.UTF-8
208 Pakiet dostarczający dane z ODBC dla GDA.
209
210 %package provider-postgres
211 Summary:        GDA PostgreSQL provider
212 Summary(pl.UTF-8):   Źródło danych PostgreSQL dla GDA
213 Group:          Applications/Databases
214 Requires:       %{name} = %{version}-%{release}
215 Obsoletes:      libgda-postgres0
216
217 %description provider-postgres
218 This package contains the GDA PostgreSQL provider.
219
220 %description provider-postgres -l pl.UTF-8
221 Pakiet dostarczający dane z PostgreSQL dla GDA.
222
223 %package provider-sqlite
224 Summary:        GDA SQLite provider
225 Summary(pl.UTF-8):   Źródło danych SQLite dla GDA
226 Group:          Applications/Databases
227 Requires:       %{name} = %{version}-%{release}
228
229 %description provider-sqlite
230 This package contains the GDA SQLite provider.
231
232 %description provider-sqlite -l pl.UTF-8
233 Pakiet dostarczający dane z SQLite dla GDA.
234
235 %package provider-xbase
236 Summary:        GDA xBase provider
237 Summary(pl.UTF-8):   Źródło danych xBase dla GDA
238 Group:          Applications/Databases
239 Requires:       %{name} = %{version}-%{release}
240
241 %description provider-xbase
242 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
243
244 %description provider-xbase -l pl.UTF-8
245 Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
246
247 %prep
248 %setup -q -n libgda-%{version}
249 %patch0 -p1
250 %patch1 -p1
251 %patch2 -p1
252
253 %if ! %{with gamin}
254 sed -i -e 's#\(PKG_CHECK_MODULES(GAMIN.*\)#dnl \1#g' configure.in
255 %endif
256
257 %build
258 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
259 %{__intltoolize}
260 %{__libtoolize}
261 %{__aclocal}
262 %{__autoconf}
263 %{__automake}
264 %configure \
265         %{?with_doc:--enable-gtk-doc} \
266         %{!?with_static_libs:--enable-static=no} \
267         --with-html-dir=%{_gtkdocdir} \
268         --with%{!?with_firebird:out}-firebird \
269         --with%{!?with_ldap:out}-ldap \
270         --with%{!?with_mdb:out}-mdb \
271         --with%{!?with_mysql:out}-mysql \
272         --with%{!?with_odbc:out}-odbc \
273         --with%{!?with_pgsql:out}-postgres \
274         --with%{!?with_sqlite:out}-sqlite \
275         --with%{!?with_freetds:out}-tds \
276         --with%{!?with_xbase:out}-xbase \
277         --without-oracle
278 %{__make} -j1
279
280 %install
281 rm -rf $RPM_BUILD_ROOT
282
283 %{__make} install \
284         DESTDIR=$RPM_BUILD_ROOT \
285         HTML_DIR=%{_gtkdocdir}
286
287 # modules dlopened by *.so through libgmodule
288 # Needs to resolve problem with libgda-sqlite.la
289 # rm -f $RPM_BUILD_ROOT%{_providersdir}/*.{a,la}
290 rm -f $RPM_BUILD_ROOT%{_providersdir}/*.a
291
292 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
293
294 %find_lang libgda-3.0
295
296 %clean
297 rm -rf $RPM_BUILD_ROOT
298
299 %post   -p /sbin/ldconfig
300 %postun -p /sbin/ldconfig
301
302 %files -f libgda-3.0.lang
303 %defattr(644,root,root,755)
304 %doc AUTHORS ChangeLog NEWS README
305 %attr(755,root,root) %{_bindir}/gda-config-tool-3.0
306 %attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
307 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
308 %attr(755,root,root) %{_libdir}/libgda-virtual-3.0.so
309 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
310 %dir %{_libdir}/%{_libgdadir}
311 %dir %{_providersdir}
312 %{_datadir}/libgda-3.0
313 %dir %{_sysconfdir}/libgda-3.0
314 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
315 %{_mandir}/man1/gda-config-tool-3.0.1*
316 %{_mandir}/man5/gda-config-3.0.5*
317
318 %files devel
319 %defattr(644,root,root,755)
320 %attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
321 %attr(755,root,root) %{_bindir}/gda-bdb-test
322 %attr(755,root,root) %{_bindir}/gda-diagnose-3.0
323 %attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
324 %attr(755,root,root) %{_bindir}/gda-list-config-3.0
325 #%attr(755,root,root) %{_bindir}/gda-report-test-3.0
326 #%attr(755,root,root) %{_bindir}/gda-run-3.0
327 %attr(755,root,root) %{_bindir}/gda-sql-3.0
328 %attr(755,root,root) %{_bindir}/gda-test-connection-3.0
329 %attr(755,root,root) %{_libdir}/libgda-3.0.so
330 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so
331 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so
332 %{_libdir}/libgda-3.0.la
333 %{_libdir}/libgda-report-3.0.la
334 %{_libdir}/libgdasql-3.0.la
335 %{_libdir}/libgda-virtual-3.0.la
336 %{_includedir}/libgda-3.0
337 %{_pkgconfigdir}/libgda-3.0.pc
338 %{_pkgconfigdir}/libgda-*-3.0.pc
339 %{?with_doc:%{_gtkdocdir}/libgda-3.0}
340 %{_sysconfdir}/libgda-3.0/sales_test.db
341
342 %if %{with static_libs}
343 %files static
344 %defattr(644,root,root,755)
345 %{_libdir}/libgda-3.0.a
346 %{_libdir}/libgda-report-3.0.a
347 %{_libdir}/libgdasql-3.0.a
348 %{_libdir}/libgda-virtual-3.0.a
349 %endif
350
351 %files provider-db
352 %defattr(644,root,root,755)
353 %attr(755,root,root) %{_providersdir}/libgda-bdb.so
354
355 %if %{with firebird}
356 %files provider-firebird
357 %defattr(644,root,root,755)
358 %attr(755,root,root) %{_providersdir}/libgda-firebird.so
359 %endif
360
361 %if %{with freetds}
362 %files provider-freetds
363 %defattr(644,root,root,755)
364 %attr(755,root,root) %{_providersdir}/libgda-freetds.so
365 %endif
366
367 %if %{with ldap}
368 %files provider-ldap
369 %defattr(644,root,root,755)
370 %attr(755,root,root) %{_providersdir}/libgda-ldap.so
371 %endif
372
373 %if %{with mdb}
374 %files provider-mdb
375 %defattr(644,root,root,755)
376 %attr(755,root,root) %{_providersdir}/libgda-mdb.so
377 %endif
378
379 %if %{with mysql}
380 %files provider-mysql
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_providersdir}/libgda-mysql.so
383 %endif
384
385 %if %{with odbc}
386 %files provider-odbc
387 %defattr(644,root,root,755)
388 %attr(755,root,root) %{_providersdir}/libgda-odbc.so
389 %endif
390
391 %if %{with pgsql}
392 %files provider-postgres
393 %defattr(644,root,root,755)
394 %attr(755,root,root) %{_providersdir}/libgda-postgres.so
395 %endif
396
397 %if %{with sqlite}
398 %files provider-sqlite
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_providersdir}/libgda-sqlite.so
401 %{_providersdir}/libgda-sqlite.la
402 %endif
403
404 %if %{with xbase}
405 %files provider-xbase
406 %defattr(644,root,root,755)
407 %attr(755,root,root) %{_providersdir}/libgda-xbase.so
408 %endif
This page took 0.048873 seconds and 3 git commands to generate.