]> git.pld-linux.org Git - packages/libgda3.git/blob - libgda3.spec
- stick to mdbtools >= 0.6 to get stable builds
[packages/libgda3.git] / libgda3.spec
1 #
2 # TODO: package dotnet-gda-sharp
3 #
4 # Conditional build:
5 %bcond_without  doc             # don't generate html documentation
6 %bcond_without  static_libs     # don't build static libraries
7 %bcond_with     gamin           # use gamin instead of fam library
8 #
9 %bcond_without  firebird        # build without firebird plugin
10 %bcond_without  freetds         # build without freetds plugin
11 %bcond_without  ldap            # build without ldap plugin
12 %bcond_without  mdb             # build without MDB plugin
13 %bcond_without  mysql           # build without MySQL plugin
14 %bcond_without  odbc            # build without unixODBC
15 %bcond_without  pgsql           # build without PostgreSQL plugin
16 %bcond_without  sqlite          # build without sqlite plugin
17 %bcond_without  xbase           # build without xbase plugin
18 #
19 %ifnarch %{ix86} sparc sparcv9 alpha
20 %undefine       with_firebird
21 %endif
22 Summary:        GNU Data Access library
23 Summary(pl.UTF-8):   Biblioteka GNU Data Access
24 Name:           libgda3
25 Version:        3.0.1
26 Release:        2
27 License:        LGPL v2/GPL v2
28 Group:          Applications/Databases
29 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/3.0/libgda-%{version}.tar.bz2
30 # Source0-md5:  1aaf23c27ba94d0b231f2b123350110a
31 Patch0:         %{name}-mdb.patch
32 Patch1:         %{name}-configure.patch
33 Patch2:         %{name}-firebird.patch
34 %{?with_firebird:BuildRequires: Firebird-devel}
35 BuildRequires:  autoconf >= 2.59
36 BuildRequires:  automake >= 1:1.8
37 BuildRequires:  bison
38 BuildRequires:  db-devel
39 %{!?with_gamin:BuildRequires:   fam-devel}
40 BuildRequires:  flex
41 %{?with_freetds:BuildRequires:  freetds-devel >= 0.64}
42 %{?with_gamin:BuildRequires:    gamin-devel}
43 BuildRequires:  glib2-devel >= 1:2.12.0
44 BuildRequires:  gnome-common >= 2.12.0
45 BuildRequires:  gtk-doc >= 1.6
46 BuildRequires:  intltool >= 0.35
47 BuildRequires:  libtool
48 BuildRequires:  libxml2-devel >= 1:.2.6.26
49 BuildRequires:  libxslt-devel >= 1.1.17
50 %{?with_mdb:BuildRequires:      mdbtools-devel >= 0.6}
51 %{?with_mysql:BuildRequires:    mysql-devel}
52 %{?with_ldap:BuildRequires:     openldap-devel >= 2.3.0}
53 BuildRequires:  perl-base
54 BuildRequires:  popt-devel
55 %{?with_pgsql:BuildRequires:    postgresql-devel}
56 BuildRequires:  readline-devel >= 5.0
57 BuildRequires:  rpmbuild(macros) >= 1.213
58 #%{?with_sqlite:BuildRequires:  sqlite3-devel >= 3.3.100}
59 %{?with_odbc:BuildRequires:     unixODBC-devel}
60 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _libgdadir      libgda-%(echo %{version} | cut -d '.' -f 1-2 )
64 %define         _providersdir   %{_libdir}/%{_libgdadir}/providers
65
66 %description
67 GNU Data Access is an attempt to provide uniform access to different
68 kinds of data sources (databases, information servers, mail spools,
69 etc). It is a complete architecture that provides all you need to
70 access your data.
71
72 libgda was part of the GNOME-DB project but has been separated from it
73 to allow non-GNOME applications to be developed based on it.
74
75 %description -l pl.UTF-8
76 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
77 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
78 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
79 potrzebujesz do dostępu do danych.
80
81 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
82 pozwolić na używanie przez niegnomowe aplikacje.
83
84 %package devel
85 Summary:        GNU Data Access development
86 Summary(pl.UTF-8):   Dla programistów GNU Data Access
87 Group:          Development/Libraries
88 Requires:       %{name} = %{version}-%{release}
89 %{!?with_gamin:Requires:        fam-devel}
90 %{?with_gamin:Requires: gamin-devel}
91 Requires:       glib2-devel >= 1:2.12.0
92 Requires:       gtk-doc-common
93 Requires:       libxml2-devel >= 1:2.6.26
94 Requires:       libxslt-devel >= 1.1.17
95 Obsoletes:      libgda0-devel
96
97 %description devel
98 GNU Data Access is an attempt to provide uniform access to different
99 kinds of data sources (databases, information servers, mail spools,
100 etc). It is a complete architecture that provides all you need to
101 access your data. This subpackage contains development files.
102
103 %description devel -l pl.UTF-8
104 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
105 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
106 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
107 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
108 programistów używających libgda.
109
110 %package static
111 Summary:        GNU Data Access static libraries
112 Summary(pl.UTF-8):   Statyczne biblioteki GNU Data Access
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}-%{release}
115
116 %description static
117 GNU Data Access static libraries.
118
119 %description static -l pl.UTF-8
120 Statyczne biblioteki GNU Data Access.
121
122 %package provider-db
123 Summary:        GDA Berkeley DB provider
124 Summary(pl.UTF-8):   Źródło danych Berkeley DB dla GDA
125 Group:          Applications/Databases
126 Requires:       %{name} = %{version}-%{release}
127
128 %description provider-db
129 This package contains the GDA Berkeley DB provider.
130
131 %description provider-db -l pl.UTF-8
132 Pakiet dostaczający dane z Berkeley DB dla GDA.
133
134 %package provider-firebird
135 Summary:        GDA Firebird provider
136 Summary(pl.UTF-8):   Źródło danych Firebird dla GDA
137 Group:          Applications/Databases
138 Requires:       %{name} = %{version}-%{release}
139
140 %description provider-firebird
141 This package contains the GDA Firebird provider.
142
143 %description provider-firebird -l pl.UTF-8
144 Pakiet dostarczający dane z Firebird dla GDA.
145
146 %package provider-freetds
147 Summary:        GDA FreeTDS provider
148 Summary(pl.UTF-8):   Źródło danych FreeTDS dla GDA
149 Group:          Applications/Databases
150 Requires:       %{name} = %{version}-%{release}
151
152 %description provider-freetds
153 This package contains the GDA FreeTDS provider.
154
155 %description provider-freetds -l pl.UTF-8
156 Pakiet dostarczający dane z FreeTDS dla GDA.
157
158 %package provider-ldap
159 Summary:        GDA LDAP provider
160 Summary(pl.UTF-8):   Źródło danych LDAP dla GDA
161 Group:          Applications/Databases
162 Requires:       %{name} = %{version}-%{release}
163
164 %description provider-ldap
165 This package contains the GDA LDAP provider.
166
167 %description provider-ldap -l pl.UTF-8
168 Pakiet dostarczający dane z LDAP dla GDA
169
170 %package provider-mdb
171 Summary:        GDA MDB provider
172 Summary(pl.UTF-8):   Źródło danych MDB
173 Group:          Applications/Databases
174 Requires:       %{name} = %{version}-%{release}
175 Requires:       mdbtools-libs >= 0.6
176
177 %description provider-mdb
178 This package contains the GDA MDB provider.
179
180 %description provider-mdb -l pl.UTF-8
181 Pakiet dostarczający dane z MDB dla GDA.
182
183 %package provider-mysql
184 Summary:        GDA MySQL provider
185 Summary(pl.UTF-8):   Źródło danych MySQL dla GDA
186 Group:          Applications/Databases
187 Requires:       %{name} = %{version}-%{release}
188 Obsoletes:      libgda-mysql0
189
190 %description provider-mysql
191 This package contains the GDA MySQL provider.
192
193 %description provider-mysql -l pl.UTF-8
194 Pakiet dostarczający dane z MySQL dla GDA.
195
196 %package provider-odbc
197 Summary:        GDA ODBC provider
198 Summary(pl.UTF-8):   Źródło danych ODBC dla GDA
199 Group:          Applications/Databases
200 Requires:       %{name} = %{version}-%{release}
201
202 %description provider-odbc
203 This package contains the GDA ODBC provider.
204
205 %description provider-odbc -l pl.UTF-8
206 Pakiet dostarczający dane z ODBC dla GDA.
207
208 %package provider-postgres
209 Summary:        GDA PostgreSQL provider
210 Summary(pl.UTF-8):   Źródło danych PostgreSQL dla GDA
211 Group:          Applications/Databases
212 Requires:       %{name} = %{version}-%{release}
213 Obsoletes:      libgda-postgres0
214
215 %description provider-postgres
216 This package contains the GDA PostgreSQL provider.
217
218 %description provider-postgres -l pl.UTF-8
219 Pakiet dostarczający dane z PostgreSQL dla GDA.
220
221 %package provider-sqlite
222 Summary:        GDA SQLite provider
223 Summary(pl.UTF-8):   Źródło danych SQLite dla GDA
224 Group:          Applications/Databases
225 Requires:       %{name} = %{version}-%{release}
226
227 %description provider-sqlite
228 This package contains the GDA SQLite provider.
229
230 %description provider-sqlite -l pl.UTF-8
231 Pakiet dostarczający dane z SQLite dla GDA.
232
233 %package provider-xbase
234 Summary:        GDA xBase provider
235 Summary(pl.UTF-8):   Źródło danych xBase dla GDA
236 Group:          Applications/Databases
237 Requires:       %{name} = %{version}-%{release}
238
239 %description provider-xbase
240 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
241
242 %description provider-xbase -l pl.UTF-8
243 Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
244
245 %prep
246 %setup -q -n libgda-%{version}
247 %patch0 -p1
248 %patch1 -p1
249 %patch2 -p1
250
251 %if ! %{with gamin}
252 sed -i -e 's#\(PKG_CHECK_MODULES(GAMIN.*\)#dnl \1#g' configure.in
253 %endif
254
255 %build
256 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
257 %{__intltoolize}
258 %{__libtoolize}
259 %{__aclocal}
260 %{__autoconf}
261 %{__automake}
262 %configure \
263         %{?with_doc:--enable-gtk-doc} \
264         %{!?with_static_libs:--enable-static=no} \
265         --with-html-dir=%{_gtkdocdir} \
266         --with%{!?with_firebird:out}-firebird \
267         --with%{!?with_ldap:out}-ldap \
268         --with%{!?with_mdb:out}-mdb \
269         --with%{!?with_mysql:out}-mysql \
270         --with%{!?with_odbc:out}-odbc \
271         --with%{!?with_pgsql:out}-postgres \
272         --with%{!?with_sqlite:out}-sqlite \
273         --with%{!?with_freetds:out}-tds \
274         --with%{!?with_xbase:out}-xbase \
275         --without-oracle
276 %{__make} -j1
277
278 %install
279 rm -rf $RPM_BUILD_ROOT
280
281 %{__make} install \
282         DESTDIR=$RPM_BUILD_ROOT \
283         HTML_DIR=%{_gtkdocdir}
284
285 # modules dlopened by *.so through libgmodule
286 rm -f $RPM_BUILD_ROOT%{_providersdir}/*.{a,la}
287
288 rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
289
290 %find_lang libgda-3.0
291
292 %clean
293 rm -rf $RPM_BUILD_ROOT
294
295 %post   -p /sbin/ldconfig
296 %postun -p /sbin/ldconfig
297
298 %files -f libgda-3.0.lang
299 %defattr(644,root,root,755)
300 %doc AUTHORS ChangeLog NEWS README
301 %attr(755,root,root) %{_bindir}/gda-config-tool-3.0
302 %attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
303 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
304 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
305 %dir %{_libdir}/%{_libgdadir}
306 %dir %{_providersdir}
307 %{_datadir}/libgda-3.0
308 %dir %{_sysconfdir}/libgda-3.0
309 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
310 %{_mandir}/man1/gda-config-tool-3.0.1*
311 %{_mandir}/man5/gda-config-3.0.5*
312
313 %files devel
314 %defattr(644,root,root,755)
315 %attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
316 %attr(755,root,root) %{_bindir}/gda-diagnose-3.0
317 %attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
318 %attr(755,root,root) %{_bindir}/gda-list-config-3.0
319 %attr(755,root,root) %{_bindir}/gda-report-test-3.0
320 %attr(755,root,root) %{_bindir}/gda-run-3.0
321 %attr(755,root,root) %{_bindir}/gda-test-connection-3.0
322 %attr(755,root,root) %{_libdir}/libgda-3.0.so
323 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so
324 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so
325 %{_libdir}/libgda-3.0.la
326 %{_libdir}/libgda-report-3.0.la
327 %{_libdir}/libgdasql-3.0.la
328 %{_includedir}/libgda-3.0
329 %{_pkgconfigdir}/libgda-3.0.pc
330 %{_pkgconfigdir}/libgda-*-3.0.pc
331 %{?with_doc:%{_gtkdocdir}/libgda-3.0}
332
333 %if %{with static_libs}
334 %files static
335 %defattr(644,root,root,755)
336 %{_libdir}/libgda-3.0.a
337 %{_libdir}/libgda-report-3.0.a
338 %{_libdir}/libgdasql-3.0.a
339 %endif
340
341 %files provider-db
342 %defattr(644,root,root,755)
343 %attr(755,root,root) %{_providersdir}/libgda-bdb.so
344
345 %if %{with firebird}
346 %files provider-firebird
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_providersdir}/libgda-firebird.so
349 %endif
350
351 %if %{with freetds}
352 %files provider-freetds
353 %defattr(644,root,root,755)
354 %attr(755,root,root) %{_providersdir}/libgda-freetds.so
355 %endif
356
357 %if %{with ldap}
358 %files provider-ldap
359 %defattr(644,root,root,755)
360 %attr(755,root,root) %{_providersdir}/libgda-ldap.so
361 %endif
362
363 %if %{with mdb}
364 %files provider-mdb
365 %defattr(644,root,root,755)
366 %attr(755,root,root) %{_providersdir}/libgda-mdb.so
367 %endif
368
369 %if %{with mysql}
370 %files provider-mysql
371 %defattr(644,root,root,755)
372 %attr(755,root,root) %{_providersdir}/libgda-mysql.so
373 %endif
374
375 %if %{with odbc}
376 %files provider-odbc
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_providersdir}/libgda-odbc.so
379 %endif
380
381 %if %{with pgsql}
382 %files provider-postgres
383 %defattr(644,root,root,755)
384 %attr(755,root,root) %{_providersdir}/libgda-postgres.so
385 %endif
386
387 %if %{with sqlite}
388 %files provider-sqlite
389 %defattr(644,root,root,755)
390 %attr(755,root,root) %{_providersdir}/libgda-sqlite.so
391 %endif
392
393 %if %{with xbase}
394 %files provider-xbase
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_providersdir}/libgda-xbase.so
397 %endif
This page took 1.890594 seconds and 3 git commands to generate.