]> git.pld-linux.org Git - packages/libgda3.git/blob - libgda3.spec
0dfe5c3b8a6e3b8b67b4b3f2f6ef8572d7f56b77
[packages/libgda3.git] / libgda3.spec
1 #
2 # TODO: package dotnet-gda-sharp
3 #
4 # Conditional build:
5 %bcond_without  doc             # don't generate html documentation
6 %bcond_without  static_libs     # don't build static libraries
7 %bcond_with     gamin           # use gamin instead of fam library
8 %bcond_without  gnomevfs        # build without gnome-vfs support
9 %bcond_without  gnome           # without gnomevfs (convenience alias)
10 # - database plugins:
11 %bcond_without  firebird        # build without firebird plugin
12 %bcond_with     freetds         # build with freetds plugin
13 %bcond_without  ldap            # build without ldap plugin
14 %bcond_without  mdb             # build without MDB plugin
15 %bcond_without  mysql           # build without MySQL plugin
16 %bcond_without  odbc            # build without unixODBC
17 %bcond_without  pgsql           # build without PostgreSQL plugin
18 %bcond_without  sqlite          # build without sqlite plugin
19 %bcond_without  sybase          # build without sybase plugin
20 %bcond_without  xbase           # build without xbase plugin
21 #
22 %if %{without gnome}
23 %undefine       with_gnomevfs
24 %endif
25 %ifnarch %{ix86} sparc sparcv9 alpha
26 %undefine       with_firebird
27 %endif
28 Summary:        GNU Data Access library
29 Summary(pl.UTF-8):      Biblioteka GNU Data Access
30 Name:           libgda3
31 Version:        3.1.5
32 Release:        6
33 License:        LGPL v2+/GPL v2+
34 Group:          Libraries
35 Source0:        http://ftp.gnome.org/pub/gnome/sources/libgda/3.1/libgda-%{version}.tar.bz2
36 # Source0-md5:  eb7da5286a112e7cff3111c89fba4456
37 Patch0:         %{name}-configure.patch
38 Patch1:         %{name}-am.patch
39 URL:            http://www.gnome-db.org/
40 %{?with_firebird:BuildRequires: Firebird-devel}
41 BuildRequires:  autoconf >= 2.59
42 BuildRequires:  automake >= 1:1.8
43 BuildRequires:  bison
44 BuildRequires:  db-devel
45 BuildRequires:  docbook-dtd412-xml
46 %{!?with_gamin:BuildRequires:   fam-devel}
47 BuildRequires:  flex
48 %{?with_freetds:BuildRequires:  freetds-devel = 0.64}
49 %{?with_sybase:BuildRequires:   freetds-devel >= 0.82}
50 %{?with_gamin:BuildRequires:    gamin-devel >= 0.1.8}
51 BuildRequires:  gettext-devel
52 BuildRequires:  glib2-devel >= 1:2.12.0
53 BuildRequires:  gnome-common >= 2.12.0
54 %{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.20}
55 BuildRequires:  gtk-doc >= 1.6
56 BuildRequires:  intltool >= 0.35.5
57 BuildRequires:  libgcrypt-devel >= 1.1.42
58 BuildRequires:  libtool
59 BuildRequires:  libxml2-devel >= 1:2.6.26
60 BuildRequires:  libxslt-devel >= 1.1.17
61 %{?with_mdb:BuildRequires:      mdbtools-devel >= 0.6}
62 %{?with_mysql:BuildRequires:    mysql-devel}
63 %{?with_ldap:BuildRequires:     openldap-devel >= 2.4.6}
64 BuildRequires:  perl-base
65 BuildRequires:  pkgconfig
66 BuildRequires:  popt-devel
67 %{?with_pgsql:BuildRequires:    postgresql-devel}
68 BuildRequires:  readline-devel >= 5.0
69 BuildRequires:  rpmbuild(macros) >= 1.213
70 %{?with_sqlite:BuildRequires:   sqlite3-devel >= 3.5.0-2}
71 %{?with_odbc:BuildRequires:     unixODBC-devel}
72 %{?with_xbase:BuildRequires:    xbase-devel >= 2.0.0}
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _libgdadir      libgda-3.0
76 %define         _providersdir   %{_libdir}/%{_libgdadir}/providers
77
78 %description
79 GNU Data Access is an attempt to provide uniform access to different
80 kinds of data sources (databases, information servers, mail spools,
81 etc). It is a complete architecture that provides all you need to
82 access your data.
83
84 libgda was part of the GNOME-DB project but has been separated from it
85 to allow non-GNOME applications to be developed based on it.
86
87 %description -l pl.UTF-8
88 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
89 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
90 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
91 potrzebujesz do dostępu do danych.
92
93 libgda była częścią projektu GNOME-DB, ale została wydzielona, aby
94 pozwolić na używanie przez niegnomowe aplikacje.
95
96 %package devel
97 Summary:        GNU Data Access development files
98 Summary(pl.UTF-8):      Pliki programistyczne biblioteki GNU Data Access
99 Group:          Development/Libraries
100 Requires:       %{name} = %{version}-%{release}
101 %{!?with_gamin:Requires:        fam-devel}
102 %{?with_gamin:Requires: gamin-devel >= 0.1.8}
103 Requires:       glib2-devel >= 1:2.12.0
104 %{?with_gnomevfs:Requires:      gnome-vfs2-devel >= 2.20}
105 Requires:       gtk-doc-common
106 Requires:       libgcrypt-devel >= 1.1.42
107 Requires:       libxml2-devel >= 1:2.6.26
108 Requires:       libxslt-devel >= 1.1.17
109 Obsoletes:      libgda0-devel
110
111 %description devel
112 GNU Data Access is an attempt to provide uniform access to different
113 kinds of data sources (databases, information servers, mail spools,
114 etc). It is a complete architecture that provides all you need to
115 access your data. This subpackage contains development files.
116
117 %description devel -l pl.UTF-8
118 GNU Data Access to próba zapewnienia jednolitego dostępu do różnych
119 źródeł danych (bazy danych, serwery informacji, katalogi z pocztą
120 itp.). Jest kompletną architekturą dostarczającą wszystko, czego
121 potrzebujesz do dostępu do danych. Ten podpakiet zawiera pliki dla
122 programistów używających libgda.
123
124 %package static
125 Summary:        GNU Data Access static libraries
126 Summary(pl.UTF-8):      Statyczne biblioteki GNU Data Access
127 Group:          Development/Libraries
128 Requires:       %{name}-devel = %{version}-%{release}
129
130 %description static
131 GNU Data Access static libraries.
132
133 %description static -l pl.UTF-8
134 Statyczne biblioteki GNU Data Access.
135
136 %package provider-db
137 Summary:        GDA Berkeley DB provider
138 Summary(pl.UTF-8):      Źródło danych Berkeley DB dla GDA
139 Group:          Libraries
140 Requires:       %{name} = %{version}-%{release}
141
142 %description provider-db
143 This package contains the GDA Berkeley DB provider.
144
145 %description provider-db -l pl.UTF-8
146 Pakiet dostaczający dane z Berkeley DB dla GDA.
147
148 %package provider-firebird
149 Summary:        GDA Firebird provider
150 Summary(pl.UTF-8):      Źródło danych Firebird dla GDA
151 Group:          Libraries
152 Requires:       %{name} = %{version}-%{release}
153
154 %description provider-firebird
155 This package contains the GDA Firebird provider.
156
157 %description provider-firebird -l pl.UTF-8
158 Pakiet dostarczający dane z Firebird dla GDA.
159
160 %package provider-freetds
161 Summary:        GDA FreeTDS provider
162 Summary(pl.UTF-8):      Źródło danych FreeTDS dla GDA
163 Group:          Libraries
164 Requires:       %{name} = %{version}-%{release}
165
166 %description provider-freetds
167 This package contains the GDA FreeTDS provider.
168
169 %description provider-freetds -l pl.UTF-8
170 Pakiet dostarczający dane z FreeTDS dla GDA.
171
172 %package provider-ldap
173 Summary:        GDA LDAP provider
174 Summary(pl.UTF-8):      Źródło danych LDAP dla GDA
175 Group:          Libraries
176 Requires:       %{name} = %{version}-%{release}
177
178 %description provider-ldap
179 This package contains the GDA LDAP provider.
180
181 %description provider-ldap -l pl.UTF-8
182 Pakiet dostarczający dane z LDAP dla GDA
183
184 %package provider-mdb
185 Summary:        GDA MDB provider
186 Summary(pl.UTF-8):      Źródło danych MDB
187 Group:          Libraries
188 Requires:       %{name} = %{version}-%{release}
189 Requires:       mdbtools-libs >= 0.6
190
191 %description provider-mdb
192 This package contains the GDA MDB provider.
193
194 %description provider-mdb -l pl.UTF-8
195 Pakiet dostarczający dane z MDB dla GDA.
196
197 %package provider-mysql
198 Summary:        GDA MySQL provider
199 Summary(pl.UTF-8):      Źródło danych MySQL dla GDA
200 Group:          Libraries
201 Requires:       %{name} = %{version}-%{release}
202 Obsoletes:      libgda-mysql0
203
204 %description provider-mysql
205 This package contains the GDA MySQL provider.
206
207 %description provider-mysql -l pl.UTF-8
208 Pakiet dostarczający dane z MySQL dla GDA.
209
210 %package provider-odbc
211 Summary:        GDA ODBC provider
212 Summary(pl.UTF-8):      Źródło danych ODBC dla GDA
213 Group:          Libraries
214 Requires:       %{name} = %{version}-%{release}
215
216 %description provider-odbc
217 This package contains the GDA ODBC provider.
218
219 %description provider-odbc -l pl.UTF-8
220 Pakiet dostarczający dane z ODBC dla GDA.
221
222 %package provider-postgres
223 Summary:        GDA PostgreSQL provider
224 Summary(pl.UTF-8):      Źródło danych PostgreSQL dla GDA
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227 Obsoletes:      libgda-postgres0
228
229 %description provider-postgres
230 This package contains the GDA PostgreSQL provider.
231
232 %description provider-postgres -l pl.UTF-8
233 Pakiet dostarczający dane z PostgreSQL dla GDA.
234
235 %package provider-sqlite
236 Summary:        GDA SQLite provider
237 Summary(pl.UTF-8):      Źródło danych SQLite dla GDA
238 Group:          Libraries
239 Requires:       %{name} = %{version}-%{release}
240
241 %description provider-sqlite
242 This package contains the GDA SQLite provider.
243
244 %description provider-sqlite -l pl.UTF-8
245 Pakiet dostarczający dane z SQLite dla GDA.
246
247 %package provider-sybase
248 Summary:        GDA Sybase provider
249 Summary(pl.UTF-8):      Źródło danych Sybase dla GDA
250 Group:          Libraries
251 Requires:       %{name} = %{version}-%{release}
252
253 %description provider-sybase
254 This package contains the GDA Sybase provider.
255
256 %description provider-sybase -l pl.UTF-8
257 Pakiet dostarczający dane z Sybase dla GDA.
258
259 %package provider-xbase
260 Summary:        GDA xBase provider
261 Summary(pl.UTF-8):      Źródło danych xBase dla GDA
262 Group:          Libraries
263 Requires:       %{name} = %{version}-%{release}
264
265 %description provider-xbase
266 This package contains the GDA xBase (dBase, Clipper, FoxPro) provider.
267
268 %description provider-xbase -l pl.UTF-8
269 Pakiet dostarczający dane z xBase (dBase, Clippera, FoxPro) dla GDA.
270
271 %prep
272 %setup -q -n libgda-%{version}
273 %patch0 -p1
274 %patch1 -p1
275
276 %if %{without gamin}
277 sed -i -e 's#PKG_CHECK_MODULES(GAMIN.*)#have_fam=no#g' configure.in
278 %endif
279 %if %{without gnomevfs}
280 sed -i -e 's#PKG_CHECK_MODULES(GNOMEVFS.*)#have_gnomevfs=no#g' configure.in
281 %endif
282
283 %build
284 CXXFLAGS="%{rpmcxxflags} -fno-rtti -fno-exceptions"
285 %{__intltoolize}
286 %{__libtoolize}
287 %{__aclocal}
288 %{__autoconf}
289 %{__automake}
290 %configure \
291         %{!?with_static_libs:--disable-static} \
292         %{?with_doc:--enable-gtk-doc} \
293         --with-html-dir=%{_gtkdocdir} \
294         --with%{!?with_firebird:out}-firebird \
295         --with%{!?with_ldap:out}-ldap \
296         --with%{!?with_mdb:out}-mdb \
297         --with%{!?with_mysql:out}-mysql \
298         --with%{!?with_odbc:out}-odbc \
299         --with%{!?with_pgsql:out}-postgres \
300         --with%{!?with_sqlite:out}-sqlite \
301         --with%{!?with_freetds:out}-tds \
302         --with%{!?with_xbase:out}-xbase \
303         %{?with_sybase:--with-sybase=/usr} \
304         --without-oracle
305 %{__make} -j1
306
307 %install
308 rm -rf $RPM_BUILD_ROOT
309
310 %{__make} install \
311         DESTDIR=$RPM_BUILD_ROOT \
312         HTML_DIR=%{_gtkdocdir}
313
314 # modules dlopened by *.so through libgmodule
315 rm -f $RPM_BUILD_ROOT%{_providersdir}/*.{a,la}
316
317 %find_lang libgda-3.0
318
319 %clean
320 rm -rf $RPM_BUILD_ROOT
321
322 %post   -p /sbin/ldconfig
323 %postun -p /sbin/ldconfig
324
325 %files -f libgda-3.0.lang
326 %defattr(644,root,root,755)
327 %doc AUTHORS ChangeLog NEWS README
328 %attr(755,root,root) %{_bindir}/gda-config-tool-3.0
329 %attr(755,root,root) %{_bindir}/gda-list-server-op-3.0
330 %attr(755,root,root) %{_libdir}/libgda-3.0.so.*.*.*
331 %attr(755,root,root) %ghost %{_libdir}/libgda-3.0.so.3
332 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so.*.*.*
333 %attr(755,root,root) %ghost %{_libdir}/libgda-report-3.0.so.3
334 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so.*.*.*
335 %attr(755,root,root) %ghost %{_libdir}/libgda-xslt-3.0.so.0
336 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so.*.*.*
337 %attr(755,root,root) %ghost %{_libdir}/libgdasql-3.0.so.3
338 %dir %{_libdir}/%{_libgdadir}
339 %dir %{_providersdir}
340 %{_datadir}/libgda-3.0
341 %dir %{_sysconfdir}/libgda-3.0
342 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libgda-3.0/config
343 %{_mandir}/man1/gda-config-tool-3.0.1*
344 %{_mandir}/man5/gda-config-3.0.5*
345
346 %files devel
347 %defattr(644,root,root,755)
348 %attr(755,root,root) %{_bindir}/gda-author-dict-file-3.0
349 %attr(755,root,root) %{_bindir}/gda-bdb-test
350 %attr(755,root,root) %{_bindir}/gda-diagnose-3.0
351 %attr(755,root,root) %{_bindir}/gda-inspect-dict-file-3.0
352 %attr(755,root,root) %{_bindir}/gda-list-config-3.0
353 %attr(755,root,root) %{_bindir}/gda-sql-3.0
354 %attr(755,root,root) %{_bindir}/gda-test-connection-3.0
355 %attr(755,root,root) %{_libdir}/libgda-3.0.so
356 %attr(755,root,root) %{_libdir}/libgda-report-3.0.so
357 %attr(755,root,root) %{_libdir}/libgda-xslt-3.0.so
358 %attr(755,root,root) %{_libdir}/libgdasql-3.0.so
359 %{_libdir}/libgda-3.0.la
360 %{_libdir}/libgda-report-3.0.la
361 %{_libdir}/libgda-xslt-3.0.la
362 %{_libdir}/libgdasql-3.0.la
363 %{_includedir}/libgda-3.0
364 %{_pkgconfigdir}/libgda-3.0.pc
365 %{_pkgconfigdir}/libgda-*-3.0.pc
366 %{_sysconfdir}/libgda-3.0/sales_test.db
367 %{?with_doc:%{_gtkdocdir}/libgda-3.0}
368
369 %if %{with static_libs}
370 %files static
371 %defattr(644,root,root,755)
372 %{_libdir}/libgda-3.0.a
373 %{_libdir}/libgda-report-3.0.a
374 %{_libdir}/libgda-xslt-3.0.a
375 %{_libdir}/libgdasql-3.0.a
376 %endif
377
378 %files provider-db
379 %defattr(644,root,root,755)
380 %attr(755,root,root) %{_providersdir}/libgda-bdb.so
381
382 %if %{with firebird}
383 %files provider-firebird
384 %defattr(644,root,root,755)
385 %attr(755,root,root) %{_providersdir}/libgda-firebird.so
386 %endif
387
388 %if %{with freetds}
389 %files provider-freetds
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_providersdir}/libgda-freetds.so
392 %endif
393
394 %if %{with ldap}
395 %files provider-ldap
396 %defattr(644,root,root,755)
397 %attr(755,root,root) %{_providersdir}/libgda-ldap.so
398 %endif
399
400 %if %{with mdb}
401 %files provider-mdb
402 %defattr(644,root,root,755)
403 %attr(755,root,root) %{_providersdir}/libgda-mdb.so
404 %endif
405
406 %if %{with mysql}
407 %files provider-mysql
408 %defattr(644,root,root,755)
409 %attr(755,root,root) %{_providersdir}/libgda-mysql.so
410 %endif
411
412 %if %{with odbc}
413 %files provider-odbc
414 %defattr(644,root,root,755)
415 %attr(755,root,root) %{_providersdir}/libgda-odbc.so
416 %endif
417
418 %if %{with pgsql}
419 %files provider-postgres
420 %defattr(644,root,root,755)
421 %attr(755,root,root) %{_providersdir}/libgda-postgres.so
422 %endif
423
424 %if %{with sqlite}
425 %files provider-sqlite
426 %defattr(644,root,root,755)
427 %attr(755,root,root) %{_providersdir}/libgda-sqlite.so
428 %endif
429
430 %if %{with sybase}
431 %files provider-sybase
432 %defattr(644,root,root,755)
433 %attr(755,root,root) %{_providersdir}/libgda-sybase.so
434 %endif
435
436 %if %{with xbase}
437 %files provider-xbase
438 %defattr(644,root,root,755)
439 %attr(755,root,root) %{_providersdir}/libgda-xbase.so
440 %endif
This page took 0.101402 seconds and 3 git commands to generate.