]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- don't provide fuse group
[packages/libfuse.git] / libfuse.spec
1 # TODO:
2 # - unpackaged:
3 #   /etc/init.d/fuse
4 #   /etc/udev/rules.d/99-fuse.rules
5 #
6 # Condtional build:
7 %bcond_without  dist_kernel     # without distribution kernel
8 %bcond_with     kernel          # build kernel modules
9 %bcond_without  userspace       # don't build userspace tools
10 %bcond_with     verbose         # verbose build (V=1)
11 %bcond_without  selinux         # build without SELinux support
12
13 %ifarch sparc
14 %undefine       with_smp
15 %endif
16
17 %if %{without kernel}
18 %undefine with_dist_kernel
19 %endif
20 %if "%{_alt_kernel}" != "%{nil}"
21 %undefine       with_userspace
22 %endif
23
24 %define         pname   libfuse
25 %define         _rel    3
26 Summary:        Filesystem in Userspace
27 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika
28 Name:           %{pname}%{_alt_kernel}
29 Version:        2.7.3
30 Release:        %{_rel}
31 Epoch:          0
32 License:        GPL v2
33 Group:          Applications/System
34 Source0:        http://dl.sourceforge.net/fuse/fuse-%{version}.tar.gz
35 # Source0-md5:  98563fc7b265b7479a3178181cbcf59a
36 Source1:        fuse.conf
37 Patch0:         kernel-misc-fuse-Makefile.am.patch
38 Patch1:         %{pname}-link.patch
39 URL:            http://fuse.sourceforge.net/
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  libtool
43 BuildRequires:  cpp
44 BuildRequires:  sed >= 4.0
45 %if %{with kernel}
46 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
47 BuildRequires:  rpmbuild(macros) >= 1.379
48 %endif
49 %if %{with userspace}
50 %{?with_selinux:BuildRequires:  libselinux-devel}
51 %endif
52 Requires(postun):       /sbin/ldconfig
53 Requires(postun):       /usr/sbin/groupdel
54 Requires(pre):  /usr/bin/getgid
55 Requires(pre):  /usr/sbin/groupadd
56 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 FUSE (Filesystem in Userspace) is a simple interface for userspace
60 programs to export a virtual filesystem to the Linux kernel. FUSE also
61 aims to provide a secure method for non privileged users to create and
62 mount their own filesystem implementations.
63
64 This package contains a shared library.
65
66 %description -l pl.UTF-8
67 FUSE stanowi prosty interfejs dla programów działających w przestrzeni
68 użytkownika eksportujący wirtualny system plików do jądra Linuksa.
69 FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
70 montowania własnych implementacji systemów plików przez zwykłych
71 (nieuprzywilejowanych) użytkowników.
72
73 Ten pakiet zawiera bibliotekę współdzieloną.
74
75 %package devel
76 Summary:        Filesytem in Userspace - Development header files
77 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - pliki nagłówkowe
78 Group:          Development/Libraries
79 Requires:       %{pname} = %{epoch}:%{version}-%{_rel}
80
81 %description devel
82 Libfuse library header files.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki libfuse.
86
87 %package static
88 Summary:        Filesytem in Userspace - static library
89 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - biblioteka statyczna
90 Group:          Development/Libraries
91 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}
92
93 %description static
94 Static libfuse libraries.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka libfuse.
98
99 %package -n kernel%{_alt_kernel}-misc-fuse
100 Summary:        Filesystem in Userspace
101 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika
102 Release:        %{_rel}@%{_kernel_ver_str}
103 License:        GPL v2
104 Group:          Base/Kernel
105 Requires(post,postun):  /sbin/depmod
106 %if %{with dist_kernel}
107 %requires_releq_kernel
108 Requires(postun):       %releq_kernel
109 %endif
110 %if "%{_alt_kernel}" != "%{nil}"
111 Provides:       kernel-misc-fuse
112 %endif
113
114 %description -n kernel%{_alt_kernel}-misc-fuse
115 FUSE (Filesystem in Userspace) is a simple interface for userspace
116 programs to export a virtual filesystem to the Linux kernel. FUSE also
117 aims to provide a secure method for non privileged users to create and
118 mount their own filesystem implementations.
119
120 %description -n kernel%{_alt_kernel}-misc-fuse -l pl.UTF-8
121 FUSE stanowi prosty interfejs dla programów działających w przestrzeni
122 użytkownika eksportujący wirtualny system plików do jądra Linuksa.
123 FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
124 montowania własnych implementacji systemów plików przez zwykłych
125 (nieuprzywilejowanych) użytkowników.
126
127 %prep
128 %setup -q -n fuse-%{version}
129 %patch0 -p1
130 %patch1 -p1
131
132 sed -i '/FUSERMOUNT_PROG/s,fusermount,%{_bindir}/fusermount,' lib/mount.c
133
134 %build
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoheader}
138 %{__autoconf}
139 %{__automake}
140 %configure \
141         %{!?with_selinux:ac_cv_header_selinux_selinux_h=no} \
142         --%{?with_kernel:en}%{!?with_kernel:dis}able-kernel-module \
143         --enable-lib \
144         --enable-util \
145         %{?with_kernel:--with-kernel=%{_kernelsrcdir}}
146
147 %if %{with userspace}
148 cp kernel/fuse_kernel.h include/
149 for DIR in include lib util; do
150 %{__make} -C $DIR
151 done
152 %endif
153
154 %if %{with kernel}
155 %build_kernel_modules -m fuse -C kernel
156 %endif
157
158 %install
159 rm -rf $RPM_BUILD_ROOT
160 install -d $RPM_BUILD_ROOT{%{_pkgconfigdir},%{_sysconfdir}}
161
162 %if %{with userspace}
163 for DIR in include lib util; do
164 %{__make} -C $DIR install \
165         DESTDIR=$RPM_BUILD_ROOT
166 done
167
168 install fuse.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
169 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
170 %endif
171
172 %if %{with kernel}
173 %install_kernel_modules -m kernel/fuse -d kernel/fs
174 %endif
175
176 %clean
177 rm -rf $RPM_BUILD_ROOT
178
179 %pre
180 %groupadd -g 84 fuse || :
181
182 %post   -p /sbin/ldconfig
183 %postun
184 /sbin/ldconfig
185
186 %post -n kernel%{_alt_kernel}-misc-fuse
187 %depmod %{_kernel_ver}
188
189 %postun -n kernel%{_alt_kernel}-misc-fuse
190 %depmod %{_kernel_ver}
191
192 %if %{with userspace}
193 %files
194 %defattr(644,root,root,755)
195 %doc README NEWS ChangeLog AUTHORS doc/*
196 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fuse.conf
197 %attr(4754,root,fuse) %{_bindir}/fusermount
198 %attr(755,root,root) %{_bindir}/ulockmgr_server
199 %attr(755,root,root) /sbin/mount.fuse
200 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
201 %attr(755,root,root) %ghost %{_libdir}/libfuse.so.2
202 %attr(755,root,root) %{_libdir}/libulockmgr.so.*.*.*
203 %attr(755,root,root) %ghost %{_libdir}/libulockmgr.so.1
204
205 %files devel
206 %defattr(644,root,root,755)
207 %attr(755,root,root) %{_libdir}/libfuse.so
208 %attr(755,root,root) %{_libdir}/libulockmgr.so
209 %{_libdir}/libfuse.la
210 %{_libdir}/libulockmgr.la
211 %{_includedir}/fuse
212 %{_includedir}/fuse.h
213 %{_includedir}/ulockmgr.h
214 %{_pkgconfigdir}/fuse.pc
215
216 %files static
217 %defattr(644,root,root,755)
218 %{_libdir}/libfuse.a
219 %{_libdir}/libulockmgr.a
220 %endif
221
222 %if %{with kernel}
223 %files -n kernel%{_alt_kernel}-misc-fuse
224 %defattr(644,root,root,755)
225 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
226 %endif
This page took 0.069595 seconds and 4 git commands to generate.