]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- depmod fixes.
[packages/libfuse.git] / libfuse.spec
1 #
2 # Condtional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  smp             # without smp packages
6 %bcond_without  userspace       # don't build userspace tools
7 %bcond_with     verbose         # verbose build (V=1)
8 #
9 %define         _rel    1.2
10 #
11 Name:           kernel-misc-fuse
12 Summary:        Filesystem in Userspace
13 Summary(pl):    System plików w przestrzeni u¿ytkownika
14 Version:        1.1
15 Release:        %{_rel}@%{_kernel_ver_str}
16 License:        GPL v2
17 Group:          Applications/System
18 Source0:        http://dl.sourceforge.net/avf/fuse-%{version}.tar.gz
19 # Source0-md5:  adfbf15cf196ca597e1ff7fb7839938e
20 Patch0:         %{name}-configure.in.patch
21 URL:            http://sourceforge.net/projects/avf
22 %if %{with kernel} && %{with dist_kernel}
23 BuildRequires:  kernel-module-build
24 %endif
25 %{?with_dist_kernel:%requires_releq_kernel_up}
26 Requires(post,postun):  /sbin/depmod
27 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 FUSE (Filesystem in Userspace) is a simple interface for userspace
31 programs to export a virtual filesystem to the Linux kernel. FUSE also
32 aims to provide a secure method for non privileged users to create and
33 mount their own filesystem implementations.
34
35 %description -l pl
36 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
37 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
38 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
39 montowania w³asnych implementacji systemów plików przez zwyk³ych
40 (nieuprzywilejowanych) u¿ytkowników.
41
42 %package -n kernel-smp-misc-fuse
43 Summary:        Filesystem in Userspace
44 Summary(pl):    System plików w przestrzeni u¿ytkownika
45 Release:        %{_rel}@%{_kernel_ver_str}
46 License:        GPL v2
47 Group:          Applications/System
48 %{?with_dist_kernel:%requires_releq_kernel_up}
49 Requires(post,postun):  /sbin/depmod
50
51 %description -n kernel-smp-misc-fuse
52 FUSE (Filesystem in Userspace) is a simple interface for userspace
53 programs to export a virtual filesystem to the Linux kernel. FUSE also
54 aims to provide a secure method for non privileged users to create and
55 mount their own filesystem implementations.
56
57 %description -n kernel-smp-misc-fuse -l pl
58 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
59 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
60 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
61 montowania w³asnych implementacji systemów plików przez zwyk³ych
62 (nieuprzywilejowanych) u¿ytkowników.
63
64 %package -n libfuse
65 Summary:        Shared library for Filesytem in Userspace
66 Summary(pl):    Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
67 Group:          Applications/System
68 Release:        %{_rel}
69
70 %description -n libfuse
71 - -- empty --
72
73 %description -n libfuse -l pl
74 - -- pusty --
75
76 %package -n libfuse-devel
77 Summary:        Filesytem in Userspace - Development header fiels and libraries
78 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki dzielone
79 Group:          Development/Libraries
80 Requires:       libfuse = %{epoch}:%{version}-%{_rel}
81
82 %description -n libfuse-devel
83 - -- empty --
84
85 %description -n libfuse-devel -l pl
86 - -- pusty --
87
88 %package -n libfuse-static
89 Summary:        Filesytem in Userspace - static libraries
90 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki statyczne
91 Group:          Development/Libraries
92 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}
93
94 %description -n libfuse-static
95 - -- empty --
96
97 %description -n libfuse-static -l pl
98 - -- pusty --
99
100 %package -n fusermount
101 Summary:        Filesytem in Userspace utilities
102 Summary(pl):    Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika
103 Group:          Applications/System
104 Release:        %{_rel}
105
106 %description -n fusermount
107 - -- empty --
108
109 %description -n fusermount -l pl
110 - -- pusty --
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %prep
116 %setup -q -n fuse-%{version}
117 %patch0 -p1
118
119 %build
120 %{__aclocal}
121 %{__autoconf}
122 %{__automake}
123 %configure \
124     --enable-lib \
125     --enable-util
126
127 %if %{with kernel}
128 cd kernel
129 rm -rf built
130 mkdir built
131 for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
132     if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
133         exit 1
134     fi
135     %{__make} -C %{_kernelsrcdir} mrproper \
136         SUBDIRS=$PWD \
137         O=$PWD \
138         RCS_FIND_IGNORE="-name built" \
139         %{?with_verbose:V=1}
140     rm -rf include
141     install -d include/{linux,config}
142     ln -sf %{_kernelsrcdir}/config-$cfg .config
143     ln -sf %{_kernelsrcdir}/include/linux/autoconf-${cfg}.h include/linux/autoconf.h
144     touch include/config/MARKER
145     %{__make} -C %{_kernelsrcdir} modules \
146         SUBDIRS=$PWD \
147         O=$PWD \
148         %{?with_verbose:V=1}
149     mv fuse.ko built/fuse-$cfg.ko
150 done
151 cd -
152 %endif
153
154 cd lib
155 for f in fuse.c fuse_mt.c helper.c mount.c; do
156 libtool --mode=compile --tag=CC %{__cc} -c -I. -I../include -DHAVE_CONFIG_H $f
157 done
158 libtool --mode=link %{__cc} -o libfuse.la fuse.lo fuse_mt.lo helper.lo mount.lo -rpath %{_libdir}
159 cd -
160
161 %{?with_userspace:%{__make} -C util}
162
163 %install
164 rm -rf $RPM_BUILD_ROOT
165
166 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
167
168 %if %{with userspace}
169 cd util
170 install fusermount $RPM_BUILD_ROOT%{_bindir}/
171 cd -
172 %endif
173
174 %if %{with kernel}
175 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/kernel/fs
176 cd kernel/built
177 install fuse-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \
178         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko
179 %if %{with smp} && %{with dist_kernel}
180 install fuse-smp.ko \
181         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko
182 %endif
183 cd -
184 %endif
185
186 install include/fuse.h $RPM_BUILD_ROOT%{_includedir}/
187 cd lib
188 libtool --mode=install install libfuse.la $RPM_BUILD_ROOT%{_libdir}/libfuse.la
189 cd -
190
191 %post
192 %depmod %{_kernel_ver}
193
194 %postun
195 %depmod %{_kernel_ver}
196
197 %post -n kernel-smp-misc-fuse
198 %depmod %{_kernel_ver}
199
200 %postun -n kernel-smp-misc-fuse
201 %depmod %{_kernel_ver}
202
203 %if %{with kernel}
204 %files
205 %defattr(644,root,root,755)
206 %doc README NEWS ChangeLog AUTHORS
207 %doc patch/
208 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
209 %endif
210
211 %if %{with userspace}
212 %files -n fusermount
213 # suid needed?
214 %attr(755,root,root) %{_bindir}/fusermount
215 %endif
216
217 %files -n libfuse
218 %defattr(644,root,root,755)
219 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
220
221 %files -n libfuse-devel
222 %defattr(644,root,root,755)
223 %{_includedir}/fuse.h
224 %{_libdir}/libfuse.la
225 %attr(755,root,root) %{_libdir}/libfuse.so
226
227 %files -n libfuse-static
228 %defattr(644,root,root,755)
229 %{_prefix}/lib/libfuse.a
This page took 0.04177 seconds and 4 git commands to generate.