]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- some fixes and fixed requires
[packages/libfuse.git] / libfuse.spec
1 #
2 # Condtional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  smp             # without smp packages
6 %bcond_without  userspace       # don't build userspace tools
7 %bcond_with     verbose         # verbose build (V=1)
8 #
9 %define         _rel    1.2
10 #
11 Name:           kernel-misc-fuse
12 Summary:        Filesystem in Userspace
13 Summary(pl):    System plików w przestrzeni u¿ytkownika
14 Version:        1.1
15 Release:        %{_rel}@%{_kernel_ver_str}
16 License:        GPL v2
17 Group:          Applications/System
18 Source0:        http://dl.sourceforge.net/avf/fuse-%{version}.tar.gz
19 # Source0-md5:  adfbf15cf196ca597e1ff7fb7839938e
20 Patch0:         %{name}-configure.in.patch
21 URL:            http://sourceforge.net/projects/avf
22 %if %{with kernel} && %{with dist_kernel}
23 BuildRequires:  kernel-module-build
24 %endif
25 %{?with_dist_kernel:%requires_releq_kernel_up}
26 Requires(post,postun):  /sbin/depmod
27 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 FUSE (Filesystem in Userspace) is a simple interface for userspace
31 programs to export a virtual filesystem to the Linux kernel. FUSE also
32 aims to provide a secure method for non privileged users to create and
33 mount their own filesystem implementations.
34
35 %description -l pl
36 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
37 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
38 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
39 montowania w³asnych implementacji systemów plików przez zwyk³ych
40 (nieuprzywilejowanych) u¿ytkowników.
41
42 %package -n kernel-smp-misc-fuse
43 Summary:        Filesystem in Userspace
44 Summary(pl):    System plików w przestrzeni u¿ytkownika
45 Release:        %{_rel}@%{_kernel_ver_str}
46 License:        GPL v2
47 Group:          Applications/System
48 %{?with_dist_kernel:%requires_releq_kernel_up}
49 Requires(post,postun):  /sbin/depmod
50
51 %description -n kernel-smp-misc-fuse
52 FUSE (Filesystem in Userspace) is a simple interface for userspace
53 programs to export a virtual filesystem to the Linux kernel. FUSE also
54 aims to provide a secure method for non privileged users to create and
55 mount their own filesystem implementations.
56
57 %description -n kernel-smp-misc-fuse -l pl
58 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
59 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
60 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
61 montowania w³asnych implementacji systemów plików przez zwyk³ych
62 (nieuprzywilejowanych) u¿ytkowników.
63
64 %package -n libfuse
65 Summary:        Shared library for Filesytem in Userspace
66 Summary(pl):    Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
67 Group:          Applications/System
68 Release:        %{_rel}
69
70 %description -n libfuse
71 Shared library for Filesytem in Userspace
72
73 %description -n libfuse -l pl
74 Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
75
76 %package -n libfuse-devel
77 Summary:        Filesytem in Userspace - Development header fiels and libraries
78 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki dzielone
79 Group:          Development/Libraries
80 Requires:       libfuse = %{epoch}:%{version}-%{_rel}
81
82 %description -n libfuse-devel
83 Libfuse library header files.
84
85 %description -n libfuse-devel -l pl
86 Libfuse biblioteki nag³ówkowe dla programistów.
87
88 %package -n libfuse-static
89 Summary:        Filesytem in Userspace - static libraries
90 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki statyczne
91 Group:          Development/Libraries
92 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}@%{_kernel_ver_str}
93
94 %description -n libfuse-static
95 Static libfuse libraries.
96
97 %description -n libfuse-static -l pl
98 Statyczne biblioteki libfuse
99
100 %package -n fusermount
101 Summary:        Filesytem in Userspace utilities
102 Summary(pl):    Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika
103 Group:          Applications/System
104 Release:        %{_rel}
105
106 %description -n fusermount
107 Filesytem in Userspace utilities. It provide a secure method for non
108 privileged users to create and mount their own filesystem implementations. 
109
110 %description -n fusermount -l pl
111 Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika. Dostarcza bezpieczn±
112 metodê tworzenia i montowania w³asnych systemów plików dla nie uprzywilejowanych userów.
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %prep
118 %setup -q -n fuse-%{version}
119 %patch0 -p1
120
121 %build
122 %{__aclocal}
123 %{__autoconf}
124 %{__automake}
125 %configure \
126     --enable-lib \
127     --enable-util
128
129 %if %{with kernel}
130 cd kernel
131 rm -rf built
132 mkdir built
133 for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
134     if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
135         exit 1
136     fi
137     %{__make} -C %{_kernelsrcdir} mrproper \
138         SUBDIRS=$PWD \
139         O=$PWD \
140         RCS_FIND_IGNORE="-name built" \
141         %{?with_verbose:V=1}
142     rm -rf include
143     install -d include/{linux,config}
144     ln -sf %{_kernelsrcdir}/config-$cfg .config
145     ln -sf %{_kernelsrcdir}/include/linux/autoconf-${cfg}.h include/linux/autoconf.h
146     touch include/config/MARKER
147     %{__make} -C %{_kernelsrcdir} modules \
148         SUBDIRS=$PWD \
149         O=$PWD \
150         %{?with_verbose:V=1}
151     mv fuse.ko built/fuse-$cfg.ko
152 done
153 cd -
154 %endif
155
156 cd lib
157 for f in fuse.c fuse_mt.c helper.c mount.c; do
158 libtool --mode=compile --tag=CC %{__cc} -c -I. -I../include -DHAVE_CONFIG_H $f
159 done
160 libtool --mode=link %{__cc} -o libfuse.la fuse.lo fuse_mt.lo helper.lo mount.lo -rpath %{_libdir}
161 cd -
162
163 %{?with_userspace:%{__make} -C util}
164
165 %install
166 rm -rf $RPM_BUILD_ROOT
167
168 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
169
170 %if %{with userspace}
171 cd util
172 install fusermount $RPM_BUILD_ROOT%{_bindir}/
173 cd -
174 %endif
175
176 %if %{with kernel}
177 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/kernel/fs
178 cd kernel/built
179 install fuse-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \
180         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko
181 %if %{with smp} && %{with dist_kernel}
182 install fuse-smp.ko \
183         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko
184 %endif
185 cd -
186 %endif
187
188 install include/fuse.h $RPM_BUILD_ROOT%{_includedir}/
189 cd lib
190 libtool --mode=install install libfuse.la $RPM_BUILD_ROOT%{_libdir}/libfuse.la
191 cd -
192
193 %post
194 %depmod %{_kernel_ver}
195
196 %postun
197 %depmod %{_kernel_ver}
198
199 %post -n kernel-smp-misc-fuse
200 %depmod %{_kernel_ver}
201
202 %postun -n kernel-smp-misc-fuse
203 %depmod %{_kernel_ver}
204
205 %if %{with kernel}
206 %files
207 %defattr(644,root,root,755)
208 %doc README NEWS ChangeLog AUTHORS
209 %doc patch/
210 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
211 %endif
212
213 %if %{with userspace}
214 %files -n fusermount
215 %defattr(644,root,root,755)
216 # suid needed? NO!
217 %attr(755,root,root) %{_bindir}/fusermount
218 # do it ! failed
219 # %%attr(755,root,root) %{_sbindir}/mount.fuse
220 %endif
221
222 %files -n libfuse
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
225
226 %files -n libfuse-devel
227 %defattr(644,root,root,755)
228 %{_includedir}/fuse.h
229 %{_libdir}/libfuse.la
230 %attr(755,root,root) %{_libdir}/libfuse.so
231
232 %files -n libfuse-static
233 %defattr(644,root,root,755)
234 %{_libdir}/libfuse.a
This page took 0.077198 seconds and 4 git commands to generate.