]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- build fixed.
[packages/libfuse.git] / libfuse.spec
1 #
2 # Condtional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  smp             # without smp packages
6 %bcond_without  userspace       # don't build userspace tools
7 %bcond_with     verbose         # verbose build (V=1)
8 #
9 Name:           kernel-misc-fuse
10 Summary:        Filesystem in Userspace
11 Summary(pl):    System plików w przestrzeni u¿ytkownika
12 Version:        1.1
13 %define         _rel    2
14 Release:        %{_rel}@%{_kernel_ver_str}
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://dl.sourceforge.net/avf/fuse-%{version}.tar.gz
18 # Source0-md5:  adfbf15cf196ca597e1ff7fb7839938e
19 Patch0:         %{name}-configure.in.patch
20 URL:            http://sourceforge.net/projects/avf
21 %if %{with kernel} && %{with dist_kernel}
22 BuildRequires:  kernel-module-build
23 %endif
24 %{?with_dist_kernel:%requires_releq_kernel_up}
25 Requires(post,postun):  /sbin/depmod
26 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 FUSE (Filesystem in Userspace) is a simple interface for userspace
30 programs to export a virtual filesystem to the Linux kernel. FUSE also
31 aims to provide a secure method for non privileged users to create and
32 mount their own filesystem implementations.
33
34 %description -l pl
35 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
36 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
37 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
38 montowania w³asnych implementacji systemów plików przez zwyk³ych
39 (nieuprzywilejowanych) u¿ytkowników.
40
41 %package -n kernel-smp-misc-fuse
42 Summary:        Filesystem in Userspace
43 Summary(pl):    System plików w przestrzeni u¿ytkownika
44 Release:        %{_rel}@%{_kernel_ver_str}
45 License:        GPL v2
46 Group:          Applications/System
47 %{?with_dist_kernel:%requires_releq_kernel_up}
48 Requires(post,postun):  /sbin/depmod
49
50 %description -n kernel-smp-misc-fuse
51 FUSE (Filesystem in Userspace) is a simple interface for userspace
52 programs to export a virtual filesystem to the Linux kernel. FUSE also
53 aims to provide a secure method for non privileged users to create and
54 mount their own filesystem implementations.
55
56 %description -n kernel-smp-misc-fuse -l pl
57 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
58 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
59 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
60 montowania w³asnych implementacji systemów plików przez zwyk³ych
61 (nieuprzywilejowanych) u¿ytkowników.
62
63 %package -n libfuse
64 Summary:        Shared library for Filesytem in Userspace
65 Summary(pl):    Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
66 Group:          Applications/System
67 Release:        %{_rel}
68
69 %description -n libfuse
70 Shared library for Filesytem in Userspace
71
72 %description -n libfuse -l pl
73 Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
74
75 %package -n libfuse-devel
76 Summary:        Filesytem in Userspace - Development header fiels and libraries
77 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki dzielone
78 Group:          Development/Libraries
79 Release:        %{_rel}
80 Requires:       libfuse = %{epoch}:%{version}-%{_rel}
81
82 %description -n libfuse-devel
83 Libfuse library header files.
84
85 %description -n libfuse-devel -l pl
86 Libfuse biblioteki nag³ówkowe dla programistów.
87
88 %package -n libfuse-static
89 Summary:        Filesytem in Userspace - static libraries
90 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki statyczne
91 Group:          Development/Libraries
92 Release:        %{_rel}
93 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}
94
95 %description -n libfuse-static
96 Static libfuse libraries.
97
98 %description -n libfuse-static -l pl
99 Statyczne biblioteki libfuse
100
101 %package -n fusermount
102 Summary:        Filesytem in Userspace utilities
103 Summary(pl):    Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika
104 Group:          Applications/System
105 Release:        %{_rel}
106
107 %description -n fusermount
108 Filesytem in Userspace utilities. It provide a secure method for non
109 privileged users to create and mount their own filesystem implementations. 
110
111 %description -n fusermount -l pl
112 Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika. Dostarcza bezpieczn±
113 metodê tworzenia i montowania w³asnych systemów plików dla nie uprzywilejowanych userów.
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %prep
119 %setup -q -n fuse-%{version}
120 %patch0 -p1
121
122 %build
123 %{__aclocal}
124 %{__autoconf}
125 %{__automake}
126 %configure \
127     --enable-lib \
128     --enable-util \
129     --with-kernel=%{_kernelsrcdir}
130
131 %if %{with kernel}
132 cd kernel
133 for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
134     if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
135         exit 1
136     fi
137     rm -rf include
138     install -d include/{linux,config}
139     ln -sf %{_kernelsrcdir}/config-$cfg .config
140     ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h include/linux/autoconf.h
141     touch include/config/MARKER
142     %{__make} -C %{_kernelsrcdir} clean modules \
143         EXTRA_CFLAGS="-I../include -DFUSE_VERSION='1.1'" \
144         RCS_FIND_IGNORE="-name '*.ko' -o" \
145         M=$PWD O=$PWD \
146         %{?with_verbose:V=1}
147     mv fuse.ko fuse-$cfg.ko
148 done
149 cd -
150 %endif
151
152 cd lib
153 for f in fuse.c fuse_mt.c helper.c mount.c; do
154 libtool --mode=compile --tag=CC %{__cc} -c -I. -I../include -DHAVE_CONFIG_H $f
155 done
156 libtool --mode=link %{__cc} -o libfuse.la fuse.lo fuse_mt.lo helper.lo mount.lo -rpath %{_libdir}
157 cd -
158
159 %{?with_userspace:%{__make} -C util}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
165
166 %if %{with userspace}
167 cd util
168 install fusermount $RPM_BUILD_ROOT%{_bindir}/
169 cd -
170 %endif
171
172 %if %{with kernel}
173 cd kernel
174 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/kernel/fs
175 install fuse-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \
176         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko
177 %if %{with smp} && %{with dist_kernel}
178 install fuse-smp.ko \
179         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko
180 %endif
181 cd -
182 %endif
183
184 install include/fuse.h $RPM_BUILD_ROOT%{_includedir}
185 cd lib
186 libtool --mode=install install libfuse.la $RPM_BUILD_ROOT%{_libdir}/libfuse.la
187 cd -
188
189 %post
190 %depmod %{_kernel_ver}
191
192 %postun
193 %depmod %{_kernel_ver}
194
195 %post -n kernel-smp-misc-fuse
196 %depmod %{_kernel_ver}
197
198 %postun -n kernel-smp-misc-fuse
199 %depmod %{_kernel_ver}
200
201 %if %{with kernel}
202 %files
203 %defattr(644,root,root,755)
204 %doc README NEWS ChangeLog AUTHORS
205 %doc patch/
206 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
207
208 %if %{with smp} && %{with dist_kernel}
209 %files -n kernel-smp-misc-fuse
210 %defattr(644,root,root,755)
211 %doc README NEWS ChangeLog AUTHORS
212 %doc patch/
213 /lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko*
214 %endif
215 %endif
216
217 %if %{with userspace}
218 %files -n fusermount
219 %defattr(644,root,root,755)
220 # suid needed? NO!
221 %attr(755,root,root) %{_bindir}/fusermount
222 # do it ! failed
223 # %%attr(755,root,root) %{_sbindir}/mount.fuse
224 %endif
225
226 %files -n libfuse
227 %defattr(644,root,root,755)
228 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
229
230 %files -n libfuse-devel
231 %defattr(644,root,root,755)
232 %{_includedir}/fuse.h
233 %{_libdir}/libfuse.la
234 %attr(755,root,root) %{_libdir}/libfuse.so
235
236 %files -n libfuse-static
237 %defattr(644,root,root,755)
238 %{_libdir}/libfuse.a
This page took 0.082221 seconds and 4 git commands to generate.