]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- {release,requires} fixed.
[packages/libfuse.git] / libfuse.spec
1 #
2 # Condtional build:
3 %bcond_without  dist_kernel     # without distribution kernel
4 %bcond_without  kernel          # don't build kernel modules
5 %bcond_without  smp             # without smp packages
6 %bcond_without  userspace       # don't build userspace tools
7 %bcond_with     verbose         # verbose build (V=1)
8 #
9 %define         _rel    1.2
10 #
11 Name:           kernel-misc-fuse
12 Summary:        Filesystem in Userspace
13 Summary(pl):    System plików w przestrzeni u¿ytkownika
14 Version:        1.1
15 Release:        %{_rel}@%{_kernel_ver_str}
16 License:        GPL v2
17 Group:          Applications/System
18 Source0:        http://dl.sourceforge.net/avf/fuse-%{version}.tar.gz
19 # Source0-md5:  adfbf15cf196ca597e1ff7fb7839938e
20 Patch0:         %{name}-configure.in.patch
21 URL:            http://sourceforge.net/projects/avf
22 %if %{with kernel} && %{with dist_kernel}
23 BuildRequires:  kernel-module-build
24 %endif
25 %{?with_dist_kernel:%requires_releq_kernel_up}
26 Requires(post,postun):  /sbin/depmod
27 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 FUSE (Filesystem in Userspace) is a simple interface for userspace
31 programs to export a virtual filesystem to the Linux kernel. FUSE also
32 aims to provide a secure method for non privileged users to create and
33 mount their own filesystem implementations.
34
35 %description -l pl
36 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
37 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
38 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
39 montowania w³asnych implementacji systemów plików przez zwyk³ych
40 (nieuprzywilejowanych) u¿ytkowników.
41
42 %package -n kernel-smp-misc-fuse
43 Summary:        Filesystem in Userspace
44 Summary(pl):    System plików w przestrzeni u¿ytkownika
45 Release:        %{_rel}@%{_kernel_ver_str}
46 License:        GPL v2
47 Group:          Applications/System
48 %{?with_dist_kernel:%requires_releq_kernel_up}
49 Requires(post,postun):  /sbin/depmod
50
51 %description -n kernel-smp-misc-fuse
52 FUSE (Filesystem in Userspace) is a simple interface for userspace
53 programs to export a virtual filesystem to the Linux kernel. FUSE also
54 aims to provide a secure method for non privileged users to create and
55 mount their own filesystem implementations.
56
57 %description -n kernel-smp-misc-fuse -l pl
58 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
59 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
60 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
61 montowania w³asnych implementacji systemów plików przez zwyk³ych
62 (nieuprzywilejowanych) u¿ytkowników.
63
64 %package -n libfuse
65 Summary:        Shared library for Filesytem in Userspace
66 Summary(pl):    Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
67 Group:          Applications/System
68 Release:        %{_rel}
69
70 %description -n libfuse
71 Shared library for Filesytem in Userspace
72
73 %description -n libfuse -l pl
74 Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
75
76 %package -n libfuse-devel
77 Summary:        Filesytem in Userspace - Development header fiels and libraries
78 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki dzielone
79 Group:          Development/Libraries
80 Release:        %{_rel}
81 Requires:       libfuse = %{epoch}:%{version}-%{_rel}
82
83 %description -n libfuse-devel
84 Libfuse library header files.
85
86 %description -n libfuse-devel -l pl
87 Libfuse biblioteki nag³ówkowe dla programistów.
88
89 %package -n libfuse-static
90 Summary:        Filesytem in Userspace - static libraries
91 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki statyczne
92 Group:          Development/Libraries
93 Release:        %{_rel}
94 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}
95
96 %description -n libfuse-static
97 Static libfuse libraries.
98
99 %description -n libfuse-static -l pl
100 Statyczne biblioteki libfuse
101
102 %package -n fusermount
103 Summary:        Filesytem in Userspace utilities
104 Summary(pl):    Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika
105 Group:          Applications/System
106 Release:        %{_rel}
107
108 %description -n fusermount
109 Filesytem in Userspace utilities. It provide a secure method for non
110 privileged users to create and mount their own filesystem implementations. 
111
112 %description -n fusermount -l pl
113 Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika. Dostarcza bezpieczn±
114 metodê tworzenia i montowania w³asnych systemów plików dla nie uprzywilejowanych userów.
115
116 %clean
117 rm -rf $RPM_BUILD_ROOT
118
119 %prep
120 %setup -q -n fuse-%{version}
121 %patch0 -p1
122
123 %build
124 %{__aclocal}
125 %{__autoconf}
126 %{__automake}
127 %configure \
128     --enable-lib \
129     --enable-util
130
131 %if %{with kernel}
132 cd kernel
133 rm -rf built
134 mkdir built
135 for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
136     if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
137         exit 1
138     fi
139     %{__make} -C %{_kernelsrcdir} mrproper \
140         SUBDIRS=$PWD \
141         O=$PWD \
142         RCS_FIND_IGNORE="-name built" \
143         %{?with_verbose:V=1}
144     rm -rf include
145     install -d include/{linux,config}
146     ln -sf %{_kernelsrcdir}/config-$cfg .config
147     ln -sf %{_kernelsrcdir}/include/linux/autoconf-${cfg}.h include/linux/autoconf.h
148     touch include/config/MARKER
149     %{__make} -C %{_kernelsrcdir} modules \
150         SUBDIRS=$PWD \
151         O=$PWD \
152         %{?with_verbose:V=1}
153     mv fuse.ko built/fuse-$cfg.ko
154 done
155 cd -
156 %endif
157
158 cd lib
159 for f in fuse.c fuse_mt.c helper.c mount.c; do
160 libtool --mode=compile --tag=CC %{__cc} -c -I. -I../include -DHAVE_CONFIG_H $f
161 done
162 libtool --mode=link %{__cc} -o libfuse.la fuse.lo fuse_mt.lo helper.lo mount.lo -rpath %{_libdir}
163 cd -
164
165 %{?with_userspace:%{__make} -C util}
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169
170 install -d $RPM_BUILD_ROOT{%{_bindir},%{_includedir},%{_libdir}}
171
172 %if %{with userspace}
173 cd util
174 install fusermount $RPM_BUILD_ROOT%{_bindir}/
175 cd -
176 %endif
177
178 %if %{with kernel}
179 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/kernel/fs
180 cd kernel/built
181 install fuse-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \
182         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko
183 %if %{with smp} && %{with dist_kernel}
184 install fuse-smp.ko \
185         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko
186 %endif
187 cd -
188 %endif
189
190 install include/fuse.h $RPM_BUILD_ROOT%{_includedir}/
191 cd lib
192 libtool --mode=install install libfuse.la $RPM_BUILD_ROOT%{_libdir}/libfuse.la
193 cd -
194
195 %post
196 %depmod %{_kernel_ver}
197
198 %postun
199 %depmod %{_kernel_ver}
200
201 %post -n kernel-smp-misc-fuse
202 %depmod %{_kernel_ver}
203
204 %postun -n kernel-smp-misc-fuse
205 %depmod %{_kernel_ver}
206
207 %if %{with kernel}
208 %files
209 %defattr(644,root,root,755)
210 %doc README NEWS ChangeLog AUTHORS
211 %doc patch/
212 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
213 %endif
214
215 %if %{with userspace}
216 %files -n fusermount
217 %defattr(644,root,root,755)
218 # suid needed? NO!
219 %attr(755,root,root) %{_bindir}/fusermount
220 # do it ! failed
221 # %%attr(755,root,root) %{_sbindir}/mount.fuse
222 %endif
223
224 %files -n libfuse
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
227
228 %files -n libfuse-devel
229 %defattr(644,root,root,755)
230 %{_includedir}/fuse.h
231 %{_libdir}/libfuse.la
232 %attr(755,root,root) %{_libdir}/libfuse.so
233
234 %files -n libfuse-static
235 %defattr(644,root,root,755)
236 %{_libdir}/libfuse.a
This page took 0.105019 seconds and 4 git commands to generate.