]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
- up to 2.2
[packages/libfuse.git] / libfuse.spec
1 #
2 # TODO:
3 # - review patches
4 #
5 # Condtional build:
6 %bcond_without  dist_kernel     # without distribution kernel
7 %bcond_without  kernel          # don't build kernel modules
8 %bcond_without  smp             # without smp packages
9 %bcond_without  userspace       # don't build userspace tools
10 %bcond_with     verbose         # verbose build (V=1)
11 #
12 Name:           kernel-misc-fuse
13 Summary:        Filesystem in Userspace
14 Summary(pl):    System plików w przestrzeni u¿ytkownika
15 Version:        2.2
16 %define         _rel    0.4
17 Release:        %{_rel}@%{_kernel_ver_str}
18 Epoch:          0
19 License:        GPL v2
20 Group:          Base/Kernel
21 Source0:        http://dl.sourceforge.net/fuse/fuse-%{version}.tar.gz
22 # Source0-md5:  6f7fe60795324111fea18143e81512ec
23 # Source0-size: 126361
24 Patch0:         %{name}-configure.in.patch
25 Patch1:         %{name}-perm.patch
26 URL:            http://fuse.sourceforge.net/
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 %if %{with kernel}
30 %{?with_dist_kernel:BuildRequires:      kernel-module-build >= 2.6.7}
31 %endif
32 BuildRequires:  libtool
33 %{?with_dist_kernel:%requires_releq_kernel_up}
34 Requires(post,postun):  /sbin/depmod
35 %{?with_dist_kernel:Requires(postun):   kernel}
36 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 FUSE (Filesystem in Userspace) is a simple interface for userspace
40 programs to export a virtual filesystem to the Linux kernel. FUSE also
41 aims to provide a secure method for non privileged users to create and
42 mount their own filesystem implementations.
43
44 %description -l pl
45 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
46 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
47 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
48 montowania w³asnych implementacji systemów plików przez zwyk³ych
49 (nieuprzywilejowanych) u¿ytkowników.
50
51 %package -n kernel-smp-misc-fuse
52 Summary:        Filesystem in Userspace
53 Summary(pl):    System plików w przestrzeni u¿ytkownika
54 Release:        %{_rel}@%{_kernel_ver_str}
55 License:        GPL v2
56 Group:          Base/Kernel
57 Provides:       kernel-misc-fuse
58 %{?with_dist_kernel:%requires_releq_kernel_smp}
59 Requires(post,postun):  /sbin/depmod
60 %{?with_dist_kernel:Requires(postun):   kernel-smp}
61
62 %description -n kernel-smp-misc-fuse
63 FUSE (Filesystem in Userspace) is a simple interface for userspace
64 programs to export a virtual filesystem to the Linux kernel. FUSE also
65 aims to provide a secure method for non privileged users to create and
66 mount their own filesystem implementations.
67
68 %description -n kernel-smp-misc-fuse -l pl
69 FUSE stanowi prosty interfejs dla programów dzia³aj±cych w przestrzeni
70 u¿ytkownika eksportuj±cy wirtualny system plików do j±dra Linuksa.
71 FUSE ma równie¿ na celu udostêpnienie bezpiecznej metody tworzenia i
72 montowania w³asnych implementacji systemów plików przez zwyk³ych
73 (nieuprzywilejowanych) u¿ytkowników.
74
75 %package -n libfuse
76 Summary:        Shared library for Filesytem in Userspace
77 Summary(pl):    Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
78 Group:          Applications/System
79 Release:        %{_rel}
80
81 %description -n libfuse
82 Shared library for Filesytem in Userspace
83
84 %description -n libfuse -l pl
85 Biblioteki dzielone Systemu plików w przestrzeni u¿ytkownika
86
87 %package -n libfuse-devel
88 Summary:        Filesytem in Userspace - Development header fiels and libraries
89 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki dzielone
90 Group:          Development/Libraries
91 Release:        %{_rel}
92 Requires:       libfuse = %{epoch}:%{version}-%{_rel}
93
94 %description -n libfuse-devel
95 Libfuse library header files.
96
97 %description -n libfuse-devel -l pl
98 Libfuse biblioteki nag³ówkowe dla programistów.
99
100 %package -n libfuse-static
101 Summary:        Filesytem in Userspace - static libraries
102 Summary(pl):    Systemu plików w przestrzeni u¿ytkownika - Biblioteki statyczne
103 Group:          Development/Libraries
104 Release:        %{_rel}
105 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}
106
107 %description -n libfuse-static
108 Static libfuse libraries.
109
110 %description -n libfuse-static -l pl
111 Statyczne biblioteki libfuse
112
113 %package -n fusermount
114 Summary:        Filesytem in Userspace utilities
115 Summary(pl):    Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika
116 Group:          Applications/System
117 Release:        %{_rel}
118
119 %description -n fusermount
120 Filesytem in Userspace utilities. It provide a secure method for non
121 privileged users to create and mount their own filesystem
122 implementations.
123
124 %description -n fusermount -l pl
125 Narzêdzia obs³uguj±ce systemu plików w przestrzeni u¿ytkownika.
126 Dostarcza bezpieczn± metodê tworzenia i montowania w³asnych systemów
127 plików dla nie uprzywilejowanych userów.
128
129 %prep
130 %setup -q -n fuse-%{version}
131 %patch0 -p0
132 #patch1 -p1
133
134 %build
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoheader}
138 %{__autoconf}
139 %{__automake}
140 %configure \
141     --enable-lib \
142     --enable-util \
143     --with-kernel=%{_kernelsrcdir}
144
145 %if %{with kernel}
146 cd kernel
147
148 for cfg in %{?with_dist_kernel:%{?with_smp:smp} up}%{!?with_dist_kernel:nondist}; do
149     if [ ! -r "%{_kernelsrcdir}/config-$cfg" ]; then
150         exit 1
151     fi
152     rm -rf include
153     install -d include/{linux,config}
154     ln -sf %{_kernelsrcdir}/config-$cfg .config
155     ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h include/linux/autoconf.h
156     ln -sf %{_kernelsrcdir}/include/asm-%{_target_base_arch} include/asm
157     touch include/config/MARKER
158     %{__make} -C %{_kernelsrcdir} clean \
159         RCS_FIND_IGNORE="-name '*.ko' -o" \
160         M=$PWD O=$PWD \
161         %{?with_verbose:V=1}
162     %{__make} -C %{_kernelsrcdir} modules \
163         EXTRA_CFLAGS='-I../include -DFUSE_VERSION=\"2.2\"' \
164         RCS_FIND_IGNORE="-name '*.ko' -o" \
165         CC="%{__cc}" CPP="%{__cpp}" \
166         M=$PWD O=$PWD \
167         %{?with_verbose:V=1}
168
169     mv fuse.ko fuse-$cfg.ko
170 done
171 cd -
172 %endif
173
174 %if %{with userspace}
175 cp kernel/fuse_kernel.h include/
176 for DIR in include lib util; do
177 %{__make} -C $DIR
178 done
179 %endif
180
181 %install
182 rm -rf $RPM_BUILD_ROOT
183
184 install -d $RPM_BUILD_ROOT%{_pkgconfigdir}
185
186 %if %{with userspace}
187 for DIR in include lib util; do
188 %{__make} -C $DIR install \
189         DESTDIR=$RPM_BUILD_ROOT
190 done
191
192 install fuse.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
193 %endif
194
195 %if %{with kernel}
196 cd kernel
197 install -d $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}{,smp}/kernel/fs
198 install fuse-%{?with_dist_kernel:up}%{!?with_dist_kernel:nondist}.ko \
199         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko
200 %if %{with smp} && %{with dist_kernel}
201 install fuse-smp.ko \
202         $RPM_BUILD_ROOT/lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko
203 %endif
204 %endif
205
206 %clean
207 rm -rf $RPM_BUILD_ROOT
208
209 %post
210 %depmod %{_kernel_ver}
211
212 %postun
213 %depmod %{_kernel_ver}
214
215 %post -n kernel-smp-misc-fuse
216 %depmod %{_kernel_ver}smp
217
218 %postun -n kernel-smp-misc-fuse
219 %depmod %{_kernel_ver}smp
220
221 %post -n libfuse -p /sbin/ldconfig
222 %postun -n libfuse -p /sbin/ldconfig
223
224 %if %{with kernel}
225 %files
226 %defattr(644,root,root,755)
227 %doc README NEWS ChangeLog AUTHORS doc/*
228 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
229
230 %if %{with smp} && %{with dist_kernel}
231 %files -n kernel-smp-misc-fuse
232 %defattr(644,root,root,755)
233 %doc README NEWS ChangeLog AUTHORS doc/*
234 /lib/modules/%{_kernel_ver}smp/kernel/fs/fuse.ko*
235 %endif
236 %endif
237
238 %if %{with userspace}
239 %files -n fusermount
240 %defattr(644,root,root,755)
241 # suid needed? NO!
242 %attr(755,root,root) %{_bindir}/fusermount
243 # do it ! failed
244 # %%attr(755,root,root) %{_sbindir}/mount.fuse
245
246 %files -n libfuse
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
249
250 %files -n libfuse-devel
251 %defattr(644,root,root,755)
252 %{_includedir}/fuse*
253 %{_libdir}/libfuse.la
254 %attr(755,root,root) %{_libdir}/libfuse.so
255 %{_pkgconfigdir}/fuse.pc
256
257 %files -n libfuse-static
258 %defattr(644,root,root,755)
259 %{_libdir}/libfuse.a
260 %endif
This page took 0.088381 seconds and 3 git commands to generate.