]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
7be4063660836245f05ef1aa39c43f791a794e09
[packages/libfuse.git] / libfuse.spec
1 # TODO:
2 # - unpackaged:
3 #   /etc/init.d/fuse
4 #   /etc/udev/rules.d/99-fuse.rules
5 #
6 # Condtional build:
7 %bcond_without  dist_kernel     # without distribution kernel
8 %bcond_with     kernel          # build kernel modules
9 %bcond_without  userspace       # don't build userspace tools
10 %bcond_with     verbose         # verbose build (V=1)
11 %bcond_without  selinux         # build without SELinux support
12
13 %ifarch sparc
14 %undefine       with_smp
15 %endif
16
17 %if %{without kernel}
18 %undefine with_dist_kernel
19 %endif
20 %if "%{_alt_kernel}" != "%{nil}"
21 %undefine       with_userspace
22 %endif
23
24 %define         pname   libfuse
25 %define         rel     1
26 Summary:        Filesystem in Userspace
27 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika
28 Name:           %{pname}%{_alt_kernel}
29 Version:        2.8.1
30 Release:        %{rel}
31 Epoch:          0
32 License:        GPL v2
33 Group:          Applications/System
34 Source0:        http://dl.sourceforge.net/fuse/fuse-%{version}.tar.gz
35 # Source0-md5:  0e3505ce90155983f1bc995eb2cf6fa7
36 Source1:        fuse.conf
37 Patch0:         kernel-misc-fuse-Makefile.am.patch
38 Patch1:         %{pname}-link.patch
39 URL:            http://fuse.sourceforge.net/
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  cpp
43 BuildRequires:  gettext-devel
44 BuildRequires:  libtool
45 BuildRequires:  sed >= 4.0
46 %if %{with kernel}
47 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
48 BuildRequires:  rpmbuild(macros) >= 1.379
49 %endif
50 %if %{with userspace}
51 %{?with_selinux:BuildRequires:  libselinux-devel}
52 %endif
53 Requires(pre):  /usr/bin/getgid
54 Requires(pre):  /usr/sbin/groupadd
55 Provides:       group(fuse)
56 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 %description
59 FUSE (Filesystem in Userspace) is a simple interface for userspace
60 programs to export a virtual filesystem to the Linux kernel. FUSE also
61 aims to provide a secure method for non privileged users to create and
62 mount their own filesystem implementations.
63
64 This package contains a shared library.
65
66 %description -l pl.UTF-8
67 FUSE stanowi prosty interfejs dla programów działających w przestrzeni
68 użytkownika eksportujący wirtualny system plików do jądra Linuksa.
69 FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
70 montowania własnych implementacji systemów plików przez zwykłych
71 (nieuprzywilejowanych) użytkowników.
72
73 Ten pakiet zawiera bibliotekę współdzieloną.
74
75 %package devel
76 Summary:        Filesytem in Userspace - Development header files
77 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - pliki nagłówkowe
78 Group:          Development/Libraries
79 Requires:       %{pname} = %{epoch}:%{version}-%{rel}
80
81 %description devel
82 Libfuse library header files.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki libfuse.
86
87 %package static
88 Summary:        Filesytem in Userspace - static library
89 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - biblioteka statyczna
90 Group:          Development/Libraries
91 Requires:       libfuse-devel = %{epoch}:%{version}-%{rel}
92
93 %description static
94 Static libfuse libraries.
95
96 %description static -l pl.UTF-8
97 Statyczna biblioteka libfuse.
98
99 %package -n kernel%{_alt_kernel}-misc-fuse
100 Summary:        Filesystem in Userspace
101 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika
102 Release:        %{rel}@%{_kernel_ver_str}
103 License:        GPL v2
104 Group:          Base/Kernel
105 Requires(post,postun):  /sbin/depmod
106 %if %{with dist_kernel}
107 %requires_releq_kernel
108 Requires(postun):       %releq_kernel
109 %endif
110 %if "%{_alt_kernel}" != "%{nil}"
111 Provides:       kernel-misc-fuse
112 %endif
113
114 %description -n kernel%{_alt_kernel}-misc-fuse
115 FUSE (Filesystem in Userspace) is a simple interface for userspace
116 programs to export a virtual filesystem to the Linux kernel. FUSE also
117 aims to provide a secure method for non privileged users to create and
118 mount their own filesystem implementations.
119
120 %description -n kernel%{_alt_kernel}-misc-fuse -l pl.UTF-8
121 FUSE stanowi prosty interfejs dla programów działających w przestrzeni
122 użytkownika eksportujący wirtualny system plików do jądra Linuksa.
123 FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
124 montowania własnych implementacji systemów plików przez zwykłych
125 (nieuprzywilejowanych) użytkowników.
126
127 %prep
128 %setup -q -n fuse-%{version}
129 %patch0 -p1
130 %patch1 -p1
131
132 sed -i '/FUSERMOUNT_PROG/s,fusermount,%{_bindir}/fusermount,' lib/mount.c
133
134 %build
135 %{__libtoolize}
136 %{__aclocal}
137 %{__autoheader}
138 %{__autoconf}
139 %{__automake}
140 %configure \
141         %{!?with_selinux:ac_cv_header_selinux_selinux_h=no} \
142         --%{?with_kernel:en}%{!?with_kernel:dis}able-kernel-module \
143         --enable-lib \
144         --enable-util \
145         %{?with_kernel:--with-kernel=%{_kernelsrcdir}}
146
147 %if %{with userspace}
148 for DIR in include lib util; do
149 %{__make} -C $DIR
150 done
151 %endif
152
153 %if %{with kernel}
154 %build_kernel_modules -m fuse -C kernel
155 %endif
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 install -d $RPM_BUILD_ROOT{%{_pkgconfigdir},%{_sysconfdir}}
160
161 %if %{with userspace}
162 for DIR in include lib util; do
163 %{__make} -C $DIR install \
164         DESTDIR=$RPM_BUILD_ROOT
165 done
166
167 install fuse.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
168 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
169 %endif
170
171 %if %{with kernel}
172 %install_kernel_modules -m kernel/fuse -d kernel/fs
173 %endif
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %pre
179 %groupadd -g 84 fuse
180
181 %post   -p /sbin/ldconfig
182 %postun -p /sbin/ldconfig
183
184 %post -n kernel%{_alt_kernel}-misc-fuse
185 %depmod %{_kernel_ver}
186
187 %postun -n kernel%{_alt_kernel}-misc-fuse
188 %depmod %{_kernel_ver}
189
190 %if %{with userspace}
191 %files
192 %defattr(644,root,root,755)
193 %doc README NEWS ChangeLog AUTHORS doc/*
194 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fuse.conf
195 %attr(4754,root,fuse) %{_bindir}/fusermount
196 %attr(755,root,root) %{_bindir}/ulockmgr_server
197 %attr(755,root,root) /sbin/mount.fuse
198 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
199 %attr(755,root,root) %ghost %{_libdir}/libfuse.so.2
200 %attr(755,root,root) %{_libdir}/libulockmgr.so.*.*.*
201 %attr(755,root,root) %ghost %{_libdir}/libulockmgr.so.1
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/libfuse.so
206 %attr(755,root,root) %{_libdir}/libulockmgr.so
207 %{_libdir}/libfuse.la
208 %{_libdir}/libulockmgr.la
209 %{_includedir}/fuse
210 %{_includedir}/fuse.h
211 %{_includedir}/ulockmgr.h
212 %{_pkgconfigdir}/fuse.pc
213
214 %files static
215 %defattr(644,root,root,755)
216 %{_libdir}/libfuse.a
217 %{_libdir}/libulockmgr.a
218 %endif
219
220 %if %{with kernel}
221 %files -n kernel%{_alt_kernel}-misc-fuse
222 %defattr(644,root,root,755)
223 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
224 %endif
This page took 0.050309 seconds and 3 git commands to generate.