]> git.pld-linux.org Git - packages/libfuse.git/blob - libfuse.spec
3c2076b0701c2533e1304fd4994668f202df2b59
[packages/libfuse.git] / libfuse.spec
1 # TODO:
2 # - unpackaged:
3 #   /etc/init.d/fuse
4 #   /etc/udev/rules.d/99-fuse.rules
5 #
6 # Condtional build:
7 %bcond_without  dist_kernel     # without distribution kernel
8 %bcond_with     kernel          # build kernel modules
9 %bcond_without  userspace       # don't build userspace tools
10 %bcond_with     verbose         # verbose build (V=1)
11 %bcond_without  selinux         # build without SELinux support
12
13 %ifarch sparc
14 %undefine       with_smp
15 %endif
16
17 %if %{without kernel}
18 %undefine with_dist_kernel
19 %endif
20 %if "%{_alt_kernel}" != "%{nil}"
21 %undefine       with_userspace
22 %endif
23
24 %define         pname   libfuse
25 %define         _rel    1
26 Summary:        Filesystem in Userspace
27 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika
28 Name:           %{pname}%{_alt_kernel}
29 Version:        2.7.3
30 Release:        %{_rel}
31 Epoch:          0
32 License:        GPL v2
33 Group:          Applications/System
34 Source0:        http://dl.sourceforge.net/fuse/fuse-%{version}.tar.gz
35 # Source0-md5:  98563fc7b265b7479a3178181cbcf59a
36 Source1:        fuse.conf
37 Patch0:         kernel-misc-fuse-Makefile.am.patch
38 Patch1:         %{pname}-link.patch
39 URL:            http://fuse.sourceforge.net/
40 BuildRequires:  autoconf
41 BuildRequires:  automake
42 BuildRequires:  libtool
43 BuildRequires:  cpp
44 BuildRequires:  sed >= 4.0
45 %if %{with kernel}
46 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
47 BuildRequires:  rpmbuild(macros) >= 1.379
48 %endif
49 %if %{with userspace}
50 %{?with_selinux:BuildRequires:  libselinux-devel}
51 %endif
52 Requires(postun):       /sbin/ldconfig
53 Requires(postun):       /usr/sbin/groupdel
54 Requires(pre):  /usr/bin/getgid
55 Requires(pre):  /usr/sbin/groupadd
56 Provides:       group(fuse)
57 Buildroot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 FUSE (Filesystem in Userspace) is a simple interface for userspace
61 programs to export a virtual filesystem to the Linux kernel. FUSE also
62 aims to provide a secure method for non privileged users to create and
63 mount their own filesystem implementations.
64
65 This package contains a shared library.
66
67 %description -l pl.UTF-8
68 FUSE stanowi prosty interfejs dla programów działających w przestrzeni
69 użytkownika eksportujący wirtualny system plików do jądra Linuksa.
70 FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
71 montowania własnych implementacji systemów plików przez zwykłych
72 (nieuprzywilejowanych) użytkowników.
73
74 Ten pakiet zawiera bibliotekę współdzieloną.
75
76 %package devel
77 Summary:        Filesytem in Userspace - Development header files
78 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - pliki nagłówkowe
79 Group:          Development/Libraries
80 Requires:       %{pname} = %{epoch}:%{version}-%{_rel}
81
82 %description devel
83 Libfuse library header files.
84
85 %description devel -l pl.UTF-8
86 Pliki nagłówkowe biblioteki libfuse.
87
88 %package static
89 Summary:        Filesytem in Userspace - static library
90 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika - biblioteka statyczna
91 Group:          Development/Libraries
92 Requires:       libfuse-devel = %{epoch}:%{version}-%{_rel}
93
94 %description static
95 Static libfuse libraries.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka libfuse.
99
100 %package -n kernel%{_alt_kernel}-misc-fuse
101 Summary:        Filesystem in Userspace
102 Summary(pl.UTF-8):      System plików w przestrzeni użytkownika
103 Release:        %{_rel}@%{_kernel_ver_str}
104 License:        GPL v2
105 Group:          Base/Kernel
106 Requires(post,postun):  /sbin/depmod
107 %if %{with dist_kernel}
108 %requires_releq_kernel
109 Requires(postun):       %releq_kernel
110 %endif
111 %if "%{_alt_kernel}" != "%{nil}"
112 Provides:       kernel-misc-fuse
113 %endif
114
115 %description -n kernel%{_alt_kernel}-misc-fuse
116 FUSE (Filesystem in Userspace) is a simple interface for userspace
117 programs to export a virtual filesystem to the Linux kernel. FUSE also
118 aims to provide a secure method for non privileged users to create and
119 mount their own filesystem implementations.
120
121 %description -n kernel%{_alt_kernel}-misc-fuse -l pl.UTF-8
122 FUSE stanowi prosty interfejs dla programów działających w przestrzeni
123 użytkownika eksportujący wirtualny system plików do jądra Linuksa.
124 FUSE ma również na celu udostępnienie bezpiecznej metody tworzenia i
125 montowania własnych implementacji systemów plików przez zwykłych
126 (nieuprzywilejowanych) użytkowników.
127
128 %prep
129 %setup -q -n fuse-%{version}
130 %patch0 -p1
131 %patch1 -p1
132
133 sed -i '/FUSERMOUNT_PROG/s,fusermount,%{_bindir}/fusermount,' lib/mount.c
134
135 %build
136 %{__libtoolize}
137 %{__aclocal}
138 %{__autoheader}
139 %{__autoconf}
140 %{__automake}
141 %configure \
142         %{!?with_selinux:ac_cv_header_selinux_selinux_h=no} \
143         --%{?with_kernel:en}%{!?with_kernel:dis}able-kernel-module \
144         --enable-lib \
145         --enable-util \
146         %{?with_kernel:--with-kernel=%{_kernelsrcdir}}
147
148 %if %{with userspace}
149 cp kernel/fuse_kernel.h include/
150 for DIR in include lib util; do
151 %{__make} -C $DIR
152 done
153 %endif
154
155 %if %{with kernel}
156 %build_kernel_modules -m fuse -C kernel
157 %endif
158
159 %install
160 rm -rf $RPM_BUILD_ROOT
161 install -d $RPM_BUILD_ROOT{%{_pkgconfigdir},%{_sysconfdir}}
162
163 %if %{with userspace}
164 for DIR in include lib util; do
165 %{__make} -C $DIR install \
166         DESTDIR=$RPM_BUILD_ROOT
167 done
168
169 install fuse.pc $RPM_BUILD_ROOT%{_pkgconfigdir}
170 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
171 %endif
172
173 %if %{with kernel}
174 %install_kernel_modules -m kernel/fuse -d kernel/fs
175 %endif
176
177 %clean
178 rm -rf $RPM_BUILD_ROOT
179
180 %pre
181 %groupadd -g 84 fuse
182
183 %post   -p /sbin/ldconfig
184 %postun
185 /sbin/ldconfig
186 if [ "$1" = "0" ] ; then
187         %groupremove fuse
188 fi
189
190 %post -n kernel%{_alt_kernel}-misc-fuse
191 %depmod %{_kernel_ver}
192
193 %postun -n kernel%{_alt_kernel}-misc-fuse
194 %depmod %{_kernel_ver}
195
196 %if %{with userspace}
197 %files
198 %defattr(644,root,root,755)
199 %doc README NEWS ChangeLog AUTHORS doc/*
200 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/fuse.conf
201 %attr(4754,root,fuse) %{_bindir}/fusermount
202 %attr(755,root,root) %{_bindir}/ulockmgr_server
203 %attr(755,root,root) /sbin/mount.fuse
204 %attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
205 %attr(755,root,root) %ghost %{_libdir}/libfuse.so.2
206 %attr(755,root,root) %{_libdir}/libulockmgr.so.*.*.*
207 %attr(755,root,root) %ghost %{_libdir}/libulockmgr.so.1
208
209 %files devel
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/libfuse.so
212 %attr(755,root,root) %{_libdir}/libulockmgr.so
213 %{_libdir}/libfuse.la
214 %{_libdir}/libulockmgr.la
215 %{_includedir}/fuse
216 %{_includedir}/fuse.h
217 %{_includedir}/ulockmgr.h
218 %{_pkgconfigdir}/fuse.pc
219
220 %files static
221 %defattr(644,root,root,755)
222 %{_libdir}/libfuse.a
223 %{_libdir}/libulockmgr.a
224 %endif
225
226 %if %{with kernel}
227 %files -n kernel%{_alt_kernel}-misc-fuse
228 %defattr(644,root,root,755)
229 /lib/modules/%{_kernel_ver}/kernel/fs/fuse.ko*
230 %endif
This page took 0.070629 seconds and 3 git commands to generate.