]> git.pld-linux.org Git - packages/libfido2.git/blob - libfido2.spec
macros for %cmake
[packages/libfido2.git] / libfido2.spec
1 Summary:        Library functionality for FIDO 2.0, including communication with a device over USB
2 Summary(pl.UTF-8):      Biblioteka funkcji dla FIDO 2.0, wraz z komunikacją z urządzeniem po USB
3 Name:           libfido2
4 Version:        1.9.0
5 Release:        1
6 License:        BSD
7 Group:          Libraries
8 #Source0Download: https://github.com/Yubico/libfido2/releases
9 Source0:        https://github.com/Yubico/libfido2/archive/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  ef5bea44900665ae7893e0b5cc740277
11 URL:            https://developers.yubico.com/libfido2/
12 BuildRequires:  cmake >= 3.0
13 BuildRequires:  hidapi-devel
14 BuildRequires:  libcbor-devel
15 BuildRequires:  openssl-devel >= 1.1.0
16 BuildRequires:  pkgconfig
17 BuildRequires:  rpmbuild(macros) >= 1.605
18 BuildRequires:  udev-devel
19 BuildRequires:  zlib-devel
20 Requires:       openssl >= 1.1.0
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This package provides library functionality for communicating with a
25 FIDO device over USB as well as verifying attestation and assertion
26 signatures.
27
28 %description -l pl.UTF-8
29 Ten pakiet zawiera bibliotekę funkcji do komunikacji z urządzeniami
30 FIDO po USB, a także weryfikowania podpisów poświadczeń i zapewnień.
31
32 %package devel
33 Summary:        Header files for FIDO2 library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki FIDO2
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       openssl-devel >= 1.1.0
38
39 %description devel
40 Header files for FIDO2 library.
41
42 %description devel -l pl.UTF-8
43 Pliki nagłówkowe biblioteki FIDO2.
44
45 %package static
46 Summary:        Static FIDO2 library
47 Summary(pl.UTF-8):      Biblioteka statyczna FIDO2
48 Group:          Development/Libraries
49 Requires:       %{name}-devel = %{version}-%{release}
50
51 %description static
52 Static FIDO2 library.
53
54 %description static -l pl.UTF-8
55 Biblioteka statyczna FIDO2.
56
57 %prep
58 %setup -q
59
60 %build
61 install -d build
62 cd build
63 # note: exects CMAKE_INSTALL_LIBDIR relative to prefix
64 %cmake .. \
65         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
66         -DGZIP_PATH=FALSE \
67         -DUSE_HIDAPI=ON \
68         -DNFC_LINUX=ON
69
70 %{__make}
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} -C build install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %files
85 %defattr(644,root,root,755)
86 %doc LICENSE README.adoc
87 %attr(755,root,root) %{_bindir}/fido2-assert
88 %attr(755,root,root) %{_bindir}/fido2-cred
89 %attr(755,root,root) %{_bindir}/fido2-token
90 %attr(755,root,root) %{_libdir}/libfido2.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libfido2.so.1
92 %{_mandir}/man1/fido2-assert.1*
93 %{_mandir}/man1/fido2-cred.1*
94 %{_mandir}/man1/fido2-token.1*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/libfido2.so
99 %{_includedir}/fido
100 %{_includedir}/fido.h
101 %{_pkgconfigdir}/libfido2.pc
102 %{_mandir}/man3/*_pk_*.3*
103 %{_mandir}/man3/fido*.3*
104
105 %files static
106 %defattr(644,root,root,755)
107 %{_libdir}/libfido2.a
This page took 0.071064 seconds and 4 git commands to generate.