]> git.pld-linux.org Git - packages/libextractor.git/blob - libextractor.spec
- update to 0.5.0
[packages/libextractor.git] / libextractor.spec
1 #
2 # Conditional build:
3 %bcond_with     static          # build with static glib
4 #
5 Summary:        Meta-data extraction library
6 Summary(pl):    Biblioteka do ekstrakcji metadanych
7 Name:           libextractor
8 Version:        0.5.0
9 Release:        1
10 License:        GPL
11 Group:          Libraries
12 # strange, .tar.gz is ~500kB smaller than .tar.bz2
13 Source0:        http://gnunet.org/libextractor/download/%{name}-%{version}.tar.gz
14 # Source0-md5:  5ca78c69a523e54b8c3c08369786f48a
15 Patch0:         %{name}-make_python.patch
16 URL:            http://gnunet.org/libextractor/
17 BuildRequires:  ImageMagick-devel >= 1:6.0.0
18 BuildRequires:  autoconf >= 2.57
19 BuildRequires:  automake
20 BuildRequires:  gettext-devel >= 0.14
21 %if %{with static}
22 BuildRequires:  glib2-static >= 2.0.0
23 %else
24 BuildRequires:  glib2-devel >= 2.0.0
25 %endif
26 BuildRequires:  libltdl-devel
27 BuildRequires:  libstdc++-devel
28 BuildRequires:  libtool >= 2:1.5
29 BuildRequires:  libvorbis-devel
30 BuildRequires:  python-devel >= 1:2.3
31 BuildRequires:  zlib-devel
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 libextractor is a simple library for meta-data extraction.
36 libextractor uses a plugin-mechanism that makes it easy to add support
37 for more file formats, allowing anybody to add new extractors quickly.
38
39 libextractor currently features meta-data extractors for HTML, JPEG,
40 Ogg, MP3, PNG, RPM, GIF, ZIP, QT, ASF, Real Audio and Video,
41 PostScript and PDF documents. It also detects many more MIME-types in
42 a fashion similar to the well-known "file" tool.
43
44 Each item of meta-data that is extracted from a file is categorized
45 into one of currently about 40 meta-data categories (e.g. title,
46 author, description or MIME-type).
47
48 This libextractor package also contains a little binary tool "extract"
49 that can be used to invoke libextractor from the command line.
50 "extract" can be used similar to "file", but while "file" currently
51 supports a wider range of file types, "extract" should be able to
52 provide more precise and more detailed information for the supported
53 types of documents (HTML, JPEG, Ogg, MP3, PNG, GIF, RPM, RA, RM, PS,
54 PDF, ZIP, QT, ASF).
55
56 %description -l pl
57 libextractor to prosta biblioteka s³u¿±ca do ekstrakcji metadanych.
58 libextractor u¿ywa mechanizmu "wtyczek", dziêki czemu ³atwo jest dodaæ
59 wsparcie dla nowych formatów plików.
60
61 libextractor obecnie pozwala na pozyskanie metadanych z plików w
62 formatach HTML, JPEG, Ogg, MP3, PNG, RPM, GIF, ZIP, QT, ASF, Real
63 Audio i Video, PostScript oraz PDF. Ponadto rozpoznaje du¿o wiêcej
64 typów MIME w sposób podobny do dobrze znanego narzêdzia "file".
65
66 Ka¿da informacja pobrana z pliku nale¿y do jednej z oko³o 40
67 kategorii (np. tytu³, autor, opis, typ MIME).
68
69 Ta paczka zawiera te¿ narzêdzie "extract", które pozwala skorzystaæ z
70 us³ug libextractor bezpo¶rednio z linii poleceñ. "extract" mo¿e byæ
71 u¿ywane w podobny sposób, co "file". "file" zna wiêcej typów danych,
72 "extract" natomiast dostarcza bardziej precyzyjnych i szczegó³owych
73 informacji na temat obs³ugiwanych formatów (HTML, JPEG, Ogg, MP3, PNG,
74 GIF, RPM, RA, RM, PS, PDF, ZIP, QT, ASF).
75
76 %package printable
77 Summary:        Printable text support plugins for libextractor
78 Summary(pl):    Wtyczki obs³uguj±ce tekst dla biblioteki libextractor
79 Group:          Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description printable
83 libextractor plugins that support printable text in few languages.
84
85 %description printable -l pl
86 Wtyczki biblioteki libextractor obs³uguj±ce tekst w kilku jêzykach.
87
88 %package devel
89 Summary:        Development files for libextractor
90 Summary(pl):    Pliki nag³ówkowe libextractor
91 Group:          Development/Libraries
92 Requires:       %{name} = %{version}-%{release}
93 Requires:       libltdl-devel
94
95 %description devel
96 This package contains files to develop with libextractor, that is
97 either to create plugins or to compile applications with libextractor.
98
99 %description devel -l pl
100 Piki nag³ówkowe wymagane do tworzenia aplikacji i wtyczek
101 korzystaj±cych z libextractor.
102
103 %package static
104 Summary:        Static libextractor libraries
105 Summary(pl):    Statyczne biblioteki libextractor
106 Group:          Development/Libraries
107 Requires:       %{name}-devel = %{version}-%{release}
108
109 %description static
110 This package contains static libraries of libextractor.
111
112 %description static -l pl
113 Statyczna wersja bibliotek libextractor.
114
115 %package -n python-extractor
116 Summary:        Python support for libextractor
117 Summary(pl):    Modu³ jêzyka Python dla biblioteki libextractor
118 Group:          Libraries/Python
119 Requires:       %{name} = %{version}-%{release}
120 %pyrequires_eq  python-libs
121
122 %description -n python-extractor
123 Python support for libextractor.
124
125 %description -n python-extractor -l pl
126 Modu³ jêzyka Python dla biblioteki libextractor.
127
128 %prep
129 %setup -q
130 %patch0 -p1
131
132 %if %{without static}
133 %{__perl} -pi -e 's/-B(static|dynamic)//g' src/plugins/ole2/Makefile.am
134 %endif
135
136 %build
137 %{__gettextize}
138 %{__libtoolize} --ltdl
139 %{__aclocal} -I m4
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 %configure
144
145 %{__make}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 # useless
154 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/libextractor_*.a
155
156 %find_lang %{name}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post   -p /sbin/ldconfig
162 %postun -p /sbin/ldconfig
163
164 %files -f %{name}.lang
165 %defattr(644,root,root,755)
166 %doc AUTHORS ChangeLog NEWS README TODO
167 %attr(755,root,root) %{_bindir}/extract
168 %attr(755,root,root) %{_libdir}/libextractor.so.*.*.*
169 # plugins are lt_dlopened without extension, so *.la are needed
170 %dir %{_libdir}/%{name}
171 %attr(755,root,root) %{_libdir}/%{name}/libextractor_asf.so
172 %attr(755,root,root) %{_libdir}/%{name}/libextractor_deb.so
173 %attr(755,root,root) %{_libdir}/%{name}/libextractor_dvi.so
174 %attr(755,root,root) %{_libdir}/%{name}/libextractor_elf.so
175 %attr(755,root,root) %{_libdir}/%{name}/libextractor_filename.so
176 %attr(755,root,root) %{_libdir}/%{name}/libextractor_gif.so
177 %attr(755,root,root) %{_libdir}/%{name}/libextractor_hash_md5.so
178 %attr(755,root,root) %{_libdir}/%{name}/libextractor_hash_rmd160.so
179 %attr(755,root,root) %{_libdir}/%{name}/libextractor_hash_sha1.so
180 %attr(755,root,root) %{_libdir}/%{name}/libextractor_html.so
181 %attr(755,root,root) %{_libdir}/%{name}/libextractor_id3v2.so
182 %attr(755,root,root) %{_libdir}/%{name}/libextractor_id3v23.so
183 %attr(755,root,root) %{_libdir}/%{name}/libextractor_id3v24.so
184 %attr(755,root,root) %{_libdir}/%{name}/libextractor_jpeg.so
185 %attr(755,root,root) %{_libdir}/%{name}/libextractor_lower.so
186 %attr(755,root,root) %{_libdir}/%{name}/libextractor_man.so
187 %attr(755,root,root) %{_libdir}/%{name}/libextractor_mime.so
188 %attr(755,root,root) %{_libdir}/%{name}/libextractor_mp3.so
189 %attr(755,root,root) %{_libdir}/%{name}/libextractor_mpeg.so
190 %attr(755,root,root) %{_libdir}/%{name}/libextractor_ogg.so
191 %attr(755,root,root) %{_libdir}/%{name}/libextractor_ole2.so
192 %attr(755,root,root) %{_libdir}/%{name}/libextractor_oo.so
193 %attr(755,root,root) %{_libdir}/%{name}/libextractor_pdf.so
194 %attr(755,root,root) %{_libdir}/%{name}/libextractor_png.so
195 %attr(755,root,root) %{_libdir}/%{name}/libextractor_ps.so
196 %attr(755,root,root) %{_libdir}/%{name}/libextractor_qt.so
197 %attr(755,root,root) %{_libdir}/%{name}/libextractor_real.so
198 %attr(755,root,root) %{_libdir}/%{name}/libextractor_riff.so
199 %attr(755,root,root) %{_libdir}/%{name}/libextractor_rpm.so
200 %attr(755,root,root) %{_libdir}/%{name}/libextractor_split.so
201 %attr(755,root,root) %{_libdir}/%{name}/libextractor_tar.so
202 %attr(755,root,root) %{_libdir}/%{name}/libextractor_thumbnail.so
203 %attr(755,root,root) %{_libdir}/%{name}/libextractor_tiff.so
204 %attr(755,root,root) %{_libdir}/%{name}/libextractor_translit.so
205 %attr(755,root,root) %{_libdir}/%{name}/libextractor_wav.so
206 %attr(755,root,root) %{_libdir}/%{name}/libextractor_zip.so
207 %{_libdir}/%{name}/libextractor_asf.la
208 %{_libdir}/%{name}/libextractor_deb.la
209 %{_libdir}/%{name}/libextractor_dvi.la
210 %{_libdir}/%{name}/libextractor_elf.la
211 %{_libdir}/%{name}/libextractor_filename.la
212 %{_libdir}/%{name}/libextractor_gif.la
213 %{_libdir}/%{name}/libextractor_hash_md5.la
214 %{_libdir}/%{name}/libextractor_hash_rmd160.la
215 %{_libdir}/%{name}/libextractor_hash_sha1.la
216 %{_libdir}/%{name}/libextractor_html.la
217 %{_libdir}/%{name}/libextractor_id3v2.la
218 %{_libdir}/%{name}/libextractor_id3v23.la
219 %{_libdir}/%{name}/libextractor_id3v24.la
220 %{_libdir}/%{name}/libextractor_jpeg.la
221 %{_libdir}/%{name}/libextractor_lower.la
222 %{_libdir}/%{name}/libextractor_man.la
223 %{_libdir}/%{name}/libextractor_mime.la
224 %{_libdir}/%{name}/libextractor_mp3.la
225 %{_libdir}/%{name}/libextractor_mpeg.la
226 %{_libdir}/%{name}/libextractor_ogg.la
227 %{_libdir}/%{name}/libextractor_ole2.la
228 %{_libdir}/%{name}/libextractor_oo.la
229 %{_libdir}/%{name}/libextractor_pdf.la
230 %{_libdir}/%{name}/libextractor_png.la
231 %{_libdir}/%{name}/libextractor_ps.la
232 %{_libdir}/%{name}/libextractor_qt.la
233 %{_libdir}/%{name}/libextractor_real.la
234 %{_libdir}/%{name}/libextractor_riff.la
235 %{_libdir}/%{name}/libextractor_rpm.la
236 %{_libdir}/%{name}/libextractor_split.la
237 %{_libdir}/%{name}/libextractor_tar.la
238 %{_libdir}/%{name}/libextractor_thumbnail.la
239 %{_libdir}/%{name}/libextractor_tiff.la
240 %{_libdir}/%{name}/libextractor_translit.la
241 %{_libdir}/%{name}/libextractor_wav.la
242 %{_libdir}/%{name}/libextractor_zip.la
243 %{_mandir}/man1/*
244
245 %files printable
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/%{name}/libextractor_printable_*.so
248 %{_libdir}/%{name}/libextractor_printable_*.la
249
250 %files devel
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_libdir}/libextractor.so
253 %{_libdir}/libextractor.la
254 %{_includedir}/extractor.h
255 %{_mandir}/man3/*
256
257 %files static
258 %defattr(644,root,root,755)
259 %{_libdir}/libextractor.a
260
261 %files -n python-extractor
262 %defattr(644,root,root,755)
263 %attr(755,root,root) %{py_sitedir}/*.so
This page took 0.049371 seconds and 4 git commands to generate.