]> git.pld-linux.org Git - packages/libextractor.git/blob - libextractor.spec
- fixed build (including amd64), BR: ac,am,lt
[packages/libextractor.git] / libextractor.spec
1 Summary:        Meta-data extraction library
2 Summary(pl):    Biblioteka do ekstrakcji metadanych
3 Name:           libextractor
4 Version:        0.3.3
5 Release:        1
6 License:        GPL
7 Group:          Libraries
8 # strange, .tar.gz is ~500kB smaller than .tar.bz2
9 Source0:        http://www.ovmj.org/libextractor/download/%{name}-%{version}.tar.gz
10 # Source0-md5:  0e70401b3a1574bf16caf17a4af78398
11 URL:            http://www.ovmj.org/libextractor/
12 BuildRequires:  autoconf >= 2.57
13 BuildRequires:  automake
14 BuildRequires:  libltdl-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool >= 2:1.5
17 BuildRequires:  libvorbis-devel
18 BuildRequires:  zlib-devel
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 libextractor is a simple library for meta-data extraction.
23 libextractor uses a plugin-mechanism that makes it easy to add support
24 for more file formats, allowing anybody to add new extractors quickly.
25
26 libextractor currently features meta-data extractors for HTML, JPEG,
27 OGG, MP3, PNG, RPM, GIF, ZIP, QT, ASF, Real Audio and Video,
28 PostScript and PDF documents. It also detects many more MIME-types in
29 a fashion similar to the well-known "file" tool.
30
31 Each item of meta-data that is extracted from a file is categorized
32 into one of currently about 40 meta-data categories (e.g. title,
33 author, description or MIME-type).
34
35 This libextractor package also contains a little binary tool "extract"
36 that can be used to invoke libextractor from the command line.
37 "extract" can be used similar to "file", but while "file" currently
38 supports a wider range of file types, "extract" should be able to
39 provide more precise and more detailed information for the supported
40 types of documents (HTML, JPEG, OGG, MP3, PNG, GIF, RPM, RA, RM, PS,
41 PDF, ZIP, QT, ASF).
42
43 %description -l pl
44 libextractor to prosta biblioteka s³u¿±ca do ekstrakcji metadanych.
45 libextractor u¿ywa mechanizmu "wtyczek", dziêki czemu ³atwo jest dodaæ
46 wsparcie dla nowych formatów plików.
47
48 libextractor obecnie pozwala na pozyskanie metadanych z plików w
49 formatach HTML, JPEG, OGG, MP3, PNG, RPM, GIF, ZIP, QT, ASF, Real
50 Audio i Video, PostScript oraz PDF. Ponadto rozpoznaje du¿o wiêcej
51 typów MIME w sposób podobny do dobrze znanego narzêdzia "file".
52
53 Ka¿da informacja pobrana z pliku nale¿y do jednej z oko³o 40
54 kategorii (np. tytu³, autor, opis, typ MIME).
55
56 Ta paczka zawiera te¿ narzedzie "extract", które pozwala skorzystaæ z
57 us³ug libextractor bezpo¶rednio z linii poleceñ. "extract" mo¿e byæ
58 u¿ywane w podobny sposób, co "file". "file" zna wiêcej typów danych,
59 "extract" natomiast dostarcza bardziej precyzyjnych i szczegó³owych
60 informacji na temat obs³ugiwanych formatów (HTML, JPEG, OGG, MP3, PNG,
61 GIF, RPM, RA, RM, PS, PDF, ZIP, QT, ASF).
62
63 %package printable
64 Summary:        Printable text support plugins for libextractor
65 Summary(pl):    Wtyczki obs³uguj±ce tekst dla biblioteki libextractor
66 Group:          Libraries
67 Requires:       %{name} = %{version}-%{release}
68
69 %description printable
70 libextractor plugins that support printable text in few languages.
71
72 %description printable -l pl
73 Wtyczki biblioteki libextractor obs³uguj±ce tekst w kilku jêzykach.
74
75 %package devel
76 Summary:        Development files for libextractor
77 Summary(pl):    Pliki nag³ówkowe libextractor
78 Group:          Development/Libraries
79 Requires:       %{name} = %{version}-%{release}
80 Requires:       libltdl-devel
81
82 %description devel
83 This package contains files to develop with libextractor, that is
84 either to create plugins or to compile applications with libextractor.
85
86 %description devel -l pl
87 Piki nag³ówkowe wymagane do tworzenia aplikacji i wtyczek
88 korzystaj±cych z libextractor.
89
90 %package static
91 Summary:        Static libextractor libraries
92 Summary(pl):    Statyczne biblioteki libextractor
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{version}-%{release}
95
96 %description static
97 This package contains static libraries of libextractor.
98
99 %description static -l pl
100 Statyczna wersja bibliotek libextractor.
101
102 %prep
103 %setup -q
104
105 %build
106 # gettext is not used yet
107 #%%{__gettextize}
108 %{__libtoolize} --ltdl
109 %{__aclocal}
110 %{__autoconf}
111 %{__autoheader}
112 %{__automake}
113 %configure
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 # useless
124 rm -f $RPM_BUILD_ROOT%{_libdir}/libextractor_[!u]*.a
125
126 %clean
127 rm -rf $RPM_BUILD_ROOT
128
129 %post   -p /sbin/ldconfig
130 %postun -p /sbin/ldconfig
131
132 %files
133 %defattr(644,root,root,755)
134 %doc AUTHORS ChangeLog NEWS README TODO
135 %attr(755,root,root) %{_bindir}/extract
136 %attr(755,root,root) %{_libdir}/libextractor.so.*.*.*
137 # plugins are lt_dlopened without extension, so *.la are needed
138 %attr(755,root,root) %{_libdir}/libextractor_asf.so
139 %attr(755,root,root) %{_libdir}/libextractor_elf.so
140 %attr(755,root,root) %{_libdir}/libextractor_filename.so
141 %attr(755,root,root) %{_libdir}/libextractor_gif.so
142 %attr(755,root,root) %{_libdir}/libextractor_html.so
143 %attr(755,root,root) %{_libdir}/libextractor_jpeg.so
144 %attr(755,root,root) %{_libdir}/libextractor_lower.so
145 %attr(755,root,root) %{_libdir}/libextractor_mime.so
146 %attr(755,root,root) %{_libdir}/libextractor_mp3.so
147 %attr(755,root,root) %{_libdir}/libextractor_mpeg.so
148 %attr(755,root,root) %{_libdir}/libextractor_ogg.so
149 %attr(755,root,root) %{_libdir}/libextractor_pdf.so
150 %attr(755,root,root) %{_libdir}/libextractor_png.so
151 %attr(755,root,root) %{_libdir}/libextractor_ps.so
152 %attr(755,root,root) %{_libdir}/libextractor_qt.so
153 %attr(755,root,root) %{_libdir}/libextractor_real.so
154 %attr(755,root,root) %{_libdir}/libextractor_riff.so
155 %attr(755,root,root) %{_libdir}/libextractor_rpm.so
156 %attr(755,root,root) %{_libdir}/libextractor_split.so
157 %attr(755,root,root) %{_libdir}/libextractor_tiff.so
158 %attr(755,root,root) %{_libdir}/libextractor_wav.so
159 %attr(755,root,root) %{_libdir}/libextractor_zip.so
160 %{_libdir}/libextractor_asf.la
161 %{_libdir}/libextractor_elf.la
162 %{_libdir}/libextractor_filename.la
163 %{_libdir}/libextractor_gif.la
164 %{_libdir}/libextractor_html.la
165 %{_libdir}/libextractor_jpeg.la
166 %{_libdir}/libextractor_lower.la
167 %{_libdir}/libextractor_mime.la
168 %{_libdir}/libextractor_mp3.la
169 %{_libdir}/libextractor_mpeg.la
170 %{_libdir}/libextractor_ogg.la
171 %{_libdir}/libextractor_pdf.la
172 %{_libdir}/libextractor_png.la
173 %{_libdir}/libextractor_ps.la
174 %{_libdir}/libextractor_qt.la
175 %{_libdir}/libextractor_real.la
176 %{_libdir}/libextractor_riff.la
177 %{_libdir}/libextractor_rpm.la
178 %{_libdir}/libextractor_split.la
179 %{_libdir}/libextractor_tiff.la
180 %{_libdir}/libextractor_wav.la
181 %{_libdir}/libextractor_zip.la
182 %{_mandir}/man1/*
183
184 %files printable
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/libextractor_printable_*.so
187 %{_libdir}/libextractor_printable_*.la
188
189 %files devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libextractor.so
192 %{_libdir}/libextractor.la
193 %{_includedir}/extractor.h
194 %{_mandir}/man3/*
195
196 %files static
197 %defattr(644,root,root,755)
198 %{_libdir}/libextractor.a
This page took 0.083084 seconds and 4 git commands to generate.