]> git.pld-linux.org Git - packages/libevent.git/blob - libevent.spec
- rel 2
[packages/libevent.git] / libevent.spec
1 # TODO: %{_bindir}/event_rpcgen.py - rename to event_rpcgen?
2 #
3 # Conditional build:
4 %bcond_without  static_libs     # don't build static library
5 #
6 Summary:        libevent - an event notification library
7 Summary(pl.UTF-8):      libevent - biblioteka powiadamiająca o zdarzeniach
8 Name:           libevent
9 Version:        2.0.14
10 Release:        2
11 License:        BSD
12 Group:          Libraries
13 Source0:        https://github.com/downloads/libevent/libevent/%{name}-%{version}-stable.tar.gz
14 # Source0-md5:  cac0f379da35d3b98f83ac16fcfe1df4
15 Patch0:         %{name}-fpm.patch
16 Patch1:         %{name}-link.patch
17 URL:            http://www.monkey.org/~provos/libevent/
18 BuildRequires:  autoconf >= 2.60
19 BuildRequires:  automake
20 BuildRequires:  libtool
21 BuildRequires:  openssl-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  zlib-devel
24 Obsoletes:      libevent-dietlibc
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The libevent API provides a mechanism to execute a callback function
29 when a specific event occurs on a file descriptor or after a timeout
30 has been reached. It is meant to replace the asynchronous event loop
31 found in event-driven network servers.
32
33 %description -l pl.UTF-8
34 API libevent dostarcza mechanizm do wykonywania funkcji callback,
35 kiedy nastąpiło określone zdarzenie w deskryptorze pliku lub po
36 określonym czasie. Ma to na celu zastąpienie asynchronicznych pętli w
37 sterowanych zdarzeniami usługach sieciowych.
38
39 %package devel
40 Summary:        Header files for libevent library
41 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libevent
42 Group:          Development/Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       openssl-devel
45
46 %description devel
47 Header files for libevent library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki libevent.
51
52 %package static
53 Summary:        Static libevent library
54 Summary(pl.UTF-8):      Statyczna biblioteka libevent
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static libevent library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka libevent.
63
64 %prep
65 %setup -q -n %{name}-%{version}-stable
66 %patch0 -p1
67 %patch1 -p1
68
69 %build
70 %{__libtoolize}
71 %{__aclocal} -I m4
72 %{__autoconf}
73 %{__automake}
74 %configure \
75         %{!?with_static_libs:--disable-static}
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT/%{_lib}
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 mv -f $RPM_BUILD_ROOT%{_libdir}/libevent-2.0.so.* $RPM_BUILD_ROOT/%{_lib}
86 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libevent-2.0.so.*.*.*) \
87         $RPM_BUILD_ROOT%{_libdir}/libevent.so
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %doc ChangeLog LICENSE README
98 %attr(755,root,root) /%{_lib}/libevent-2.0.so.*.*.*
99 %attr(755,root,root) %ghost /%{_lib}/libevent-2.0.so.5
100 %attr(755,root,root) %{_libdir}/libevent_core-2.0.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libevent_core-2.0.so.5
102 %attr(755,root,root) %{_libdir}/libevent_extra-2.0.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libevent_extra-2.0.so.5
104 %attr(755,root,root) %{_libdir}/libevent_openssl-2.0.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libevent_openssl-2.0.so.5
106 %attr(755,root,root) %{_libdir}/libevent_pthreads-2.0.so.*.*.*
107 %attr(755,root,root) %ghost %{_libdir}/libevent_pthreads-2.0.so.5
108
109 %files devel
110 %defattr(644,root,root,755)
111 # R: python
112 %attr(755,root,root) %{_bindir}/event_rpcgen.py
113 %attr(755,root,root) %{_libdir}/libevent.so
114 %attr(755,root,root) %{_libdir}/libevent_core.so
115 %attr(755,root,root) %{_libdir}/libevent_extra.so
116 %attr(755,root,root) %{_libdir}/libevent_openssl.so
117 %attr(755,root,root) %{_libdir}/libevent_pthreads.so
118 %{_libdir}/libevent.la
119 %{_libdir}/libevent_core.la
120 %{_libdir}/libevent_extra.la
121 %{_libdir}/libevent_openssl.la
122 %{_libdir}/libevent_pthreads.la
123 %dir %{_includedir}/event2
124 %{_includedir}/event2/*.h
125 %{_includedir}/evdns.h
126 %{_includedir}/event*.h
127 %{_includedir}/evhttp.h
128 %{_includedir}/evrpc.h
129 %{_includedir}/evutil.h
130 #%%{_mandir}/man3/evdns.3*
131 #%%{_mandir}/man3/event.3*
132 %{_pkgconfigdir}/libevent.pc
133 %{_pkgconfigdir}/libevent_openssl.pc
134 %{_pkgconfigdir}/libevent_pthreads.pc
135
136 %if %{with static_libs}
137 %files static
138 %defattr(644,root,root,755)
139 %{_libdir}/libevent.a
140 %{_libdir}/libevent_core.a
141 %{_libdir}/libevent_extra.a
142 %{_libdir}/libevent_openssl.a
143 %{_libdir}/libevent_pthreads.a
144 %endif
This page took 0.109512 seconds and 4 git commands to generate.