]> git.pld-linux.org Git - packages/libevent.git/blob - libevent.spec
- release 2
[packages/libevent.git] / libevent.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        libevent - an event notification library
6 Summary(pl.UTF-8):      libevent - biblioteka powiadamiająca o zdarzeniach
7 Name:           libevent
8 Version:        1.4.7
9 Release:        2
10 Epoch:          0
11 License:        BSD
12 Group:          Libraries
13 #Source0Download: http://www.monkey.org/~provos/libevent/
14 Source0:        http://www.monkey.org/~provos/%{name}-%{version}-stable.tar.gz
15 # Source0-md5:  f247d0671ea4fc95b191daf79cb762a0
16 URL:            http://www.monkey.org/~provos/libevent/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  libtool
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The libevent API provides a mechanism to execute a callback function
24 when a specific event occurs on a file descriptor or after a timeout
25 has been reached. It is meant to replace the asynchronous event loop
26 found in event-driven network servers.
27
28 %description -l pl.UTF-8
29 API libevent dostarcza mechanizm do wykonywania funkcji callback,
30 kiedy nastąpiło określone zdarzenie w deskryptorze pliku lub po
31 określonym czasie. Ma to na celu zastąpienie asynchronicznych pętli w
32 sterowanych zdarzeniami usługach sieciowych.
33
34 %package devel
35 Summary:        Header files for libevent library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libevent
37 Group:          Development/Libraries
38 Requires:       %{name} = %{epoch}:%{version}-%{release}
39
40 %description devel
41 Header files for libevent library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki libevent.
45
46 %package static
47 Summary:        Static libevent library
48 Summary(pl.UTF-8):      Statyczna biblioteka libevent
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
51
52 %description static
53 Static libevent library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka libevent.
57
58 %prep
59 %setup -q -n %{name}-%{version}-stable
60
61 %build
62 %{__libtoolize}
63 %{__aclocal}
64 %{__autoconf}
65 %{__autoheader}
66 %{__automake}
67 %configure \
68         %{!?with_static_libs:--disable-static}
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %attr(755,root,root) %{_libdir}/libevent-1.4.so.*.*.*
86 %attr(755,root,root) %ghost %{_libdir}/libevent-1.4.so.2
87 %attr(755,root,root) %{_libdir}/libevent_core-1.4.so.*.*.*
88 %attr(755,root,root) %ghost %{_libdir}/libevent_core-1.4.so.2
89 %attr(755,root,root) %{_libdir}/libevent_extra-1.4.so.*.*.*
90 %attr(755,root,root) %ghost %{_libdir}/libevent_extra-1.4.so.2
91
92 %files devel
93 %defattr(644,root,root,755)
94 # R: python
95 #%attr(755,root,root) %{_bindir}/event_rpcgen.py
96 %attr(755,root,root) %{_libdir}/libevent.so
97 %attr(755,root,root) %{_libdir}/libevent_core.so
98 %attr(755,root,root) %{_libdir}/libevent_extra.so
99 %{_libdir}/libevent.la
100 %{_libdir}/libevent_core.la
101 %{_libdir}/libevent_extra.la
102 %{_includedir}/evdns.h
103 %{_includedir}/event*.h
104 %{_includedir}/evhttp.h
105 %{_includedir}/evrpc.h
106 %{_includedir}/evutil.h
107 %{_mandir}/man3/evdns.3*
108 %{_mandir}/man3/event.3*
109
110 %if %{with static_libs}
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libevent.a
114 %{_libdir}/libevent_core.a
115 %{_libdir}/libevent_extra.a
116 %endif
This page took 0.063477 seconds and 4 git commands to generate.