]> git.pld-linux.org Git - packages/libevent.git/blob - libevent.spec
- package docs, including LICENSE
[packages/libevent.git] / libevent.spec
1 # TODO
2 # - %attr(755,root,root) %{_bindir}/event_rpcgen.py
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # don't build static library
6 #
7 Summary:        libevent - an event notification library
8 Summary(pl.UTF-8):      libevent - biblioteka powiadamiająca o zdarzeniach
9 Name:           libevent
10 Version:        2.0.10
11 Release:        2
12 License:        BSD
13 Group:          Libraries
14 Source0:        http://www.monkey.org/~provos/%{name}-%{version}-stable.tar.gz
15 # Source0-md5:  a37401d26cbbf28185211d582741a3d4
16 Patch0:         %{name}-fpm.patch
17 Patch1:         %{name}-link.patch
18 URL:            http://www.monkey.org/~provos/libevent/
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRequires:  openssl-devel
23 BuildRequires:  pkgconfig
24 BuildRequires:  zlib-devel
25 Obsoletes:      libevent-dietlibc
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The libevent API provides a mechanism to execute a callback function
30 when a specific event occurs on a file descriptor or after a timeout
31 has been reached. It is meant to replace the asynchronous event loop
32 found in event-driven network servers.
33
34 %description -l pl.UTF-8
35 API libevent dostarcza mechanizm do wykonywania funkcji callback,
36 kiedy nastąpiło określone zdarzenie w deskryptorze pliku lub po
37 określonym czasie. Ma to na celu zastąpienie asynchronicznych pętli w
38 sterowanych zdarzeniami usługach sieciowych.
39
40 %package devel
41 Summary:        Header files for libevent library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libevent
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       openssl-devel
46
47 %description devel
48 Header files for libevent library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki libevent.
52
53 %package static
54 Summary:        Static libevent library
55 Summary(pl.UTF-8):      Statyczna biblioteka libevent
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static libevent library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka libevent.
64
65 %prep
66 %setup -q -n %{name}-%{version}-stable
67 %patch0 -p1
68 %patch1 -p1
69
70 %build
71 %{__libtoolize}
72 %{__aclocal} -I m4
73 %{__autoconf}
74 %{__automake}
75 %configure \
76         %{!?with_static_libs:--disable-static}
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc ChangeLog LICENSE README
94 %attr(755,root,root) %{_libdir}/libevent-2.0.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libevent-2.0.so.5
96 %attr(755,root,root) %{_libdir}/libevent_core-2.0.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libevent_core-2.0.so.5
98 %attr(755,root,root) %{_libdir}/libevent_extra-2.0.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/libevent_extra-2.0.so.5
100 %attr(755,root,root) %{_libdir}/libevent_openssl-2.0.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libevent_openssl-2.0.so.5
102 %attr(755,root,root) %{_libdir}/libevent_pthreads-2.0.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libevent_pthreads-2.0.so.5
104
105 %files devel
106 %defattr(644,root,root,755)
107 # R: python
108 %attr(755,root,root) %{_bindir}/event_rpcgen.py
109 %attr(755,root,root) %{_libdir}/libevent.so
110 %attr(755,root,root) %{_libdir}/libevent_core.so
111 %attr(755,root,root) %{_libdir}/libevent_extra.so
112 %attr(755,root,root) %{_libdir}/libevent_openssl.so
113 %attr(755,root,root) %{_libdir}/libevent_pthreads.so
114 %{_libdir}/libevent.la
115 %{_libdir}/libevent_core.la
116 %{_libdir}/libevent_extra.la
117 %{_libdir}/libevent_openssl.la
118 %{_libdir}/libevent_pthreads.la
119 %dir %{_includedir}/event2
120 %{_includedir}/event2/*.h
121 %{_includedir}/evdns.h
122 %{_includedir}/event*.h
123 %{_includedir}/evhttp.h
124 %{_includedir}/evrpc.h
125 %{_includedir}/evutil.h
126 #%%{_mandir}/man3/evdns.3*
127 #%%{_mandir}/man3/event.3*
128 %{_pkgconfigdir}/libevent.pc
129 %{_pkgconfigdir}/libevent_openssl.pc
130 %{_pkgconfigdir}/libevent_pthreads.pc
131
132 %if %{with static_libs}
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libevent.a
136 %{_libdir}/libevent_core.a
137 %{_libdir}/libevent_extra.a
138 %{_libdir}/libevent_openssl.a
139 %{_libdir}/libevent_pthreads.a
140 %endif
This page took 0.039824 seconds and 4 git commands to generate.