]> git.pld-linux.org Git - packages/libdbi-drivers.git/blob - libdbi-drivers.spec
- updated to 0.7.1
[packages/libdbi-drivers.git] / libdbi-drivers.spec
1 #
2 # Conditional build:
3 %bcond_without mysql  # don't build mysql driver
4 %bcond_without pgsql  # don't build postgresql driver
5 %bcond_without sqlite # don't build sqlite driver
6 #
7 %define dbiver  0.7.2
8 Summary:        Database Independent Abstraction Layer for C
9 Summary(pl):    Warstwa DBI dla C
10 Name:           libdbi-drivers
11 Version:        0.7.1
12 Release:        1
13 License:        LGPL
14 Group:          Libraries
15 Source0:        http://dl.sourceforge.net/libdbi-drivers/libdbi-drivers-%{version}.tar.gz
16 # Source0-md5:  f11020119ceb7a6dee3969cb0589d4bc
17 Patch0:         %{name}-opt.patch
18 URL:            http://libdbi-drivers.sourceforge.net/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  libtool
22 BuildRequires:  libdbi-devel >= %{dbiver}
23 %{?with_mysql:BuildRequires:    mysql-devel}
24 %{?with_pgsql:BuildRequires:    postgresql-devel}
25 %{?with_sqlite:BuildRequires:   sqlite-devel}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 libdbi implements a database-independent abstraction layer in C,
30 similar to the DBI/DBD layer in Perl. Writing one generic set of code,
31 programmers can leverage the power of multiple databases and multiple
32 simultaneous database connections by using this framework.
33
34 %description -l pl
35 libdbi jest implementacj± w C warstwy abstrakcyjnej niezale¿nej od
36 bazy danych, podobnej do warstwy DBI/DBD w Perlu. U¿ywaj±c tego
37 ¶rodowiska programista mo¿e za pomoc± jednego, wspólnego kodu
38 odwo³ywaæ siê do wielu ró¿nych baz danych, tak¿e jednocze¶nie.
39
40 %package mysql
41 Summary:        MySQL plugin for libdbi
42 Summary(pl):    Wtyczka MySQL dla libdbi
43 Group:          Libraries
44 Requires:       libdbi >= %{dbiver}
45 Provides:       libdbi-dbd = %{version}-%{release}
46 Obsoletes:      libdbi-dbd-mysql
47
48 %description mysql
49 This plugin provides connectivity to MySQL database servers through
50 the libdbi database independent abstraction layer. Switching a
51 program's plugin does not require recompilation or rewriting source
52 code.
53
54 %description mysql -l pl
55 Ta wtyczka daje mo¿liwo¶æ ³±czenia siê z serwerami MySQL poprzez
56 bibliotekê libdbi. Zmiana u¿ywanej wtyczki nie wymaga rekompilacji ani
57 zmiany ¼róde³ programu.
58
59 %package pgsql
60 Summary:        PostgreSQL plugin for libdbi
61 Summary(pl):    Wtyczka PostgreSQL dla libdbi
62 Group:          Libraries
63 Requires:       libdbi >= %{dbiver}
64 Provides:       libdbi-dbd = %{version}-%{release}
65 Obsoletes:      libdbi-dbd-pgsql
66
67 %description pgsql
68 This plugin provides connectivity to PostgreSQL database servers
69 through the libdbi database independent abstraction layer. Switching a
70 program's plugin does not require recompilation or rewriting source
71 code.
72
73 %description pgsql -l pl
74 Ta wtyczka daje mo¿liwo¶æ ³±czenia siê z serwerami PostgreSQL poprzez
75 bibliotekê libdbi. Zmiana u¿ywanej wtyczki nie wymaga rekompilacji ani
76 zmiany ¼róde³ programu.
77
78 %package sqlite
79 Summary:        SQLite plugin for libdbi
80 Summary(pl):    Wtyczka SQLite dla libdbi
81 Group:          Libraries
82 Requires:       libdbi >= %{dbiver}
83 Provides:       libdbi-dbd = %{version}-%{release}
84
85 %description sqlite
86 This plugin provides connectivity to SQLite engine
87 through the libdbi database independent abstraction layer. Switching a
88 program's plugin does not require recompilation or rewriting source
89 code.
90
91 %description sqlite -l pl
92 Ta wtyczka daje mo¿liwo¶æ ³±czenia siê z silnikiem SQLite poprzez
93 bibliotekê libdbi. Zmiana u¿ywanej wtyczki nie wymaga rekompilacji ani
94 zmiany ¼róde³ programu.
95
96 %prep
97 %setup -q
98 %patch0 -p1
99
100 %build
101 %{__libtoolize}
102 %{__aclocal}
103 %{__automake}
104 %{__autoconf}
105 %configure \
106         --disable-static \
107         --with-dbi-incdir=%{_includedir} \
108         %{?with_sqlite:--with-sqlite} \
109         %{?with_mysql:--with-mysql} \
110         %{?with_pgsql:--with-pgsql}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_libdir}/dbd
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 rm -f $RPM_BUILD_ROOT%{_libdir}/dbd/lib*.la
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %if %{with mysql}
126 %files mysql
127 %defattr(644,root,root,755)
128 %doc drivers/mysql/*.pdf drivers/mysql/dbd_mysql
129 %attr(755,root,root) %{_libdir}/dbd/libmysql.so
130 %endif
131
132 %if %{with pgsql}
133 %files pgsql
134 %defattr(644,root,root,755)
135 %doc drivers/pgsql/*.pdf drivers/pgsql/dbd_pgsql
136 %attr(755,root,root) %{_libdir}/dbd/libpgsql.so
137 %endif
138
139 %if %{with sqlite}
140 %files sqlite
141 %defattr(644,root,root,755)
142 %doc drivers/sqlite/*.pdf drivers/sqlite/dbd_sqlite
143 %{_libdir}/dbd/libsqlite.so
144 %endif
This page took 0.184607 seconds and 4 git commands to generate.