]> git.pld-linux.org Git - packages/libbluray.git/blob - libbluray.spec
- new
[packages/libbluray.git] / libbluray.spec
1 #
2 # TODO:
3 #  Build with bdjava (0.2.1 tarball doesn't have all necessary files)
4 #
5 # Conditional build:
6 %bcond_without  static_libs     # don't build static libraries
7 #
8 Summary:        Library to access Blu-Ray disks for video playback
9 Name:           libbluray
10 Version:        0.2.1
11 Release:        1
12 License:        LGPL v2+
13 Group:          Libraries
14 Source0:        ftp://ftp.videolan.org/pub/videolan/libbluray/0.2.1/%{name}-%{version}.tar.bz2
15 # Source0-md5:  d4cfcf3f110e9d2afe01d29feb8c842b
16 URL:            http://www.videolan.org/developers/libbluray.html
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  doxygen
20 BuildRequires:  libtool
21 BuildRequires:  libxml2-devel >= 1:2.6.0
22 BuildRequires:  pkgconfig
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This package is aiming to provide a full portable free open source
27 bluray library, which can be plugged into popular media players to
28 allow full bluray navigation and playback on Linux. It will eventually
29 be compatible with all current titles, and will be easily portable and
30 embeddable in standard players such as mplayer and vlc.
31
32 %package devel
33 Summary:        Header files for libbluray library
34 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libbluray
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37
38 %description devel
39 Header files for libbluray library.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe biblioteki libbluray.
43
44 %package static
45 Summary:        Static libbluray library
46 Summary(pl.UTF-8):      Statyczna biblioteka libbluray
47 Group:          Development/Libraries
48 Requires:       %{name}-devel = %{version}-%{release}
49
50 %description static
51 Static libbluray library.
52
53 %description static -l pl.UTF-8
54 Statyczna biblioteka libbluray.
55
56 %prep
57 %setup -q
58
59 %build
60 %{__libtoolize}
61 %{__aclocal} -I m4
62 %{__autoconf}
63 %{__autoheader}
64 %{__automake}
65 %configure \
66         %{__enable_disable static_libs static}
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc README.txt
86 %attr(755,root,root) %{_libdir}/libbluray.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libbluray.so.1
88
89 %files devel
90 %defattr(644,root,root,755)
91 %attr(755,root,root) %{_libdir}/libbluray.so
92 %{_includedir}/libbluray
93 %{_pkgconfigdir}/libbluray.pc
94
95 %if %{with static_libs}
96 %files static
97 %defattr(644,root,root,755)
98 %{_libdir}/libbluray.a
99 %endif
This page took 0.314966 seconds and 4 git commands to generate.