]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- added pl.po-update patch (one fuzzy entry)
[packages/lftp.git] / lftp.spec
1 #
2 # Conditional build:
3 # _without_ssl - do not use SSL
4 #
5 Summary:        Sophisticated command line ftp/http client
6 Summary(ko):    ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â ftp/http Å¬¶óÀ̾ðÆ®
7 Summary(pl):    Zaawansowany klient ftp/http
8 Summary(pt_BR): Sofisticado programa de transferência de arquivos (cliente ftp/http)
9 Summary(zh_CN): lftp ¿Í»§¶Ë³ÌÐò
10 Name:           lftp
11 Version:        2.6.8
12 Release:        1
13 License:        GPL
14 Group:          Applications/Networking
15 Source0:        ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/%{name}-%{version}.tar.bz2
16 # Source0-md5:  7ca299efb0c0d8bd73baa2fb75308c9e
17 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
18 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
19 Source2:        %{name}.desktop
20 Patch0:         %{name}-amfix.patch
21 Patch1:         %{name}-home_etc.patch
22 Patch2:         %{name}-no_pkgverlibdir.patch
23 Patch3:         %{name}-pl.po-update.patch
24 Icon:           ftp.gif
25 URL:            http://lftp.yar.ru/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  gettext-devel
29 BuildRequires:  libstdc++-devel
30 BuildRequires:  libtool >= 1:1.4.2-9
31 BuildRequires:  ncurses-devel >= 5.2
32 %{!?_without_ssl:BuildRequires: openssl-devel >= 0.9.7c}
33 BuildRequires:  readline-devel >= 4.2
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
37 %if %{_gcc_ver} == 2
38 %define         __cxx           "%{__cc}"
39 %endif
40
41 %description
42 LFTP is a shell-like command line ftp/http client. The main two
43 advantages over other ftp clients are reliability and ability to
44 perform tasks in background. It will reconnect and reget the file
45 being transferred if the connection broke. You can start a transfer in
46 background and continue browsing on the ftp site. It does this all in
47 one process. When you have started background jobs and feel you are
48 done, you can just exit lftp and it automatically moves to nohup mode
49 and completes the transfers. It has also such nice features as reput
50 and mirror.
51
52 %description -l pl
53 Lftp jest zaawansowanym klientem ftp/http. Potrafi automatycznie
54 po³±czyæ siê z serwerem ftp po zerwanym po³±czeniu i dokoñczyæ
55 ¶ci±ganie archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym
56 po³±czenia po tym jak siê wylogujesz. Program ten honoruje komendy
57 pow³oki podczas sesji, np. `ls -al | less` itp. Doskonale siê spisuje
58 jako aplikacja do mirrorowania serwerów FTP.
59
60 %description -l pt_BR
61 O lftp é um programa de transferência de arquivos por linha de
62 comando. Ele suporta os protocolos ftp/http. Suporta: proxy ftp, proxy
63 http, ftp sobre http, opie/skey, transferências fxp, repetição de
64 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
65 o arquivo FEATURES para uma lista mais detalhada.
66
67 %prep
68 %setup -q
69 %patch0 -p1
70 %patch1 -p1
71 %patch2 -p1
72 %patch3 -p1
73
74 %build
75 %{__libtoolize}
76 %{__gettextize}
77 %{__aclocal} -I m4
78 %{__autoconf}
79 %{__automake}
80 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
81 %configure \
82         --with-modules \
83         --with%{?_without_ssl:out}-ssl
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_applnkdir}/Network/FTP}
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
94 install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
95 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Network/FTP
96
97 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
98
99 %find_lang %{name}
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files -f %{name}.lang
105 %defattr(644,root,root,755)
106 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
107 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lftp.conf
108 %attr(755,root,root) %{_bindir}/*
109 %dir %{_libdir}/lftp
110 %attr(755,root,root) %{_libdir}/lftp/cmd-mirror.so
111 %attr(755,root,root) %{_libdir}/lftp/cmd-sleep.so
112 %attr(755,root,root) %{_libdir}/lftp/libnetwork.so
113 %attr(755,root,root) %{_libdir}/lftp/proto-file.so
114 %attr(755,root,root) %{_libdir}/lftp/proto-fish.so
115 %attr(755,root,root) %{_libdir}/lftp/proto-ftp.so
116 %attr(755,root,root) %{_libdir}/lftp/proto-http.so
117 %attr(755,root,root) %{_datadir}/lftp
118 %{_mandir}/man1/*
119 %lang(pl) %{_mandir}/pl/man1/*
120 %{_applnkdir}/Network/FTP/lftp.desktop
121 %{_pixmapsdir}/lftp.png
This page took 0.043208 seconds and 4 git commands to generate.