]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- rel 2; rebuild with fixed pl.po
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7 %bcond_without  dante   # Dante-based SOCKS support
8 # broken currently https://www.dnssec-tools.org/trac/ticket/173
9 %bcond_with     dnssec  # DNSSEC local validation
10 #
11 %if %{with ssl}
12 %define with_openssl 1
13 %endif
14
15 %if %{with gnutls} && %{with ssl}
16 %undefine with_openssl
17 %endif
18
19 Summary:        Sophisticated command line FTP/HTTP client
20 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
21 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
22 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
23 Summary(zh_CN.UTF-8):   lftp 客户端程序
24 Name:           lftp
25 Version:        4.4.6
26 Release:        2
27 License:        GPL v3+
28 Group:          Applications/Networking
29 Source0:        ftp://ftp.yar.ru/pub/source/lftp/%{name}-%{version}.tar.xz
30 # Source0-md5:  4f5c1a35acf0a0ee3b2e47dabd440a0e
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
32 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
33 Source2:        %{name}.desktop
34 Source3:        %{name}-icon.png
35 Patch0:         %{name}-makefile.patch
36 Patch1:         %{name}-m4.patch
37 Patch2:         aliases.patch
38 # maintained by me, sent upstream from time to time  --qboosh
39 Patch3:         %{name}-pl.po-update.patch
40 Patch4:         lftp-4.3.8-gets.patch
41 Patch5:         %{name}-am.patch
42 URL:            http://lftp.yar.ru/
43 BuildRequires:  autoconf >= 2.60
44 BuildRequires:  automake
45 %{?with_dante:BuildRequires:    dante-devel}
46 %{?with_dnssec:BuildRequires:   dnssec-tools-devel}
47 BuildRequires:  expat-devel
48 BuildRequires:  gettext-devel >= 0.14.2
49 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
50 BuildRequires:  libstdc++-devel
51 BuildRequires:  libtool >= 1:1.4.2-9
52 BuildRequires:  ncurses-devel >= 5.2
53 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
54 BuildRequires:  pkgconfig
55 BuildRequires:  readline-devel >= 4.2
56 BuildRequires:  tar >= 1:1.22
57 BuildRequires:  xz
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
61 %if %{_gcc_ver} == 2
62 %define         __cxx           "%{__cc}"
63 %endif
64
65 %description
66 LFTP is a shell-like command line FTP/HTTP client. The main two
67 advantages over other FTP clients are reliability and ability to
68 perform tasks in background. It will reconnect and reget the file
69 being transferred if the connection broke. You can start a transfer in
70 background and continue browsing on the FTP site. It does this all in
71 one process. When you have started background jobs and feel you are
72 done, you can just exit lftp and it automatically moves to nohup mode
73 and completes the transfers. It has also such nice features as reput
74 and mirror.
75
76 %description -l pl.UTF-8
77 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
78 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
79 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
80 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
81 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
82 jako aplikacja do mirrorowania serwerów FTP.
83
84 %description -l pt_BR.UTF-8
85 O lftp é um programa de transferência de arquivos por linha de
86 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
87 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
88 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
89 o arquivo FEATURES para uma lista mais detalhada.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96 # file incorrectly recoded to UTF-8 (input set as iso-8859-1 instead of iso-8859-2)
97 iconv -f utf-8 -t iso-8859-1 po/pl.po > po/pl.po.tmp
98 mv po/pl.po.tmp po/pl.po
99 %patch3 -p1
100 %patch4 -p1
101 %patch5 -p1
102
103 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
104
105 %build
106 %{__libtoolize}
107 %{__gettextize}
108 %{__aclocal} -I m4
109 %{__autoconf}
110 %{__automake}
111 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
112 %configure \
113         --without-included-regex \
114         --with-dnssec-local-validation%{!?with_dnssec:=no} \
115         --with-modules \
116         --with-socksdante%{!?with_dante:=no} \
117         --with%{!?with_openssl:out}-openssl \
118         --with%{!?with_gnutls:out}-gnutls
119
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
129 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
130 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
131
132 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
133 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
134 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
135
136 %find_lang %{name}
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files -f %{name}.lang
145 %defattr(644,root,root,755)
146 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
147 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
148 %attr(755,root,root) %{_bindir}/lftp
149 %attr(755,root,root) %{_bindir}/lftpget
150 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
151 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
152 %dir %{_libdir}/lftp
153 %attr(755,root,root) %{_libdir}/lftp/*.so
154 %attr(755,root,root) %{_datadir}/lftp
155 %{_mandir}/man1/lftp.1*
156 %{_mandir}/man1/lftpget.1*
157 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
158 %{_mandir}/man5/lftp.conf.5*
159 %{_desktopdir}/lftp.desktop
160 %{_pixmapsdir}/lftp.png
This page took 0.037332 seconds and 4 git commands to generate.