]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- 4.0.7
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
18 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
19 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN.UTF-8):   lftp 客户端程序
21 Name:           lftp
22 Version:        4.0.7
23 Release:        1
24 License:        GPL v3+
25 Group:          Applications/Networking
26 Source0:        ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.lzma
27 # Source0-md5:  cf8211552682c9edba5cf4172943a5f1
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Source3:        %{name}-icon.png
32 Patch0:         %{name}-home_etc.patch
33 Patch1:         %{name}-makefile.patch
34 # ALWAYS send updated patch to lftp mailing lists
35 Patch2:         %{name}-pl.po-update.patch
36 Patch3:         %{name}-m4.patch
37 URL:            http://lftp.yar.ru/
38 BuildRequires:  autoconf >= 2.60
39 BuildRequires:  automake
40 BuildRequires:  gettext-devel >= 0.14.2
41 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
42 BuildRequires:  libstdc++-devel
43 BuildRequires:  libtool >= 1:1.4.2-9
44 BuildRequires:  ncurses-devel >= 5.2
45 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
46 BuildRequires:  readline-devel >= 4.2
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
50 %if %{_gcc_ver} == 2
51 %define         __cxx           "%{__cc}"
52 %endif
53
54 %description
55 LFTP is a shell-like command line FTP/HTTP client. The main two
56 advantages over other FTP clients are reliability and ability to
57 perform tasks in background. It will reconnect and reget the file
58 being transferred if the connection broke. You can start a transfer in
59 background and continue browsing on the FTP site. It does this all in
60 one process. When you have started background jobs and feel you are
61 done, you can just exit lftp and it automatically moves to nohup mode
62 and completes the transfers. It has also such nice features as reput
63 and mirror.
64
65 %description -l pl.UTF-8
66 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
67 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
68 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
69 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
70 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
71 jako aplikacja do mirrorowania serwerów FTP.
72
73 %description -l pt_BR.UTF-8
74 O lftp é um programa de transferência de arquivos por linha de
75 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
76 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
77 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
78 o arquivo FEATURES para uma lista mais detalhada.
79
80 %prep
81 %setup -q
82 #%%patch0 -p1
83 %patch1 -p1
84 #%patch2 -p1
85 %patch3 -p1
86
87 rm -f po/stamp-po
88
89 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
90
91 %build
92 %{__libtoolize}
93 %{__gettextize}
94 %{__aclocal} -I m4
95 %{__autoconf}
96 %{__automake}
97 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
98 %configure \
99         --with-modules \
100         --with%{!?with_openssl:out}-openssl \
101         --with%{!?with_gnutls:out}-gnutls
102
103 %{__make}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT
111
112 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
113 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
114 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
115
116 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
117 rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
118 rm -f $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
119
120 %find_lang %{name}
121
122 %clean
123 rm -rf $RPM_BUILD_ROOT
124
125 %post   -p /sbin/ldconfig
126 %postun -p /sbin/ldconfig
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
131 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
132 %attr(755,root,root) %{_bindir}/lftp
133 %attr(755,root,root) %{_bindir}/lftpget
134 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
136 %dir %{_libdir}/lftp
137 %attr(755,root,root) %{_libdir}/lftp/*.so
138 %attr(755,root,root) %{_datadir}/lftp
139 %{_mandir}/man1/lftp.1*
140 %{_mandir}/man1/lftpget.1*
141 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
142 %{_desktopdir}/lftp.desktop
143 %{_pixmapsdir}/lftp.png
This page took 0.100807 seconds and 4 git commands to generate.