]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- updated pl.po-update patch is back
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7 %bcond_without  dante   # Dante-based SOCKS support
8 # broken currently https://www.dnssec-tools.org/trac/ticket/173
9 %bcond_with     dnssec  # DNSSEC local validation
10 #
11 %if %{with ssl}
12 %define with_openssl 1
13 %endif
14
15 %if %{with gnutls} && %{with ssl}
16 %undefine with_openssl
17 %endif
18
19 Summary:        Sophisticated command line FTP/HTTP client
20 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
21 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
22 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
23 Summary(zh_CN.UTF-8):   lftp 客户端程序
24 Name:           lftp
25 Version:        4.4.4
26 Release:        1
27 License:        GPL v3+
28 Group:          Applications/Networking
29 Source0:        ftp://ftp.yar.ru/pub/source/lftp/%{name}-%{version}.tar.xz
30 # Source0-md5:  a5742ec5d6112faacde4cd7d83cf0629
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
32 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
33 Source2:        %{name}.desktop
34 Source3:        %{name}-icon.png
35 Patch0:         %{name}-makefile.patch
36 Patch1:         %{name}-m4.patch
37 Patch2:         aliases.patch
38 # maintained by me, sent upstream from time to time  --qboosh
39 Patch3:         %{name}-pl.po-update.patch
40 Patch4:         lftp-4.3.8-gets.patch
41 Patch5:         %{name}-am.patch
42 URL:            http://lftp.yar.ru/
43 BuildRequires:  autoconf >= 2.60
44 BuildRequires:  automake
45 %{?with_dante:BuildRequires:    dante-devel}
46 %{?with_dnssec:BuildRequires:   dnssec-tools-devel}
47 BuildRequires:  expat-devel
48 BuildRequires:  gettext-devel >= 0.14.2
49 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
50 BuildRequires:  libstdc++-devel
51 BuildRequires:  libtool >= 1:1.4.2-9
52 BuildRequires:  ncurses-devel >= 5.2
53 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
54 BuildRequires:  pkgconfig
55 BuildRequires:  readline-devel >= 4.2
56 BuildRequires:  tar >= 1:1.22
57 BuildRequires:  xz
58 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
59
60 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
61 %if %{_gcc_ver} == 2
62 %define         __cxx           "%{__cc}"
63 %endif
64
65 %description
66 LFTP is a shell-like command line FTP/HTTP client. The main two
67 advantages over other FTP clients are reliability and ability to
68 perform tasks in background. It will reconnect and reget the file
69 being transferred if the connection broke. You can start a transfer in
70 background and continue browsing on the FTP site. It does this all in
71 one process. When you have started background jobs and feel you are
72 done, you can just exit lftp and it automatically moves to nohup mode
73 and completes the transfers. It has also such nice features as reput
74 and mirror.
75
76 %description -l pl.UTF-8
77 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
78 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
79 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
80 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
81 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
82 jako aplikacja do mirrorowania serwerów FTP.
83
84 %description -l pt_BR.UTF-8
85 O lftp é um programa de transferência de arquivos por linha de
86 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
87 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
88 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
89 o arquivo FEATURES para uma lista mais detalhada.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96 %patch3 -p1
97 %patch4 -p1
98 %patch5 -p1
99
100 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
101
102 %build
103 %{__libtoolize}
104 %{__gettextize}
105 %{__aclocal} -I m4
106 %{__autoconf}
107 %{__automake}
108 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
109 %configure \
110         --without-included-regex \
111         --with-dnssec-local-validation%{!?with_dnssec:=no} \
112         --with-modules \
113         --with-socksdante%{!?with_dante:=no} \
114         --with%{!?with_openssl:out}-openssl \
115         --with%{!?with_gnutls:out}-gnutls
116
117 %{__make}
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
122 %{__make} install \
123         DESTDIR=$RPM_BUILD_ROOT
124
125 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
126 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
127 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
128
129 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
130 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
131 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
132
133 %find_lang %{name}
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %post   -p /sbin/ldconfig
139 %postun -p /sbin/ldconfig
140
141 %files -f %{name}.lang
142 %defattr(644,root,root,755)
143 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
144 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
145 %attr(755,root,root) %{_bindir}/lftp
146 %attr(755,root,root) %{_bindir}/lftpget
147 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
149 %dir %{_libdir}/lftp
150 %attr(755,root,root) %{_libdir}/lftp/*.so
151 %attr(755,root,root) %{_datadir}/lftp
152 %{_mandir}/man1/lftp.1*
153 %{_mandir}/man1/lftpget.1*
154 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
155 %{_mandir}/man5/lftp.conf.5*
156 %{_desktopdir}/lftp.desktop
157 %{_pixmapsdir}/lftp.png
This page took 0.080545 seconds and 4 git commands to generate.