]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- Up to 4.3.7
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
18 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
19 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN.UTF-8):   lftp 客户端程序
21 Name:           lftp
22 Version:        4.3.7
23 Release:        1
24 License:        GPL v3+
25 Group:          Applications/Networking
26 Source0:        http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
27 # Source0-md5:  df7c928644866712ad8fc1677f42fc30
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Source3:        %{name}-icon.png
32 Patch0:         %{name}-makefile.patch
33 Patch1:         %{name}-m4.patch
34 Patch2:         aliases.patch
35 # maintained by me, sent upstream from time to time  --qboosh
36 Patch3:         %{name}-pl.po-update.patch
37 URL:            http://lftp.yar.ru/
38 BuildRequires:  autoconf >= 2.60
39 BuildRequires:  automake
40 BuildRequires:  expat-devel
41 BuildRequires:  gettext-devel >= 0.14.2
42 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
43 BuildRequires:  libstdc++-devel
44 BuildRequires:  libtool >= 1:1.4.2-9
45 BuildRequires:  ncurses-devel >= 5.2
46 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
47 BuildRequires:  pkgconfig
48 BuildRequires:  readline-devel >= 4.2
49 BuildRequires:  tar >= 1:1.22
50 BuildRequires:  xz
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
54 %if %{_gcc_ver} == 2
55 %define         __cxx           "%{__cc}"
56 %endif
57
58 %description
59 LFTP is a shell-like command line FTP/HTTP client. The main two
60 advantages over other FTP clients are reliability and ability to
61 perform tasks in background. It will reconnect and reget the file
62 being transferred if the connection broke. You can start a transfer in
63 background and continue browsing on the FTP site. It does this all in
64 one process. When you have started background jobs and feel you are
65 done, you can just exit lftp and it automatically moves to nohup mode
66 and completes the transfers. It has also such nice features as reput
67 and mirror.
68
69 %description -l pl.UTF-8
70 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
71 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
72 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
73 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
74 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
75 jako aplikacja do mirrorowania serwerów FTP.
76
77 %description -l pt_BR.UTF-8
78 O lftp é um programa de transferência de arquivos por linha de
79 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
80 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
81 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
82 o arquivo FEATURES para uma lista mais detalhada.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89 %patch3 -p1
90
91 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
92
93 %build
94 %{__libtoolize}
95 %{__gettextize}
96 %{__aclocal} -I m4
97 %{__autoconf}
98 %{__automake}
99 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
100 %configure \
101         --with-modules \
102         --with%{!?with_openssl:out}-openssl \
103         --with%{!?with_gnutls:out}-gnutls
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
114 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
115 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
116
117 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
118 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
119 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
120
121 %find_lang %{name}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post   -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
132 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
133 %attr(755,root,root) %{_bindir}/lftp
134 %attr(755,root,root) %{_bindir}/lftpget
135 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
136 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
137 %dir %{_libdir}/lftp
138 %attr(755,root,root) %{_libdir}/lftp/*.so
139 %attr(755,root,root) %{_datadir}/lftp
140 %{_mandir}/man1/lftp.1*
141 %{_mandir}/man1/lftpget.1*
142 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
143 %{_mandir}/man5/lftp.conf.5*
144 %{_desktopdir}/lftp.desktop
145 %{_pixmapsdir}/lftp.png
This page took 0.039704 seconds and 4 git commands to generate.