]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- rel 5; more git fixes
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7 %bcond_without  dante   # Dante-based SOCKS support
8 # broken currently https://www.dnssec-tools.org/trac/ticket/173
9 %bcond_with     dnssec  # DNSSEC local validation
10 #
11 %if %{with ssl}
12 %define with_openssl 1
13 %endif
14
15 %if %{with gnutls} && %{with ssl}
16 %undefine with_openssl
17 %endif
18
19 Summary:        Sophisticated command line FTP/HTTP client
20 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
21 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
22 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
23 Summary(zh_CN.UTF-8):   lftp 客户端程序
24 Name:           lftp
25 Version:        4.4.6
26 Release:        5
27 License:        GPL v3+
28 Group:          Applications/Networking
29 Source0:        ftp://ftp.yar.ru/pub/source/lftp/%{name}-%{version}.tar.xz
30 # Source0-md5:  4f5c1a35acf0a0ee3b2e47dabd440a0e
31 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
32 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
33 Source2:        %{name}.desktop
34 Source3:        %{name}-icon.png
35 Patch0:         %{name}-makefile.patch
36 Patch1:         %{name}-m4.patch
37 Patch2:         aliases.patch
38 # maintained by me, sent upstream from time to time  --qboosh
39 Patch3:         %{name}-pl.po-update.patch
40 Patch4:         lftp-4.3.8-gets.patch
41 Patch5:         %{name}-am.patch
42 Patch6:         lftp-git.patch
43 URL:            http://lftp.yar.ru/
44 BuildRequires:  autoconf >= 2.60
45 BuildRequires:  automake
46 %{?with_dante:BuildRequires:    dante-devel}
47 %{?with_dnssec:BuildRequires:   dnssec-tools-devel}
48 BuildRequires:  expat-devel
49 BuildRequires:  gettext-devel >= 0.14.2
50 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
51 BuildRequires:  libstdc++-devel
52 BuildRequires:  libtool >= 1:1.4.2-9
53 BuildRequires:  ncurses-devel >= 5.2
54 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
55 BuildRequires:  pkgconfig
56 BuildRequires:  readline-devel >= 4.2
57 BuildRequires:  tar >= 1:1.22
58 BuildRequires:  xz
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
62 %if %{_gcc_ver} == 2
63 %define         __cxx           "%{__cc}"
64 %endif
65
66 %description
67 LFTP is a shell-like command line FTP/HTTP client. The main two
68 advantages over other FTP clients are reliability and ability to
69 perform tasks in background. It will reconnect and reget the file
70 being transferred if the connection broke. You can start a transfer in
71 background and continue browsing on the FTP site. It does this all in
72 one process. When you have started background jobs and feel you are
73 done, you can just exit lftp and it automatically moves to nohup mode
74 and completes the transfers. It has also such nice features as reput
75 and mirror.
76
77 %description -l pl.UTF-8
78 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
79 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
80 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
81 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
82 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
83 jako aplikacja do mirrorowania serwerów FTP.
84
85 %description -l pt_BR.UTF-8
86 O lftp é um programa de transferência de arquivos por linha de
87 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
88 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
89 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
90 o arquivo FEATURES para uma lista mais detalhada.
91
92 %prep
93 %setup -q
94 %patch0 -p1
95 %patch1 -p1
96 %patch2 -p1
97 # file incorrectly recoded to UTF-8 (input set as iso-8859-1 instead of iso-8859-2)
98 iconv -f utf-8 -t iso-8859-1 po/pl.po > po/pl.po.tmp
99 mv po/pl.po.tmp po/pl.po
100 %patch3 -p1
101 %patch4 -p1
102 %patch5 -p1
103 %patch6 -p1
104
105 %{__rm} po/stamp-po
106
107 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
108
109 %build
110 %{__libtoolize}
111 %{__gettextize}
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %{__automake}
115 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
116 %configure \
117         --without-included-regex \
118         --with-dnssec-local-validation%{!?with_dnssec:=no} \
119         --with-modules \
120         --with-socksdante%{!?with_dante:=no} \
121         --with%{!?with_openssl:out}-openssl \
122         --with%{!?with_gnutls:out}-gnutls
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
133 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
134 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
135
136 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
137 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
139
140 %find_lang %{name}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
151 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
152 %attr(755,root,root) %{_bindir}/lftp
153 %attr(755,root,root) %{_bindir}/lftpget
154 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
156 %dir %{_libdir}/lftp
157 %attr(755,root,root) %{_libdir}/lftp/*.so
158 %attr(755,root,root) %{_datadir}/lftp
159 %{_mandir}/man1/lftp.1*
160 %{_mandir}/man1/lftpget.1*
161 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
162 %{_mandir}/man5/lftp.conf.5*
163 %{_desktopdir}/lftp.desktop
164 %{_pixmapsdir}/lftp.png
This page took 0.09468 seconds and 4 git commands to generate.