]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- up to 3.3.3 (TODO: pl.po)
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl             # do not use SSL
6 %bcond_with             gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko):    ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â FTP/HTTP Å¬¶óÀ̾ðÆ®
18 Summary(pl):    Zaawansowany klient FTP/HTTP
19 Summary(pt_BR): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN): lftp ¿Í»§¶Ë³ÌÐò
21 Name:           lftp
22 Version:        3.3.3
23 Release:        1
24 License:        GPL
25 Group:          Applications/Networking
26 Source0:        ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.bz2
27 # Source0-md5:  92f2c10ee4460a9e4654615db0f3f8ab
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Patch0:         %{name}-home_etc.patch
32 Patch1:         %{name}-pl.po-update.patch
33 Icon:           ftp.gif
34 URL:            http://lftp.yar.ru/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  gettext-devel >= 0.14.2
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 1:1.4.2-9
40 BuildRequires:  ncurses-devel >= 5.2
41 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
42 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
43 BuildRequires:  readline-devel >= 4.2
44 BuildRequires:  sed >= 4.0
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
48 %if %{_gcc_ver} == 2
49 %define         __cxx           "%{__cc}"
50 %endif
51
52 %description
53 LFTP is a shell-like command line FTP/HTTP client. The main two
54 advantages over other FTP clients are reliability and ability to
55 perform tasks in background. It will reconnect and reget the file
56 being transferred if the connection broke. You can start a transfer in
57 background and continue browsing on the FTP site. It does this all in
58 one process. When you have started background jobs and feel you are
59 done, you can just exit lftp and it automatically moves to nohup mode
60 and completes the transfers. It has also such nice features as reput
61 and mirror.
62
63 %description -l pl
64 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
65 po³±czyæ siê z serwerem FTP po zerwanym po³±czeniu i dokoñczyæ
66 ¶ci±ganie archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym
67 po³±czenia po tym jak siê wylogujesz. Program ten honoruje komendy
68 pow³oki podczas sesji, np. `ls -al | less` itp. Doskonale siê spisuje
69 jako aplikacja do mirrorowania serwerów FTP.
70
71 %description -l pt_BR
72 O lftp é um programa de transferência de arquivos por linha de
73 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
74 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
75 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
76 o arquivo FEATURES para uma lista mais detalhada.
77
78 %prep
79 %setup -q
80 #%patch0 -p1
81 #%patch1 -p1
82
83 sed -i -e 's#pkgverlibdir.*=.*#pkgverlibdir = $(pkglibdir)#g' src/Makefile*
84 # for gettext >= 0.14.2
85 sed -i -e 's/jm_AC/gl_AC/' m4/human.m4
86
87 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
88
89 %build
90 %{__libtoolize}
91 %{__gettextize}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__automake}
95 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
96 %configure \
97         --with-modules \
98         --with%{!?with_ssl:out}-ssl \
99         --with%{!?with_openssl:out}-openssl \
100         --with%{!?with_gnutls:out}-gnutls
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
112 install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
113 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
114
115 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %files -f %{name}.lang
123 %defattr(644,root,root,755)
124 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
125 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
126 %attr(755,root,root) %{_bindir}/*
127 %dir %{_libdir}/lftp
128 %attr(755,root,root) %{_libdir}/lftp/*.so
129 %attr(755,root,root) %{_datadir}/lftp
130 %{_mandir}/man1/*
131 %lang(pl) %{_mandir}/pl/man1/*
132 %{_desktopdir}/lftp.desktop
133 %{_pixmapsdir}/lftp.png
This page took 2.315108 seconds and 4 git commands to generate.