]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
66bfe20c025b1d3f4c421beb0a99613776779095
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko):    ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â FTP/HTTP Å¬¶óÀ̾ðÆ®
18 Summary(pl):    Zaawansowany klient FTP/HTTP
19 Summary(pt_BR): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN): lftp ¿Í»§¶Ë³ÌÐò
21 Name:           lftp
22 Version:        3.5.2
23 Release:        2
24 License:        GPL
25 Group:          Applications/Networking
26 Source0:        ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.bz2
27 # Source0-md5:  9f40e9963de53c111d676171b9f810cd
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Patch0:         %{name}-home_etc.patch
32 Patch1:         %{name}-pl.po-update.patch
33 Patch2:         %{name}-makefile.patch
34 Patch3:         %{name}-as_needed-fix.patch
35 URL:            http://lftp.yar.ru/
36 BuildRequires:  autoconf >= 2.60
37 BuildRequires:  automake
38 BuildRequires:  gettext-devel >= 0.14.2
39 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
40 BuildRequires:  libstdc++-devel
41 BuildRequires:  libtool >= 1:1.4.2-9
42 BuildRequires:  ncurses-devel >= 5.2
43 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
44 BuildRequires:  readline-devel >= 4.2
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
48 %if %{_gcc_ver} == 2
49 %define         __cxx           "%{__cc}"
50 %endif
51
52 %description
53 LFTP is a shell-like command line FTP/HTTP client. The main two
54 advantages over other FTP clients are reliability and ability to
55 perform tasks in background. It will reconnect and reget the file
56 being transferred if the connection broke. You can start a transfer in
57 background and continue browsing on the FTP site. It does this all in
58 one process. When you have started background jobs and feel you are
59 done, you can just exit lftp and it automatically moves to nohup mode
60 and completes the transfers. It has also such nice features as reput
61 and mirror.
62
63 %description -l pl
64 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
65 po³±czyæ siê z serwerem FTP po zerwanym po³±czeniu i dokoñczyæ
66 ¶ci±ganie archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym
67 po³±czenia po tym jak siê wylogujesz. Program ten honoruje komendy
68 pow³oki podczas sesji, np. `ls -al | less` itp. Doskonale siê spisuje
69 jako aplikacja do mirrorowania serwerów FTP.
70
71 %description -l pt_BR
72 O lftp é um programa de transferência de arquivos por linha de
73 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
74 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
75 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
76 o arquivo FEATURES para uma lista mais detalhada.
77
78 %prep
79 %setup -q
80 #%patch0 -p1
81 %patch1 -p1
82 %patch2 -p1
83 %patch3 -p1
84 rm -f po/stamp-po
85
86 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
87
88 %build
89 %{__libtoolize}
90 %{__gettextize}
91 %{__aclocal} -I m4
92 %{__autoconf}
93 %{__automake}
94 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
95 %configure \
96         --with-modules \
97         --with%{!?with_ssl:out}-ssl \
98         --with%{!?with_openssl:out}-openssl \
99         --with%{!?with_gnutls:out}-gnutls
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
111 install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
112 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
113
114 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
115 rm -f $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
116 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
117
118 %find_lang %{name}
119
120 %clean
121 rm -rf $RPM_BUILD_ROOT
122
123 %post   -p /sbin/ldconfig
124 %postun -p /sbin/ldconfig
125
126 %files -f %{name}.lang
127 %defattr(644,root,root,755)
128 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
129 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
130 %attr(755,root,root) %{_bindir}/*
131 %dir %{_libdir}/lftp
132 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
133 %attr(755,root,root) %{_libdir}/lftp/*.so
134 %attr(755,root,root) %{_datadir}/lftp
135 %{_mandir}/man1/*
136 %lang(pl) %{_mandir}/pl/man1/*
137 %{_desktopdir}/lftp.desktop
138 %{_pixmapsdir}/lftp.png
This page took 0.025614 seconds and 2 git commands to generate.