]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
647c71dbc947cf32df219df57b97170a657130c4
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
18 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
19 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN.UTF-8):   lftp 客户端程序
21 Name:           lftp
22 Version:        4.4.2
23 Release:        1
24 License:        GPL v3+
25 Group:          Applications/Networking
26 Source0:        http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
27 # Source0-md5:  3c9411d859e1df9c09d3de0f32774cf3
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Source3:        %{name}-icon.png
32 Patch0:         %{name}-makefile.patch
33 Patch1:         %{name}-m4.patch
34 Patch2:         aliases.patch
35 # maintained by me, sent upstream from time to time  --qboosh
36 Patch3:         %{name}-pl.po-update.patch
37 Patch4:         lftp-4.3.8-gets.patch
38 URL:            http://lftp.yar.ru/
39 BuildRequires:  autoconf >= 2.60
40 BuildRequires:  automake
41 BuildRequires:  dante-devel
42 BuildRequires:  dnssec-tools-devel
43 BuildRequires:  expat-devel
44 BuildRequires:  gettext-devel >= 0.14.2
45 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
46 BuildRequires:  libstdc++-devel
47 BuildRequires:  libtool >= 1:1.4.2-9
48 BuildRequires:  ncurses-devel >= 5.2
49 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
50 BuildRequires:  pkgconfig
51 BuildRequires:  readline-devel >= 4.2
52 BuildRequires:  tar >= 1:1.22
53 BuildRequires:  xz
54 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
55
56 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
57 %if %{_gcc_ver} == 2
58 %define         __cxx           "%{__cc}"
59 %endif
60
61 %description
62 LFTP is a shell-like command line FTP/HTTP client. The main two
63 advantages over other FTP clients are reliability and ability to
64 perform tasks in background. It will reconnect and reget the file
65 being transferred if the connection broke. You can start a transfer in
66 background and continue browsing on the FTP site. It does this all in
67 one process. When you have started background jobs and feel you are
68 done, you can just exit lftp and it automatically moves to nohup mode
69 and completes the transfers. It has also such nice features as reput
70 and mirror.
71
72 %description -l pl.UTF-8
73 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
74 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
75 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
76 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
77 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
78 jako aplikacja do mirrorowania serwerów FTP.
79
80 %description -l pt_BR.UTF-8
81 O lftp é um programa de transferência de arquivos por linha de
82 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
83 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
84 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
85 o arquivo FEATURES para uma lista mais detalhada.
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92 #%patch3 -p1
93 %patch4 -p1
94
95 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
96
97 %build
98 %{__libtoolize}
99 %{__gettextize}
100 %{__aclocal} -I m4
101 %{__autoconf}
102 %{__automake}
103 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
104 %configure \
105         --without-included-regex \
106         --with-dnssec-local-validation \
107         --with-modules \
108         --with-socksdante \
109         --with%{!?with_openssl:out}-openssl \
110         --with%{!?with_gnutls:out}-gnutls
111
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
121 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
122 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
123
124 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
125 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
127
128 %find_lang %{name}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post   -p /sbin/ldconfig
134 %postun -p /sbin/ldconfig
135
136 %files -f %{name}.lang
137 %defattr(644,root,root,755)
138 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
139 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
140 %attr(755,root,root) %{_bindir}/lftp
141 %attr(755,root,root) %{_bindir}/lftpget
142 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
143 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
144 %dir %{_libdir}/lftp
145 %attr(755,root,root) %{_libdir}/lftp/*.so
146 %attr(755,root,root) %{_datadir}/lftp
147 %{_mandir}/man1/lftp.1*
148 %{_mandir}/man1/lftpget.1*
149 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
150 %{_mandir}/man5/lftp.conf.5*
151 %{_desktopdir}/lftp.desktop
152 %{_pixmapsdir}/lftp.png
This page took 0.0570929999999999 seconds and 2 git commands to generate.