]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- x32 rebuild
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl     # do not use SSL
6 %bcond_with     gnutls  # use gnutls, otherwise openssl is used when ssl is on
7 # better just preload it instead forcing linking
8 %bcond_with     dante   # Dante-based SOCKS support
9 # broken currently https://www.dnssec-tools.org/trac/ticket/173
10 %bcond_with     dnssec  # DNSSEC local validation
11 #
12 %if %{with ssl}
13 %define with_openssl 1
14 %endif
15
16 %if %{with gnutls} && %{with ssl}
17 %undefine with_openssl
18 %endif
19
20 Summary:        Sophisticated command line FTP/HTTP client
21 Summary(ko.UTF-8):      명령줄에서 돌아가는 FTP/HTTP 클라이언트
22 Summary(pl.UTF-8):      Zaawansowany klient FTP/HTTP
23 Summary(pt_BR.UTF-8):   Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
24 Summary(zh_CN.UTF-8):   lftp 客户端程序
25 Name:           lftp
26 Version:        4.6.1
27 Release:        3
28 License:        GPL v3+
29 Group:          Applications/Networking
30 Source0:        http://lftp.yar.ru/ftp/%{name}-%{version}.tar.xz
31 # Source0-md5:  e204e68ee2438da67644cc239de7c465
32 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
33 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
34 Source2:        %{name}.desktop
35 Source3:        %{name}-icon.png
36 Patch100:       %{name}-git.patch
37 Patch0:         %{name}-makefile.patch
38 Patch1:         %{name}-m4.patch
39 Patch2:         aliases.patch
40 # when updated attach at https://github.com/lavv17/lftp/issues
41 Patch3:         %{name}-pl.po-update.patch
42 Patch4:         lftp-4.3.8-gets.patch
43 Patch5:         %{name}-am.patch
44 Patch6:         lftp-bug-121.patch
45 URL:            http://lftp.yar.ru/
46 BuildRequires:  autoconf >= 2.60
47 BuildRequires:  automake
48 %{?with_dante:BuildRequires:    dante-devel}
49 %{?with_dnssec:BuildRequires:   dnssec-tools-devel}
50 BuildRequires:  expat-devel
51 BuildRequires:  gettext-tools >= 0.14.2
52 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
53 BuildRequires:  libstdc++-devel
54 BuildRequires:  libtool >= 1:1.4.2-9
55 BuildRequires:  ncurses-devel >= 5.2
56 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
57 BuildRequires:  pkgconfig
58 BuildRequires:  readline-devel >= 4.2
59 BuildRequires:  tar >= 1:1.22
60 BuildRequires:  xz
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
64 %if %{_gcc_ver} == 2
65 %define         __cxx           "%{__cc}"
66 %endif
67
68 %description
69 LFTP is a shell-like command line FTP/HTTP client. The main two
70 advantages over other FTP clients are reliability and ability to
71 perform tasks in background. It will reconnect and reget the file
72 being transferred if the connection broke. You can start a transfer in
73 background and continue browsing on the FTP site. It does this all in
74 one process. When you have started background jobs and feel you are
75 done, you can just exit lftp and it automatically moves to nohup mode
76 and completes the transfers. It has also such nice features as reput
77 and mirror.
78
79 %description -l pl.UTF-8
80 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
81 połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
82 ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
83 połączenia po tym jak się wylogujesz. Program ten honoruje komendy
84 powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
85 jako aplikacja do mirrorowania serwerów FTP.
86
87 %description -l pt_BR.UTF-8
88 O lftp é um programa de transferência de arquivos por linha de
89 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
90 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
91 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
92 o arquivo FEATURES para uma lista mais detalhada.
93
94 %prep
95 %setup -q
96 #%patch100 -p1
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100 %patch3 -p1
101 %patch4 -p1
102 %patch5 -p1
103 %patch6 -p1
104
105 %{__rm} po/stamp-po
106
107 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
108
109 %build
110 %{__libtoolize}
111 %{__gettextize}
112 %{__aclocal} -I m4
113 %{__autoconf}
114 %{__automake}
115 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
116 %configure \
117         --without-included-regex \
118         --with-dnssec-local-validation%{!?with_dnssec:=no} \
119         --with-modules \
120         --with-socksdante%{!?with_dante:=no} \
121         --with%{!?with_openssl:out}-openssl \
122         --with%{!?with_gnutls:out}-gnutls
123
124 %{__make}
125
126 %install
127 rm -rf $RPM_BUILD_ROOT
128 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT
131
132 cp -p lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
133 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
134 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
135
136 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
137 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
138 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
139
140 %find_lang %{name}
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %post   -p /sbin/ldconfig
146 %postun -p /sbin/ldconfig
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
151 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
152 %attr(755,root,root) %{_bindir}/lftp
153 %attr(755,root,root) %{_bindir}/lftpget
154 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
156 %dir %{_libdir}/lftp
157 %attr(755,root,root) %{_libdir}/lftp/*.so
158 %attr(755,root,root) %{_datadir}/lftp
159 %{_mandir}/man1/lftp.1*
160 %{_mandir}/man1/lftpget.1*
161 %lang(pl) %{_mandir}/pl/man1/lftpget.1*
162 %{_mandir}/man5/lftp.conf.5*
163 %{_desktopdir}/lftp.desktop
164 %{_pixmapsdir}/lftp.png
This page took 0.066279 seconds and 3 git commands to generate.