]> git.pld-linux.org Git - packages/lftp.git/blob - lftp.spec
- kill Icon: field (support for these is obsolete says jbj)
[packages/lftp.git] / lftp.spec
1 # TODO
2 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
3 #
4 # Conditional build:
5 %bcond_without  ssl             # do not use SSL
6 %bcond_with             gnutls  # use gnutls, otherwise openssl is used when ssl is on
7
8 %if %{with ssl}
9 %define with_openssl 1
10 %endif
11
12 %if %{with gnutls} && %{with ssl}
13 %undefine with_openssl
14 %endif
15
16 Summary:        Sophisticated command line FTP/HTTP client
17 Summary(ko):    ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â FTP/HTTP Å¬¶óÀ̾ðÆ®
18 Summary(pl):    Zaawansowany klient FTP/HTTP
19 Summary(pt_BR): Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
20 Summary(zh_CN): lftp ¿Í»§¶Ë³ÌÐò
21 Name:           lftp
22 Version:        3.4.0
23 Release:        2
24 License:        GPL
25 Group:          Applications/Networking
26 Source0:        ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.bz2
27 # Source0-md5:  5d39a8b250691a693470b1773b5c6bd4
28 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
29 # Source1-md5:  cdad8fb5342eebd9916eccefc98a855b
30 Source2:        %{name}.desktop
31 Patch0:         %{name}-home_etc.patch
32 Patch1:         %{name}-pl.po-update.patch
33 URL:            http://lftp.yar.ru/
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  gettext-devel >= 0.14.2
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool >= 1:1.4.2-9
39 BuildRequires:  ncurses-devel >= 5.2
40 %{?with_openssl:BuildRequires:  openssl-devel >= 0.9.7d}
41 %{?with_gnutls:BuildRequires:   gnutls-devel >= 1.2.5}
42 BuildRequires:  readline-devel >= 4.2
43 BuildRequires:  sed >= 4.0
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
47 %if %{_gcc_ver} == 2
48 %define         __cxx           "%{__cc}"
49 %endif
50
51 %description
52 LFTP is a shell-like command line FTP/HTTP client. The main two
53 advantages over other FTP clients are reliability and ability to
54 perform tasks in background. It will reconnect and reget the file
55 being transferred if the connection broke. You can start a transfer in
56 background and continue browsing on the FTP site. It does this all in
57 one process. When you have started background jobs and feel you are
58 done, you can just exit lftp and it automatically moves to nohup mode
59 and completes the transfers. It has also such nice features as reput
60 and mirror.
61
62 %description -l pl
63 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
64 po³±czyæ siê z serwerem FTP po zerwanym po³±czeniu i dokoñczyæ
65 ¶ci±ganie archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym
66 po³±czenia po tym jak siê wylogujesz. Program ten honoruje komendy
67 pow³oki podczas sesji, np. `ls -al | less` itp. Doskonale siê spisuje
68 jako aplikacja do mirrorowania serwerów FTP.
69
70 %description -l pt_BR
71 O lftp é um programa de transferência de arquivos por linha de
72 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
73 HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
74 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
75 o arquivo FEATURES para uma lista mais detalhada.
76
77 %prep
78 %setup -q
79 #%patch0 -p1
80 %patch1 -p1
81 rm -f po/stamp-po
82
83 sed -i -e 's#pkgverlibdir.*=.*#pkgverlibdir = $(pkglibdir)#g' src/Makefile*
84 # for gettext >= 0.14.2
85 sed -i -e 's/jm_AC/gl_AC/' m4/human.m4
86
87 %{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
88
89 %build
90 %{__libtoolize}
91 %{__gettextize}
92 %{__aclocal} -I m4
93 %{__autoconf}
94 %{__automake}
95 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
96 %configure \
97         --with-modules \
98         --with%{!?with_ssl:out}-ssl \
99         --with%{!?with_openssl:out}-openssl \
100         --with%{!?with_gnutls:out}-gnutls
101
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
112 install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
113 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
114
115 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
116
117 %find_lang %{name}
118
119 %clean
120 rm -rf $RPM_BUILD_ROOT
121
122 %post   -p /sbin/ldconfig
123 %postun -p /sbin/ldconfig
124
125 %files -f %{name}.lang
126 %defattr(644,root,root,755)
127 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
128 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
129 %attr(755,root,root) %{_bindir}/*
130 %dir %{_libdir}/lftp
131 %attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
132 %attr(755,root,root) %{_libdir}/lftp/*.so
133 %attr(755,root,root) %{_datadir}/lftp
134 %{_mandir}/man1/*
135 %lang(pl) %{_mandir}/pl/man1/*
136 %{_desktopdir}/lftp.desktop
137 %{_pixmapsdir}/lftp.png
This page took 0.03822 seconds and 3 git commands to generate.