]> git.pld-linux.org Git - packages/dehydrated.git/blob - letsencrypt.sh.spec
add dummy domains file
[packages/dehydrated.git] / letsencrypt.sh.spec
1 Summary:        letsencrypt/acme client implemented as a shell-script
2 Name:           letsencrypt.sh
3 Version:        0.1.0
4 Release:        0.5
5 License:        MIT
6 Group:          Applications/Networking
7 Source0:        https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  eadd134cc5365753c03929dd70db341d
9 Source1:        apache.conf
10 Source2:        lighttpd.conf
11 Source3:        config.sh
12 Source4:        domains.txt
13 Patch0:         pld.patch
14 URL:            https://github.com/lukas2511/letsencrypt.sh
15 BuildRequires:  rpmbuild(macros) >= 1.713
16 Requires:       curl
17 Requires:       grep
18 Requires:       mktemp
19 Requires:       openssl
20 Requires:       sed
21 Requires:       webapps
22 Requires:       webserver(access)
23 Requires:       webserver(alias)
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _webapps        /etc/webapps
28 %define         _webapp         %{name}
29 %define         _sysconfdir     %{_webapps}/%{_webapp}
30 %define         _appdir         %{_datadir}/%{_webapp}
31
32 %description
33 This is a client for signing certificates with an ACME-server
34 (currently only provided by letsencrypt) implemented as a relatively
35 simple bash-script.
36
37 Current features:
38 - Signing of a list of domains
39 - Signing of a CSR
40 - Renewal if a certificate is about to expire or SAN (subdomains)
41   changed
42 - Certificate revocation
43
44 %prep
45 %setup -q
46 %patch0 -p1
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/acme-challenges}
51
52 install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
53
54 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
55 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
56 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
57 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
58 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %triggerin -- apache1 < 1.3.37-3, apache1-base
64 %webapp_register apache %{_webapp}
65
66 %triggerun -- apache1 < 1.3.37-3, apache1-base
67 %webapp_unregister apache %{_webapp}
68
69 %triggerin -- apache < 2.2.0, apache-base
70 %webapp_register httpd %{_webapp}
71
72 %triggerun -- apache < 2.2.0, apache-base
73 %webapp_unregister httpd %{_webapp}
74
75 %triggerin -- lighttpd
76 %webapp_register lighttpd %{_webapp}
77
78 %triggerun -- lighttpd
79 %webapp_unregister lighttpd %{_webapp}
80
81 %files
82 %defattr(644,root,root,755)
83 %doc README.md CHANGELOG LICENSE
84 %dir %attr(750,root,http) %{_sysconfdir}
85 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
86 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
87 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
88 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
89 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
90 # challenges written here from letsencrypt.sh, need to be readable by webserver
91 %dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
92
93 %attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.062109 seconds and 4 git commands to generate.