]> git.pld-linux.org Git - packages/dehydrated.git/blob - letsencrypt.sh.spec
d13d564e2ac263ebf52e5c548a182b4856fadc18
[packages/dehydrated.git] / letsencrypt.sh.spec
1 Summary:        letsencrypt/acme client implemented as a shell-script
2 Name:           letsencrypt.sh
3 Version:        0.1.0
4 Release:        0.4
5 License:        MIT
6 Group:          Applications/Networking
7 Source0:        https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  eadd134cc5365753c03929dd70db341d
9 Source1:        apache.conf
10 Source2:        lighttpd.conf
11 Source3:        config.sh
12 Patch0:         pld.patch
13 URL:            https://github.com/lukas2511/letsencrypt.sh
14 BuildRequires:  rpmbuild(macros) >= 1.713
15 Requires:       curl
16 Requires:       grep
17 Requires:       mktemp
18 Requires:       openssl
19 Requires:       sed
20 Requires:       webapps
21 Requires:       webserver(access)
22 Requires:       webserver(alias)
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _webapps        /etc/webapps
27 %define         _webapp         %{name}
28 %define         _sysconfdir     %{_webapps}/%{_webapp}
29 %define         _appdir         %{_datadir}/%{_webapp}
30
31 %description
32 This is a client for signing certificates with an ACME-server
33 (currently only provided by letsencrypt) implemented as a relatively
34 simple bash-script.
35
36 Current features:
37 - Signing of a list of domains
38 - Signing of a CSR
39 - Renewal if a certificate is about to expire or SAN (subdomains)
40   changed
41 - Certificate revocation
42
43 %prep
44 %setup -q
45 %patch0 -p1
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/acme-challenges}
50
51 install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
52
53 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
54 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
55 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
56 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %triggerin -- apache1 < 1.3.37-3, apache1-base
62 %webapp_register apache %{_webapp}
63
64 %triggerun -- apache1 < 1.3.37-3, apache1-base
65 %webapp_unregister apache %{_webapp}
66
67 %triggerin -- apache < 2.2.0, apache-base
68 %webapp_register httpd %{_webapp}
69
70 %triggerun -- apache < 2.2.0, apache-base
71 %webapp_unregister httpd %{_webapp}
72
73 %triggerin -- lighttpd
74 %webapp_register lighttpd %{_webapp}
75
76 %triggerun -- lighttpd
77 %webapp_unregister lighttpd %{_webapp}
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README.md CHANGELOG LICENSE
82 %dir %attr(750,root,http) %{_sysconfdir}
83 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
84 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
85 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
86 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
87 # challenges written here from letsencrypt.sh, need to be readable by webserver
88 %dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
89
90 %attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.032376 seconds and 3 git commands to generate.