]> git.pld-linux.org Git - packages/dehydrated.git/blob - letsencrypt.sh.spec
looks complete; rel 1
[packages/dehydrated.git] / letsencrypt.sh.spec
1 Summary:        letsencrypt/acme client implemented as a shell-script
2 Name:           letsencrypt.sh
3 Version:        0.1.0
4 Release:        1
5 License:        MIT
6 Group:          Applications/Networking
7 Source0:        https://github.com/lukas2511/letsencrypt.sh/archive/v%{version}/%{name}-%{version}.tar.gz
8 # Source0-md5:  eadd134cc5365753c03929dd70db341d
9 Source1:        apache.conf
10 Source2:        lighttpd.conf
11 Source3:        config.sh
12 Source4:        domains.txt
13 Source5:        hook.sh
14 Source6:        crontab
15 Patch0:         pld.patch
16 URL:            https://github.com/lukas2511/letsencrypt.sh
17 BuildRequires:  rpmbuild(macros) >= 1.713
18 Requires:       crondaemon
19 Requires:       curl
20 Requires:       grep
21 Requires:       mktemp
22 Requires:       openssl-tools
23 Requires:       sed
24 Requires:       webapps
25 Requires:       webserver(access)
26 Requires:       webserver(alias)
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _webapps        /etc/webapps
31 %define         _webapp         %{name}
32 %define         _sysconfdir     %{_webapps}/%{_webapp}
33 %define         _appdir         %{_datadir}/%{_webapp}
34
35 %description
36 This is a client for signing certificates with an ACME-server
37 (currently only provided by letsencrypt) implemented as a relatively
38 simple bash-script.
39
40 Current features:
41 - Signing of a list of domains
42 - Signing of a CSR
43 - Renewal if a certificate is about to expire or SAN (subdomains)
44   changed
45 - Certificate revocation
46
47 %prep
48 %setup -q
49 %patch0 -p1
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}/{acme-challenges,certs},/etc/cron.d}
54
55 install -p letsencrypt.sh $RPM_BUILD_ROOT%{_sbindir}
56
57 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
58 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
59 cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}
60 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}
61 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/cron.d/letsencrypt
62 install -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}
63 cp -p $RPM_BUILD_ROOT%{_sysconfdir}/{apache,httpd}.conf
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %triggerin -- apache1 < 1.3.37-3, apache1-base
69 %webapp_register apache %{_webapp}
70
71 %triggerun -- apache1 < 1.3.37-3, apache1-base
72 %webapp_unregister apache %{_webapp}
73
74 %triggerin -- apache < 2.2.0, apache-base
75 %webapp_register httpd %{_webapp}
76
77 %triggerun -- apache < 2.2.0, apache-base
78 %webapp_unregister httpd %{_webapp}
79
80 %triggerin -- lighttpd
81 %webapp_register lighttpd %{_webapp}
82
83 %triggerun -- lighttpd
84 %webapp_unregister lighttpd %{_webapp}
85
86 %files
87 %defattr(644,root,root,755)
88 %doc README.md CHANGELOG LICENSE
89 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/cron.d/letsencrypt
90 %dir %attr(750,root,http) %{_sysconfdir}
91 %dir %attr(700,root,root) %{_sysconfdir}/certs
92 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
93 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
94 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
95 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/config.sh
96 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/domains.txt
97 %attr(750,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hook.sh
98 # challenges written here from letsencrypt.sh, need to be readable by webserver
99 %dir %attr(751,root,root) %{_sysconfdir}/acme-challenges
100
101 %attr(755,root,root) %{_sbindir}/letsencrypt.sh
This page took 0.052553 seconds and 3 git commands to generate.