]> git.pld-linux.org Git - packages/ldb.git/blob - ldb.spec
- updated to 1.1.25
[packages/ldb.git] / ldb.spec
1 # TODO
2 # - ld.bfd enforced because gold does not understand '!' in version script (binutils-3:2.21.53.0.1-1)
3 %define         talloc_version  2:2.1.5
4 %define         tdb_version     2:1.3.8
5 %define         tevent_version  0.9.26
6 Summary:        LDAP-like embedded database
7 Summary(pl.UTF-8):      Wbudowana baza danych podobna do LDAP
8 Name:           ldb
9 Version:        1.1.25
10 Release:        1
11 License:        LGPL v3+
12 Group:          Libraries
13 Source0:        https://www.samba.org/ftp/ldb/%{name}-%{version}.tar.gz
14 # Source0-md5:  d674b5b9e659a97e43b5e424b3cedbb4
15 URL:            https://ldb.samba.org/
16 BuildRequires:  autoconf
17 BuildRequires:  docbook-style-xsl
18 BuildRequires:  libxslt
19 BuildRequires:  openldap-devel
20 BuildRequires:  popt-devel >= 1.6
21 BuildRequires:  python-devel >= 1:2.4.2
22 BuildRequires:  python-talloc-devel >= %{talloc_version}
23 BuildRequires:  python-tdb >= %{tdb_version}
24 BuildRequires:  python-tevent >= %{tevent_version}
25 BuildRequires:  rpmbuild(macros) >= 1.219
26 BuildRequires:  talloc-devel >= %{talloc_version}
27 BuildRequires:  tdb-devel >= %{tdb_version}
28 BuildRequires:  tevent-devel >= %{tevent_version}
29 Requires:       talloc >= %{talloc_version}
30 Requires:       tdb >= %{tdb_version}
31 Requires:       tevent >= %{tevent_version}
32 Requires:       popt >= 1.6
33 Provides:       libldb = %{version}-%{release}
34 Obsoletes:      libldb < 1.1.0-3
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 An extensible library that implements an LDAP like API to access
39 remote LDAP servers, or use local tdb databases.
40
41 %description -l pl.UTF-8
42 Rozszerzalna biblioteka implementująca API podobne do LDAP pozwalające
43 na dostęp do zdalnych serwerów LDAP lub wykorzystanie lokalnych baz
44 danych tdb.
45
46 %package tools
47 Summary:        Tools to manage LDB files
48 Summary(pl.UTF-8):      Narzędzia do zarządzania plikami LDB
49 Group:          Applications/Databases
50 Requires:       %{name} = %{version}-%{release}
51
52 %description tools
53 Tools to manage LDB files.
54
55 %description tools -l pl.UTF-8
56 Narzędzia do zarządzania plikami LDB.
57
58 %package devel
59 Summary:        Header files for the LDB library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LDB
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       talloc-devel >= %{talloc_version}
64 Requires:       tdb-devel >= %{tdb_version}
65 Requires:       tevent-devel >= %{tevent_version}
66 Provides:       libldb-devel = %{version}-%{release}
67 Obsoletes:      libldb-devel < 1.1.0-3
68
69 %description devel
70 Header files needed to develop programs that link against the LDB
71 library.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe potrzebne do tworzenia programów wykorzystujących
75 bibliotekę LDB.
76
77 %package -n python-ldb
78 Summary:        Python bindings for the LDB library
79 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki LDB
80 Group:          Libraries/Python
81 Requires:       %{name} = %{version}-%{release}
82 Requires:       python-libs >= 1:2.4.2
83 Requires:       python-tdb >= %{tdb_version}
84 Obsoletes:      pyldb
85
86 %description -n python-ldb
87 Python bindings for the LDB library.
88
89 %description -n python-ldb -l pl.UTF-8
90 Wiązania Pythona do biblioteki LDB.
91
92 %package -n python-ldb-devel
93 Summary:        Development files for the Python bindings for the LDB library
94 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do biblioteki LDB
95 Group:          Development/Libraries
96 Requires:       python-ldb = %{version}-%{release}
97
98 %description -n python-ldb-devel
99 Development files for the Python bindings for the LDB library.
100
101 %description -n python-ldb-devel -l pl.UTF-8
102 Pliki programistyczne wiązań Pythona do biblioteki LDB.
103
104 %prep
105 %setup -q
106
107 %build
108 CC="%{__cc}" \
109 CFLAGS="%{rpmcflags}" \
110 LDFLAGS="%{rpmldflags} -fuse-ld=bfd" \
111 PYTHONDIR=%{py_sitedir} \
112 ./configure \
113         --prefix=%{_prefix} \
114         --libdir=%{_libdir} \
115         --with-modulesdir=%{_libdir}/ldb/modules \
116         --with-privatelibdir=%{_libdir}/ldb \
117         --bundled-libraries=NONE \
118         --disable-rpath \
119         --disable-rpath-install
120
121 %{__make} \
122         V=1
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
130 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
131 %py_postclean
132
133 # Shared libraries need to be marked executable for
134 # rpmbuild to strip them and include them in debuginfo
135 find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} ';'
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post   -p /sbin/ldconfig
141 %postun -p /sbin/ldconfig
142
143 %post   -n python-ldb -p /sbin/ldconfig
144 %postun -n python-ldb -p /sbin/ldconfig
145
146 %files
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_libdir}/libldb.so.*.*.*
149 %attr(755,root,root) %ghost %{_libdir}/libldb.so.1
150 %dir %{_libdir}/ldb
151 %dir %{_libdir}/ldb/modules
152 %dir %{_libdir}/ldb/modules/ldb
153 %attr(755,root,root) %{_libdir}/ldb/modules/ldb/*.so
154
155 %files tools
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/ldbadd
158 %attr(755,root,root) %{_bindir}/ldbdel
159 %attr(755,root,root) %{_bindir}/ldbedit
160 %attr(755,root,root) %{_bindir}/ldbmodify
161 %attr(755,root,root) %{_bindir}/ldbrename
162 %attr(755,root,root) %{_bindir}/ldbsearch
163 %attr(755,root,root) %{_libdir}/ldb/libldb-cmdline.so
164 %{_mandir}/man1/ldbadd.1*
165 %{_mandir}/man1/ldbdel.1*
166 %{_mandir}/man1/ldbedit.1*
167 %{_mandir}/man1/ldbmodify.1*
168 %{_mandir}/man1/ldbrename.1*
169 %{_mandir}/man1/ldbsearch.1*
170
171 %files devel
172 %defattr(644,root,root,755)
173 %attr(755,root,root) %{_libdir}/libldb.so
174 %{_includedir}/ldb_module.h
175 %{_includedir}/ldb_handlers.h
176 %{_includedir}/ldb_errors.h
177 %{_includedir}/ldb_version.h
178 %{_includedir}/ldb.h
179 %{_pkgconfigdir}/ldb.pc
180 %{_mandir}/man3/ldb.3*
181
182 %files -n python-ldb
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libpyldb-util.so.*.*.*
185 %attr(755,root,root) %ghost %{_libdir}/libpyldb-util.so.1
186 %attr(755,root,root) %{py_sitedir}/ldb.so
187 %{py_sitedir}/_ldb_text.py[co]
188
189 %files -n python-ldb-devel
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libdir}/libpyldb-util.so
192 %{_includedir}/pyldb.h
193 %{_pkgconfigdir}/pyldb-util.pc
This page took 0.138131 seconds and 4 git commands to generate.