]> git.pld-linux.org Git - packages/ldb.git/blob - ldb.spec
- tevent 0.9.27
[packages/ldb.git] / ldb.spec
1 # TODO
2 # - ld.bfd enforced because gold does not understand '!' in version script (binutils-3:2.21.53.0.1-1)
3 %define         talloc_version  2:2.1.5
4 %define         tdb_version     2:1.3.8
5 %define         tevent_version  0.9.27
6 Summary:        LDAP-like embedded database
7 Summary(pl.UTF-8):      Wbudowana baza danych podobna do LDAP
8 Name:           ldb
9 Version:        1.1.26
10 Release:        1
11 License:        LGPL v3+
12 Group:          Libraries
13 Source0:        https://www.samba.org/ftp/ldb/%{name}-%{version}.tar.gz
14 # Source0-md5:  31780b702b638ad32aa5d9853d257839
15 URL:            https://ldb.samba.org/
16 BuildRequires:  docbook-style-xsl
17 BuildRequires:  libxslt
18 BuildRequires:  openldap-devel
19 BuildRequires:  popt-devel >= 1.6
20 BuildRequires:  python-devel >= 1:2.4.2
21 BuildRequires:  python-talloc-devel >= %{talloc_version}
22 BuildRequires:  python-tdb >= %{tdb_version}
23 BuildRequires:  python-tevent >= %{tevent_version}
24 BuildRequires:  rpmbuild(macros) >= 1.219
25 BuildRequires:  talloc-devel >= %{talloc_version}
26 BuildRequires:  tdb-devel >= %{tdb_version}
27 BuildRequires:  tevent-devel >= %{tevent_version}
28 Requires:       talloc >= %{talloc_version}
29 Requires:       tdb >= %{tdb_version}
30 Requires:       tevent >= %{tevent_version}
31 Requires:       popt >= 1.6
32 Provides:       libldb = %{version}-%{release}
33 Obsoletes:      libldb < 1.1.0-3
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 An extensible library that implements an LDAP like API to access
38 remote LDAP servers, or use local tdb databases.
39
40 %description -l pl.UTF-8
41 Rozszerzalna biblioteka implementująca API podobne do LDAP pozwalające
42 na dostęp do zdalnych serwerów LDAP lub wykorzystanie lokalnych baz
43 danych tdb.
44
45 %package tools
46 Summary:        Tools to manage LDB files
47 Summary(pl.UTF-8):      Narzędzia do zarządzania plikami LDB
48 Group:          Applications/Databases
49 Requires:       %{name} = %{version}-%{release}
50
51 %description tools
52 Tools to manage LDB files.
53
54 %description tools -l pl.UTF-8
55 Narzędzia do zarządzania plikami LDB.
56
57 %package devel
58 Summary:        Header files for the LDB library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LDB
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       talloc-devel >= %{talloc_version}
63 Requires:       tdb-devel >= %{tdb_version}
64 Requires:       tevent-devel >= %{tevent_version}
65 Provides:       libldb-devel = %{version}-%{release}
66 Obsoletes:      libldb-devel < 1.1.0-3
67
68 %description devel
69 Header files needed to develop programs that link against the LDB
70 library.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe potrzebne do tworzenia programów wykorzystujących
74 bibliotekę LDB.
75
76 %package -n python-ldb
77 Summary:        Python bindings for the LDB library
78 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki LDB
79 Group:          Libraries/Python
80 Requires:       %{name} = %{version}-%{release}
81 Requires:       python-libs >= 1:2.4.2
82 Requires:       python-tdb >= %{tdb_version}
83 Obsoletes:      pyldb
84
85 %description -n python-ldb
86 Python bindings for the LDB library.
87
88 %description -n python-ldb -l pl.UTF-8
89 Wiązania Pythona do biblioteki LDB.
90
91 %package -n python-ldb-devel
92 Summary:        Development files for the Python bindings for the LDB library
93 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do biblioteki LDB
94 Group:          Development/Libraries
95 Requires:       python-ldb = %{version}-%{release}
96
97 %description -n python-ldb-devel
98 Development files for the Python bindings for the LDB library.
99
100 %description -n python-ldb-devel -l pl.UTF-8
101 Pliki programistyczne wiązań Pythona do biblioteki LDB.
102
103 %prep
104 %setup -q
105
106 %build
107 CC="%{__cc}" \
108 CFLAGS="%{rpmcflags}" \
109 LDFLAGS="%{rpmldflags} -fuse-ld=bfd" \
110 PYTHONDIR=%{py_sitedir} \
111 ./configure \
112         --prefix=%{_prefix} \
113         --libdir=%{_libdir} \
114         --with-modulesdir=%{_libdir}/ldb/modules \
115         --with-privatelibdir=%{_libdir}/ldb \
116         --bundled-libraries=NONE \
117         --disable-rpath \
118         --disable-rpath-install
119
120 %{__make} \
121         V=1
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT
127
128 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
129 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
130 %py_postclean
131
132 # Shared libraries need to be marked executable for
133 # rpmbuild to strip them and include them in debuginfo
134 find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} ';'
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post   -p /sbin/ldconfig
140 %postun -p /sbin/ldconfig
141
142 %post   -n python-ldb -p /sbin/ldconfig
143 %postun -n python-ldb -p /sbin/ldconfig
144
145 %files
146 %defattr(644,root,root,755)
147 %attr(755,root,root) %{_libdir}/libldb.so.*.*.*
148 %attr(755,root,root) %ghost %{_libdir}/libldb.so.1
149 %dir %{_libdir}/ldb
150 %dir %{_libdir}/ldb/modules
151 %dir %{_libdir}/ldb/modules/ldb
152 %attr(755,root,root) %{_libdir}/ldb/modules/ldb/*.so
153
154 %files tools
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/ldbadd
157 %attr(755,root,root) %{_bindir}/ldbdel
158 %attr(755,root,root) %{_bindir}/ldbedit
159 %attr(755,root,root) %{_bindir}/ldbmodify
160 %attr(755,root,root) %{_bindir}/ldbrename
161 %attr(755,root,root) %{_bindir}/ldbsearch
162 %attr(755,root,root) %{_libdir}/ldb/libldb-cmdline.so
163 %{_mandir}/man1/ldbadd.1*
164 %{_mandir}/man1/ldbdel.1*
165 %{_mandir}/man1/ldbedit.1*
166 %{_mandir}/man1/ldbmodify.1*
167 %{_mandir}/man1/ldbrename.1*
168 %{_mandir}/man1/ldbsearch.1*
169
170 %files devel
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libldb.so
173 %{_includedir}/ldb_module.h
174 %{_includedir}/ldb_handlers.h
175 %{_includedir}/ldb_errors.h
176 %{_includedir}/ldb_version.h
177 %{_includedir}/ldb.h
178 %{_pkgconfigdir}/ldb.pc
179 %{_mandir}/man3/ldb.3*
180
181 %files -n python-ldb
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_libdir}/libpyldb-util.so.*.*.*
184 %attr(755,root,root) %ghost %{_libdir}/libpyldb-util.so.1
185 %attr(755,root,root) %{py_sitedir}/ldb.so
186 %{py_sitedir}/_ldb_text.py[co]
187
188 %files -n python-ldb-devel
189 %defattr(644,root,root,755)
190 %attr(755,root,root) %{_libdir}/libpyldb-util.so
191 %{_includedir}/pyldb.h
192 %{_pkgconfigdir}/pyldb-util.pc
This page took 0.168864 seconds and 4 git commands to generate.