]> git.pld-linux.org Git - packages/ldb.git/blob - ldb.spec
- base Group fixed
[packages/ldb.git] / ldb.spec
1 # TODO
2 # - ld.bfd enforced because gold does not understand '!' in version script (binutils-3:2.21.53.0.1-1)
3 %define         talloc_version  2.0.5
4 %define         tdb_version     2:1.2.9
5 %define         tevent_version  0.9.12
6 Summary:        LDAP-like embedded database
7 Summary(pl.UTF-8):      Wbudowana baza danych podobna do LDAP
8 Name:           ldb
9 Version:        1.1.0
10 Release:        4
11 License:        LGPL v3+
12 Group:          Libraries
13 Source0:        http://samba.org/ftp/ldb/%{name}-%{version}.tar.gz
14 # Source0-md5:  61145ad9cfe017ce4fca5cbc77b9552b
15 URL:            http://ldb.samba.org/
16 BuildRequires:  autoconf
17 BuildRequires:  docbook-style-xsl
18 BuildRequires:  libxslt
19 BuildRequires:  popt-devel
20 BuildRequires:  python-devel
21 BuildRequires:  python-talloc-devel
22 BuildRequires:  python-tdb
23 BuildRequires:  talloc-devel >= %{talloc_version}
24 BuildRequires:  tdb-devel >= %{tdb_version}
25 BuildRequires:  tevent-devel >= %{tevent_version}
26 Requires:       talloc >= %{talloc_version}
27 Requires:       tdb >= %{tdb_version}
28 Requires:       tevent >= %{tevent_version}
29 Provides:       libldb = %{version}-%{release}
30 Obsoletes:      libldb < 1.1.0-3
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 An extensible library that implements an LDAP like API to access
35 remote LDAP servers, or use local tdb databases.
36
37 %description -l pl.UTF-8
38 Rozszerzalna biblioteka implementująca API podobne do LDAP pozwalające
39 na dostęp do zdalnych serwerów LDAP lub wykorzystanie lokalnych baz
40 danych tdb.
41
42 %package tools
43 Summary:        Tools to manage LDB files
44 Summary(pl.UTF-8):      Narzędzia do zarządzania plikami LDB
45 Group:          Applications/Databases
46 Requires:       %{name} = %{version}-%{release}
47
48 %description tools
49 Tools to manage LDB files.
50
51 %description tools -l pl.UTF-8
52 Narzędzia do zarządzania plikami LDB.
53
54 %package devel
55 Summary:        Header files for the LDB library
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki LDB
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       talloc-devel >= %{talloc_version}
60 Requires:       tdb-devel >= %{tdb_version}
61 Requires:       tevent-devel >= %{tevent_version}
62 Provides:       libldb-devel = %{version}-%{release}
63 Obsoletes:      libldb-devel < 1.1.0-3
64
65 %description devel
66 Header files needed to develop programs that link against the LDB
67 library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe potrzebne do tworzenia programów wykorzystujących
71 bibliotekę LDB.
72
73 %package -n python-ldb
74 Summary:        Python bindings for the LDB library
75 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki LDB
76 Group:          Libraries/Python
77 Requires:       %{name} = %{version}-%{release}
78 Requires:       python-tdb = %{tdb_version}
79 Obsoletes:      pyldb
80
81 %description -n python-ldb
82 Python bindings for the LDB library.
83
84 %description -n python-ldb -l pl.UTF-8
85 Wiązania Pythona do biblioteki LDB.
86
87 %package -n python-ldb-devel
88 Summary:        Development files for the Python bindings for the LDB library
89 Summary(pl.UTF-8):      Pliki programistyczne wiązań Pythona do biblioteki LDB
90 Group:          Development/Libraries
91 Requires:       python-ldb = %{version}-%{release}
92
93 %description -n python-ldb-devel
94 Development files for the Python bindings for the LDB library.
95
96 %description -n python-ldb-devel -l pl.UTF-8
97 Pliki programistyczne wiązań Pythona do biblioteki LDB.
98
99 %prep
100 %setup -q
101
102 %build
103 CC="%{__cc}" \
104 CFLAGS="%{rpmcflags}" \
105 LDFLAGS="%{rpmldflags} -fuse-ld=bfd" \
106 PYTHONDIR=%{py_sitedir} \
107 ./configure \
108         --prefix=%{_prefix} \
109         --libdir=%{_libdir} \
110         --with-modulesdir=%{_libdir}/ldb/modules \
111         --with-privatelibdir=%{_libdir}/ldb \
112         --bundled-libraries=NONE \
113         --disable-rpath \
114         --disable-rpath-install
115
116 %{__make} \
117         V=1
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT
123
124 # Remove _tevent.so (it's managed by python-tevent)
125 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_tevent.so
126
127 # Shared libraries need to be marked executable for
128 # rpmbuild to strip them and include them in debuginfo
129 find $RPM_BUILD_ROOT -name "*.so*" -exec chmod -c +x {} ';'
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %post   -p /sbin/ldconfig
135 %postun -p /sbin/ldconfig
136
137 %post   -n python-ldb -p /sbin/ldconfig
138 %postun -n python-ldb -p /sbin/ldconfig
139
140 %files
141 %defattr(644,root,root,755)
142 %attr(755,root,root) %{_libdir}/libldb.so.*
143 %dir %{_libdir}/ldb
144 %dir %{_libdir}/ldb/modules
145 %dir %{_libdir}/ldb/modules/ldb
146 %attr(755,root,root) %{_libdir}/ldb/modules/ldb/*.so
147
148 %files tools
149 %defattr(644,root,root,755)
150 %attr(755,root,root) %{_bindir}/ldbadd
151 %attr(755,root,root) %{_bindir}/ldbdel
152 %attr(755,root,root) %{_bindir}/ldbedit
153 %attr(755,root,root) %{_bindir}/ldbmodify
154 %attr(755,root,root) %{_bindir}/ldbrename
155 %attr(755,root,root) %{_bindir}/ldbsearch
156 %attr(755,root,root) %{_libdir}/ldb/libldb-cmdline.so
157 %{_mandir}/man1/ldbadd.1*
158 %{_mandir}/man1/ldbdel.1*
159 %{_mandir}/man1/ldbedit.1*
160 %{_mandir}/man1/ldbmodify.1*
161 %{_mandir}/man1/ldbrename.1*
162 %{_mandir}/man1/ldbsearch.1*
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libldb.so
167 %{_includedir}/ldb_module.h
168 %{_includedir}/ldb_handlers.h
169 %{_includedir}/ldb_errors.h
170 %{_includedir}/ldb_version.h
171 %{_includedir}/ldb.h
172 %{_pkgconfigdir}/ldb.pc
173 %{_mandir}/man3/ldb.3*
174
175 %files -n python-ldb
176 %defattr(644,root,root,755)
177 %attr(755,root,root) %{_libdir}/libpyldb-util.so.1*
178 %attr(755,root,root) %{py_sitedir}/ldb.so
179
180 %files -n python-ldb-devel
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libpyldb-util.so
183 %{_includedir}/pyldb.h
184 %{_pkgconfigdir}/pyldb-util.pc
This page took 0.136986 seconds and 4 git commands to generate.