]> git.pld-linux.org Git - packages/kodi.git/blob - kodi.spec
up to 16.0-Jarvis
[packages/kodi.git] / kodi.spec
1 # TODO:
2 #  - fix build flags - some files are compiled with -O3 and without rpm*flags
3 #  - add and/or fix users/groups permissions
4 #  - split to subpackages?
5 # - bundled ffmpeg build (tools/depends/target/ffmpeg/autobuild.sh) enables nonfree & gpl!
6 #
7 # Conditional build:
8 # Features:
9 %bcond_with     afpclient       # AFP support via libafpclient
10 %bcond_without  airplay         # AirPlay support
11 %bcond_with     airtunes        # AirTunes support
12 %bcond_without  alsa            # ALSA support
13 %bcond_without  avahi           # Avahi support
14 %bcond_without  dbus            # DBUS support
15 %bcond_without  dvdcss          # DVDCSS support
16 %bcond_without  fishbmc         # FishBMC visualisation
17 %bcond_without  gl              # OpenGL rendering
18 %bcond_without  goom            # GOOM visualisation
19 %bcond_with     gtest           # configure Google Test Framework
20 %bcond_without  joystick        # SDL joystick support
21 %bcond_without  libcap          # libcap support
22 %bcond_with     libcec          # libcec support
23 %bcond_without  libusb          # libusb support
24 %bcond_with     mdnsembedded    # mDNSEmbedded support
25 %bcond_without  mysql           # MySQL
26 %bcond_without  nfs             # NFS support via libnfs
27 %bcond_without  non_free        # componentents with non-compliant licenses
28 %bcond_with     openmax         # OpenMax decoding, requires OpenGLES
29 %bcond_without  optical_drive   # optical drive
30 %bcond_without  projectm        # ProjectM visualisation
31 %bcond_without  pulse           # PulseAudio support
32 %bcond_without  rsxs            # really slick X screensavers
33 %bcond_without  rtmp            # RTMP support via librtmp
34 %bcond_without  samba           # SAMBA support
35 %bcond_without  sdl             # SDL
36 %bcond_without  spectrum        # Spectrum visualisation
37 %bcond_without  ssh             # SSH SFTP support
38 %bcond_without  texturepacker   # texturepacker support
39 %bcond_without  udev            # udev support
40 %bcond_without  upnp            # UPnP support
41 %bcond_without  vaapi           # VAAPI decoding
42 %bcond_without  vdpau           # VDPAU decoding
43 %bcond_with     vtbdecoder      # VTBDecoder decoding (VTB Decoder not supported on this platform)
44 %bcond_without  waveform        # Waveform visualisation
45 %bcond_without  webserver       # webserver
46 %bcond_without  x11             # x11 'Linux Only'
47 %bcond_without  xrandr          # XRandR support
48 %bcond_with     asap_codec      # ASAP ADPCM support
49 %bcond_with     gles            # OpenGLES rendering
50 %bcond_without  libbluray       # libbluray support
51 %bcond_without  mid             # MID support
52 %bcond_with     profiling       # gprof profiling
53 %bcond_with     tegra           # Tegra2 arm
54 %bcond_with     wayland         # wayland
55 # System libs:
56 %bcond_without  system_ffmpeg   # build with system ffmpeg
57 %bcond_without  system_dvdread  # build with system dvdread
58
59 %define codename Jarvis
60 Summary:        Kodi is a free and open source media-player and entertainment hub
61 Name:           kodi
62 Version:        16.0
63 Release:        0.1
64 License:        GPL v2+ and GPL v3+
65 Group:          Applications/Multimedia
66 Source0:        http://mirrors.kodi.tv/releases/source/%{version}-%{codename}.tar.gz
67 # Source0-md5:  ce887b7e831bca8843c5262313f28913
68 Patch0:         jpeglib-boolean.patch
69 Patch1:         disable-static.patch
70 Patch2:         dvdread.patch
71 Patch4:         gcc5.patch
72 URL:            http://kodi.tv/
73 BuildRequires:  Mesa-libGLU-devel
74 BuildRequires:  OpenGL-devel
75 BuildRequires:  SDL2-devel
76 BuildRequires:  SDL_image-devel
77 BuildRequires:  SDL_mixer-devel
78 BuildRequires:  alsa-lib-devel
79 BuildRequires:  autoconf
80 BuildRequires:  automake
81 BuildRequires:  avahi-devel
82 BuildRequires:  bluez-libs-devel >= 4.99
83 BuildRequires:  boost-devel
84 BuildRequires:  bzip2-devel
85 BuildRequires:  cmake
86 BuildRequires:  crossguid-devel
87 BuildRequires:  curl-devel
88 BuildRequires:  dbus-devel
89 BuildRequires:  doxygen
90 %{?with_system_ffmpeg:BuildRequires:    ffmpeg-devel >= 2.4.4}
91 BuildRequires:  flac-devel
92 BuildRequires:  fontconfig-devel
93 BuildRequires:  freetype-devel
94 BuildRequires:  fribidi-devel
95 BuildRequires:  gawk
96 BuildRequires:  gettext-autopoint
97 BuildRequires:  gettext-tools
98 BuildRequires:  giflib-devel
99 BuildRequires:  glew-devel
100 BuildRequires:  gperf
101 BuildRequires:  jasper-devel
102 BuildRequires:  jre
103 BuildRequires:  libass-devel
104 BuildRequires:  libbluray-devel >= 0.2.1
105 BuildRequires:  libcap-devel
106 BuildRequires:  libcdio-devel
107 %{?with_libcec:BuildRequires:   libcec-devel}
108 %{?with_system_dvdread:BuildRequires:   libdvdread-devel}
109 %ifarch i686 pentium4 athlon %{x8664}
110 BuildRequires:  libcrystalhd-devel
111 %endif
112 BuildRequires:  libgcrypt-devel
113 BuildRequires:  libjpeg-devel
114 BuildRequires:  libltdl-devel
115 BuildRequires:  libmad-devel
116 BuildRequires:  libmicrohttpd-devel
117 BuildRequires:  libmodplug-devel
118 BuildRequires:  libmpeg2-devel
119 BuildRequires:  libogg-devel
120 BuildRequires:  libplist-devel
121 BuildRequires:  libpng-devel
122 BuildRequires:  librtmp-devel
123 BuildRequires:  libsamplerate-devel
124 BuildRequires:  libsmbclient-devel
125 BuildRequires:  libssh-devel
126 BuildRequires:  libtiff-devel
127 BuildRequires:  libtool
128 BuildRequires:  libva-devel
129 BuildRequires:  libva-glx-devel
130 BuildRequires:  libvdpau-devel
131 BuildRequires:  libvorbis-devel
132 BuildRequires:  libxslt-devel
133 BuildRequires:  lzo-devel
134 BuildRequires:  mysql-devel
135 %ifarch %{ix86}
136 BuildRequires:  nasm
137 %endif
138 BuildRequires:  openssl-devel
139 BuildRequires:  pcre-cxx-devel
140 BuildRequires:  pkgconfig
141 BuildRequires:  pulseaudio-devel
142 BuildRequires:  python-devel >= 2.4
143 BuildRequires:  rpm-pythonprov
144 BuildRequires:  rpmbuild(macros) >= 1.566
145 BuildRequires:  sed >= 4.0
146 BuildRequires:  sqlite3-devel
147 BuildRequires:  swig
148 BuildRequires:  taglib-devel >= 1.8
149 BuildRequires:  tinyxml-devel
150 BuildRequires:  udev-devel
151 BuildRequires:  unzip
152 BuildRequires:  xorg-lib-libX11-devel
153 BuildRequires:  xorg-lib-libXext-devel
154 BuildRequires:  xorg-lib-libXinerama-devel
155 BuildRequires:  xorg-lib-libXmu-devel
156 BuildRequires:  xorg-lib-libXrandr-devel
157 BuildRequires:  xorg-lib-libXt-devel
158 BuildRequires:  xorg-lib-libXtst-devel
159 BuildRequires:  yajl-devel
160 BuildRequires:  yasm
161 BuildRequires:  zip
162 BuildRequires:  zlib-devel
163 # kodi uses it's own, modified squish
164 BuildConflicts: squish-devel
165 #https://github.com/sahlberg/libnfs
166 BuildRequires:  libnfs-devel
167 #http://sites.google.com/site/alexthepuffin/home
168 #BuildRequires: afpfs-ng-devel
169 #http://mirrors.xbmc.org/build-deps/darwin-libs/libshairport-1.2.0.20310_lib.tar.gz
170 #https://github.com/albertz/shairport
171 #BuildRequires: libshairport
172 Requires:       /usr/bin/glxinfo
173 Requires:       SDL >= 1.2.14-5
174 Requires:       lsb-release
175 Requires:       xorg-app-xdpyinfo
176 # dlopened libraries:
177 # grep 'DLL_PATH_.*lib.*\.so' xbmc/DllPaths_generated.h | grep -v special://
178 Requires:       curl-libs
179 Requires:       libass
180 Requires:       libbluray
181 Requires:       libmodplug
182 Requires:       libmpeg2-libs
183 Requires:       libogg
184 Requires:       libplist
185 Requires:       libvorbis
186 Obsoletes:      xbmc < 14.0
187 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
188
189 %description
190 Kodi Entertainment Center (formerly XBMC) is a free and open-source
191 media player software developed by the XBMC Foundation, a non-profit
192 technology consortium. Kodi is available for multiple operating
193 systems and hardware platforms, with a software 10-foot user interface
194 for use with televisions and remote controls. It allows users to play
195 and view most videos, music, such as podcasts from the internet, and
196 all common digital media files from local and network storage media.
197
198 %prep
199 %setup -q -n xbmc-%{version}-%{codename}
200 %patch0 -p1
201 %patch1 -p1
202 %{?with_system_dvdread:%patch2 -p1}
203 #%patch4 -p1
204
205 rm -r lib/cximage-6.0/zlib
206 #rm -r lib/libhdhomerun
207 rm -r lib/libmpeg2
208 rm -r xbmc/cores/dvdplayer/DVDCodecs/Video/libmpeg2
209 rm -r lib/libbluray
210 rm -r lib/librtmp
211 rm -r lib/win32
212 %{?with_system_dvdread:rm -r lib/libdvd/libdvdread}
213
214 %if %{without system_ffmpeg}
215 #ln -s %{SOURCE1} tools/depends/target/ffmpeg/ffmpeg-2.4.4-%{codename}.tar.gz
216 %endif
217
218 %build
219 %{__make} -C tools/depends/native/libsquish-native \
220         CXX="%{__cxx}"
221
222 ./bootstrap
223 %configure \
224         ac_cv_type__Bool=yes \
225         --disable-silent-rules \
226         --disable-debug \
227         --disable-ccache \
228         --with-ffmpeg=%{!?with_system_ffmpeg:force}%{?with_system_ffmpeg:shared} \
229         %{__enable_disable afpclient} \
230         %{__enable_disable airplay} \
231         %{__enable_disable airtunes} \
232         %{__enable_disable alsa} \
233         %{__enable_disable asap_codec asap-codec} \
234         %{__enable_disable avahi} \
235         %{__enable_disable dbus} \
236         %{__enable_disable dvdcss} \
237         %{__enable_disable fishbmc} \
238         %{__enable_disable gles} \
239         %{__enable_disable gl} \
240         %{__enable_disable goom} \
241         %{__enable_disable gtest} \
242         %{__enable_disable joystick} \
243         %{__enable_disable libbluray} \
244         %{__enable_disable libcap} \
245         %{__enable_disable libcec} \
246         %{__enable_disable libusb} \
247         %{__enable_disable mdnsembedded} \
248         %{__enable_disable mid} \
249         %{__enable_disable mysql} \
250         %{__enable_disable nfs} \
251         %{__enable_disable non_free non-free} \
252         %{__enable_disable openmax} \
253         %{__enable_disable optical_drive optical-drive} \
254         %{__enable_disable profiling} \
255         %{__enable_disable projectm} \
256         %{__enable_disable pulse} \
257         %{__enable_disable rsxs} \
258         %{__enable_disable rtmp} \
259         %{__enable_disable samba} \
260         %{__enable_disable sdl} \
261         %{__enable_disable spectrum} \
262         %{__enable_disable ssh} \
263         %{__enable_disable tegra} \
264         %{__enable_disable texturepacker} \
265         %{__enable_disable udev} \
266         %{__enable_disable upnp} \
267         %{__enable_disable vaapi} \
268         %{__enable_disable vdpau} \
269         %{__enable_disable vtbdecoder} \
270         %{__enable_disable waveform} \
271         %{__enable_disable wayland} \
272         %{__enable_disable webserver} \
273         %{__enable_disable x11} \
274         %{__enable_disable xrandr} \
275         %{nil}
276
277 %{__make} V=1
278
279 %install
280 rm -rf $RPM_BUILD_ROOT
281 %{__make} install \
282         DESTDIR=$RPM_BUILD_ROOT
283
284 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/%{name}
285
286 # no -devel package yet
287 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/kodi
288 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/xbmc
289
290 # no real use for symlinks to datadir, and make rpm packaging more difficult (symlink vs dir issues)
291 %{__rm} $RPM_BUILD_ROOT%{_libdir}/xbmc
292 %{__rm} $RPM_BUILD_ROOT%{_datadir}/xbmc
293
294 %clean
295 rm -rf $RPM_BUILD_ROOT
296
297 %files
298 %defattr(644,root,root,755)
299 %doc README.md docs/README.linux
300 %attr(755,root,root) %{_bindir}/kodi
301 %attr(755,root,root) %{_bindir}/kodi-standalone
302 %{_datadir}/%{name}
303 %attr(755,root,root) %{_libdir}/%{name}
304 %{_desktopdir}/kodi.desktop
305 %{_iconsdir}/hicolor/*/apps/%{name}.png
306 %{_datadir}/xsessions/kodi.desktop
307
308 # legacy xbmc compatibility links
309 %attr(755,root,root) %{_bindir}/xbmc
310 %attr(755,root,root) %{_bindir}/xbmc-standalone
311 %{_datadir}/xsessions/xbmc.desktop
This page took 0.081191 seconds and 4 git commands to generate.