]> git.pld-linux.org Git - packages/kmplayer.git/blob - kmplayer.spec
- downgraded to 0.9.2; this release actually builds
[packages/kmplayer.git] / kmplayer.spec
1
2 %bcond_without  gstreamer       # Do not build kgstplayer
3 %bcond_with     koffice         # Build koffice plugin
4 %bcond_without  xine            # Do not build kxineplayer
5
6 Summary:        A KDE MPlayer/Xine/ffmpeg/ffserver/VDR frontend
7 Summary(pl):    Frontend dla programów MPlayer/Xine/ffmpeg/ffserver/VDR pod KDE
8 Name:           kmplayer
9 Version:        0.9.2
10 Release:        1
11 Epoch:          2
12 License:        GPL
13 Group:          X11/Applications/Multimedia
14 Source0:        http://kmplayer.kde.org/pkgs/%{name}-%{version}.tar.bz2
15 # Source0-md5:  23020ec5425226953452bd46fa59337e
16 #Patch0:                %{name}-mimetypes.patch
17 URL:            http://kmplayer.kde.org/
18 BuildRequires:  arts-qt-devel
19 BuildRequires:  artsc-devel
20 BuildRequires:  automake
21 BuildRequires:  gettext-devel
22 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-devel >= 0.8.6}
23 BuildRequires:  kdelibs-devel >= 9:3.1.92
24 %{?with_koffice:BuildRequires:  koffice-devel}
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpmbuild(macros) >= 1.129
27 BuildRequires:  sed >= 4.0
28 #BuildRequires: unsermake
29 %{?with_xine:BuildRequires:     xine-lib-devel >= 1:1.0}
30 Requires:       kdebase-core >= 9:3.1.90
31 Requires:       kdelibs >= 9:3.4.0-4
32 Requires:       mplayer
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 A powerful, fully integrated with KDE MPlayer/Xine/ffmpeg/ffserver/VDR
37 GUI.
38
39 %description -l pl
40 W pe³ni zintegrowany z KDE frontend dla programów
41 MPlayer/Xine/ffmpeg/ffserver/VDR.
42
43 %package gstreamer
44 Summary:        Gstreamer wrapper
45 Summary(pl):    Wrapper gstreamera
46 Group:          X11/Applications/Multimedia
47 Requires:       %{name} = %{epoch}:%{version}-%{release}
48
49 %description gstreamer
50 Gstreamer wrapper.
51
52 %description gstreamer -l pl
53 Wrapper gstreamera.
54
55 %package koffice
56 Summary:        Kmplayer integration with Koffice
57 Summary(pl):    Integracja kmplayera z koffice
58 Group:          X11/Applications/Multimedia
59 Requires:       %{name} = %{epoch}:%{version}-%{release}
60 Requires:       koffice-common
61
62 %description koffice
63 Kmplayer integration with Koffice.
64
65 %description koffice -l pl
66 Integracja kmplayera z koffice.
67
68 %package xine
69 Summary:        Xine wrapper
70 Summary(pl):    Wrapper xine
71 Group:          X11/Applications/Multimedia
72 Requires:       %{name} = %{epoch}:%{version}-%{release}
73
74 %description xine
75 Xine wrapper.
76
77 %description xine -l pl
78 Wrapper xine.
79
80 %prep
81 %setup -q
82
83 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
84         src/kmplayer.desktop \
85
86 #%patch0 -p1
87
88 %build
89 cp /usr/share/automake/config.sub admin
90
91 #%{__make} -f admin/Makefile.common cvs
92
93 %configure \
94         --disable-rpath \
95         --enable-final \
96         %{?with_koffice:--enable-koffice-plugin} \
97         %{!?with_gstreamer:--without-gstreamer} \
98         %{!?with_xine:--without-xine} \
99         --with-qt-libraries=%{_libdir}
100
101 %{__make}
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT \
108         kde_htmldir=%{_kdedocdir}
109
110 # remove bogus translation
111 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
112
113 # already in kdelibs
114 rm $RPM_BUILD_ROOT%{_datadir}/mimelnk/application/x-mplayer2.desktop
115
116 %find_lang %{name} --with-kde
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files -f %{name}.lang
122 %defattr(644,root,root,755)
123 %doc AUTHORS ChangeLog README
124 %attr(755,root,root) %{_bindir}/kmplayer
125 %attr(755,root,root) %{_bindir}/kxvplayer
126 %{_libdir}/libkdeinit_kmplayer.la
127 %attr(755,root,root) %{_libdir}/libkdeinit_kmplayer.so
128 %{_libdir}/libkmplayercommon.la
129 %attr(755,root,root) %{_libdir}/libkmplayercommon.so
130 %{_libdir}/kde3/kmplayer.la
131 %attr(755,root,root) %{_libdir}/kde3/kmplayer.so
132 %{_libdir}/kde3/libkmplayerpart.la
133 %attr(755,root,root) %{_libdir}/kde3/libkmplayerpart.so
134 %{_datadir}/apps/kmplayer
135 %{_datadir}/config/kmplayerrc
136 %{_datadir}/mimelnk/application/x-kmplayer.desktop
137 %{_datadir}/mimelnk/video/x-ms-wmp.desktop
138 %{_datadir}/services/kmplayer_part.desktop
139 %{_desktopdir}/kde/kmplayer.desktop
140 %{_iconsdir}/[!l]*/*/apps/kmplayer.*
141
142 %if %{with gstreamer}
143 %files gstreamer
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/kgstplayer
146 %endif
147
148 %if %{with koffice}
149 %files koffice
150 %defattr(644,root,root,755)
151 %{_libdir}/kde3/libkmplayerkofficepart.la
152 %attr(755,root,root) %{_libdir}/kde3/libkmplayerkofficepart.so
153 %{_datadir}/services/kmplayer_koffice.desktop
154 %endif
155
156 %if %{with xine}
157 %files xine
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/kxineplayer
160 %endif
This page took 0.039665 seconds and 4 git commands to generate.