]> git.pld-linux.org Git - packages/kmplayer.git/blob - kmplayer.spec
db273283f7bd4b0a53be39e4c2a361ab593233c4
[packages/kmplayer.git] / kmplayer.spec
1 #
2 # Conditional build:
3 %bcond_without  gstreamer       # Do not build kgstplayer
4 %bcond_with     koffice         # Build koffice plugin
5 %bcond_without  xine            # Do not build kxineplayer
6 #
7 Summary:        A KDE MPlayer/Xine/ffmpeg/ffserver/VDR frontend
8 Summary(pl.UTF-8):      Frontend dla programów MPlayer/Xine/ffmpeg/ffserver/VDR pod KDE
9 Name:           kmplayer
10 Version:        0.9.3a
11 Release:        2
12 Epoch:          2
13 License:        GPL
14 Group:          X11/Applications/Multimedia
15 # http://kmplayer.kde.org/pkgs/kmplayer-0.9.3-pre1.tar.bz2
16 Source0:        http://kmplayer.kde.org/pkgs/%{name}-%{version}.tar.bz2
17 # Source0-md5:  d18749a254af3d54dd10ce651975527c
18 Patch0:         kde-common-PLD.patch
19 Patch1:         kde-ac260-lt.patch
20 URL:            http://kmplayer.kde.org/
21 BuildRequires:  arts-qt-devel
22 BuildRequires:  artsc-devel
23 BuildRequires:  autoconf
24 BuildRequires:  automake
25 BuildRequires:  gettext-devel
26 %{?with_gstreamer:BuildRequires:        gstreamer-plugins-base-devel >= 0.10.0}
27 BuildRequires:  kdelibs-devel >= 9:3.5.3
28 %{?with_koffice:BuildRequires:  koffice-devel}
29 BuildRequires:  pkgconfig
30 BuildRequires:  rpmbuild(macros) >= 1.129
31 BuildRequires:  sed >= 4.0
32 %{?with_xine:BuildRequires:     xine-lib-devel >= 1:1.0}
33 Requires:       kdebase-core >= 9:3.5.3
34 Requires:       kdelibs >= 9:3.5.3
35 Requires:       mplayer
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 A powerful, fully integrated with KDE MPlayer/Xine/ffmpeg/ffserver/VDR
40 GUI.
41
42 %description -l pl.UTF-8
43 W pełni zintegrowany z KDE frontend dla programów
44 MPlayer/Xine/ffmpeg/ffserver/VDR.
45
46 %package gstreamer
47 Summary:        Gstreamer wrapper
48 Summary(pl.UTF-8):      Wrapper gstreamera
49 Group:          X11/Applications/Multimedia
50 Requires:       %{name} = %{epoch}:%{version}-%{release}
51
52 %description gstreamer
53 Gstreamer wrapper.
54
55 %description gstreamer -l pl.UTF-8
56 Wrapper gstreamera.
57
58 %package koffice
59 Summary:        Kmplayer integration with Koffice
60 Summary(pl.UTF-8):      Integracja kmplayera z koffice
61 Group:          X11/Applications/Multimedia
62 Requires:       %{name} = %{epoch}:%{version}-%{release}
63 Requires:       koffice-common
64
65 %description koffice
66 Kmplayer integration with Koffice.
67
68 %description koffice -l pl.UTF-8
69 Integracja kmplayera z koffice.
70
71 %package xine
72 Summary:        Xine wrapper
73 Summary(pl.UTF-8):      Wrapper xine
74 Group:          X11/Applications/Multimedia
75 Requires:       %{name} = %{epoch}:%{version}-%{release}
76
77 %description xine
78 Xine wrapper.
79
80 %description xine -l pl.UTF-8
81 Wrapper xine.
82
83 %prep
84 %setup -q
85 %patch0 -p1
86 %patch1 -p1
87
88 %{__sed} -i -e 's/Categories=.*/Categories=Qt;KDE;AudioVideo;Player;/' \
89         src/kmplayer.desktop
90
91 %build
92 cp /usr/share/automake/config.sub admin
93
94 %{__make} -f admin/Makefile.common cvs
95
96 %configure \
97         --disable-rpath \
98         --enable-final \
99         %{?with_koffice:--enable-koffice-plugin} \
100         %{!?with_gstreamer:--without-gstreamer} \
101         %{!?with_xine:--without-xine} \
102         --with-qt-libraries=%{_libdir}
103
104 %{__make}
105
106 %install
107 rm -rf $RPM_BUILD_ROOT
108
109 %{__make} install \
110         DESTDIR=$RPM_BUILD_ROOT \
111         kde_htmldir=%{_kdedocdir}
112
113 # remove bogus translation
114 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/xx
115
116 # already in kdelibs
117 rm $RPM_BUILD_ROOT%{_datadir}/mimelnk/application/x-mplayer2.desktop
118
119 %find_lang %{name} --with-kde
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog README
127 %attr(755,root,root) %{_bindir}/kmplayer
128 %attr(755,root,root) %{_bindir}/kxvplayer
129 %{_libdir}/libkdeinit_kmplayer.la
130 %attr(755,root,root) %{_libdir}/libkdeinit_kmplayer.so
131 %{_libdir}/libkmplayercommon.la
132 %attr(755,root,root) %{_libdir}/libkmplayercommon.so
133 %{_libdir}/kde3/kmplayer.la
134 %attr(755,root,root) %{_libdir}/kde3/kmplayer.so
135 %{_libdir}/kde3/libkmplayerpart.la
136 %attr(755,root,root) %{_libdir}/kde3/libkmplayerpart.so
137 %{_datadir}/apps/kmplayer
138 %{_datadir}/config/kmplayerrc
139 %{_datadir}/mimelnk/application/x-kmplayer.desktop
140 %{_datadir}/mimelnk/video/x-ms-wmp.desktop
141 %{_datadir}/services/kmplayer_part.desktop
142 %{_desktopdir}/kde/kmplayer.desktop
143 %{_iconsdir}/[!l]*/*/apps/kmplayer.*
144
145 %if %{with gstreamer}
146 %files gstreamer
147 %defattr(644,root,root,755)
148 %attr(755,root,root) %{_bindir}/kgstplayer
149 %endif
150
151 %if %{with koffice}
152 %files koffice
153 %defattr(644,root,root,755)
154 %{_libdir}/kde3/libkmplayerkofficepart.la
155 %attr(755,root,root) %{_libdir}/kde3/libkmplayerkofficepart.so
156 %{_datadir}/services/kmplayer_koffice.desktop
157 %endif
158
159 %if %{with xine}
160 %files xine
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_bindir}/kxineplayer
163 %endif
This page took 0.089799 seconds and 3 git commands to generate.